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1 What is FastTrack Schedule?

What is FastTrack Schedule?

Click here if you experience problems viewing the help system. 

FastTrack Schedule is a project management application for tracking all your projects, activities,
tasks, resources, to-do lists, and deadlines. 

FastTrack Schedule helps you organize, track, and manage your projects by graphically representing
start and finish dates as bars along a timeline graph. Within project management, this type of schedule
is known as a Gantt chart–named after its creator, Henry Gantt. 

FastTrack Schedule automates the Gantt chart, making it a dynamic timeline. In addition to extensive
graphic capabilities and customizable features, it is also a powerful database. As you draw, resize,
and move bars along the timeline graph, it automatically updates start and finish dates, durations,
dependencies, percent complete values, and costs.

 

To enter an activity you can draw a bar directly on the timeline graph and have FastTrack Schedule
enter the duration and dates for you, or you can enter the duration or the dates in columns and have
FastTrack Schedule draw the bar for you.

In fact, everything you can do to an activity bar, can be done with your mouse and the tools in
FastTrack ScheduleToolbars or by editing values in columns. This flexibility allows you to concentrate
on the activities you are scheduling, instead of the act of scheduling those activities.

There are three Views in FastTrack Schedule:

The Schedule View 

The Calendar View

The Resource View

Each view offers a specific set of functionality, though all Views are interrelated.

See also:

The Tools 

The Bar Styles

The Timeline Range
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2 The FastTrack Schedule Environment

2.1 Views

2.1.1 The Schedule View

The Schedule View

This is the primary View of FastTrack Schedule; all other Views support the Schedule View. It is in this
View that you enter activities; draw activity bars along a timeline; link bars; view critical paths; track
the Scheduled, Revised and Actual dates and times of tasks in your schedule; insert pictures, text
boxes, and legends; and create and view summary graphs.

See also:

The Tools group 

The Resource View 

The Calendar View 
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2.1.2 The Calendar View

The Calendar View

The Calendar View displays information from the Schedule View in the traditional look of a wall
calendar. This allows you to view time vertically rather than horizontally, as you do in the Schedule and
Resource Views. You can view and print completely customizable calendars that can be filtered to
display only those activities you want to see. You can also create a calendar of any number of
contiguous weeks.

In the Calendar View you can draw bars; move bars; hide bars; filter activities – to view only those bars
you want to see; edit Scheduled, Revised and Actual dates and times; apply ranges and FastSteps;
and print the calendar in current, monthly, and custom configurations.

 

See also:

The Schedule View 

The Resource View 
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2.1.3 The Resource View

The Resource View

In this View you track and manage the use of resources in your project. You can see exactly to which
tasks your resources are assigned, what percentage of their total available time is being used, and how
many hours they are working in a given unit of time.

In this View, you can create resources, move bars in the timeline, and change the Scheduled, Revised
and Actual dates of tasks. Until you assign the resources you have created to a task in the Schedule
View, no bars will appear in the Resource View.

 

The Resource View allows you to track many resources in one window with colorful and dynamic bar
graphs. You can collapse and expand the subrows to display only the information you need to see.
You can easily determine when a resource has been over allocated or when it is available to be
assigned more hours. You can also spot allocate resources.

See also:

The Schedule View 

The Calendar View 
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2.2 Action Columns

2.2.1 Action Columns

Action Columns

FastTrack ScheduleAction Columns simplify working with activities and resources. The Action
Columns can be displayed to the left of the columns in the Schedule and Resource Views. They
simplify operations performed on rows, subrows, and outline levels.

Row Number/Select Row

Clicking here selects the row for moving, deleting, copying, cutting, formatting, and hiding.

 Page Break 

Clicking here makes the corresponding row the last row on a printed page.

Information Form

Clicking here opens the Information form in the Schedule View and the Resource Information form in
the Resource View.

 Expand/Collapse

Clicking here collapses and expands outline levels in the Schedule View and subrows in the Resource
View.

2.3 Toolbars

2.3.1 The Tools

The Tools
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FastTrack Schedule’s Tools group holds six tools. Unless a tool is locked, the default setting for each

tool is to revert back to the Arrow tool after use. When locked, the selected tool is locked down and can

be used multiple times.

 Arrow tool 

The general-purpose tool that selects, moves, and resizes items in all Views. When you want to drag
an activity bar, row, column or graphic item this is the tool you need to have selected.

 Bar Tool 

The Bar Tool draws activity bars in the timeline graph with a default Constrain Type of "Start On Or
After."

 Link Bars Tool 

Lets you draw links between bars to create dependencies.

 Revise Tool 

Changes the activity's Revised start and/or finish dates, times, and durations.

 % Complete Tool 

Defines the percent complete and Actual start, finish, and duration of an activity.

 Text Tool

Draws and edits text boxes for use as labels and titles.

Note:

Selecting a tool changes the appearance and purpose of the mouse cursor. Each tool has its own

operations and, while a tool is selected, clicking and dragging the mouse performs those operations.
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See also:

The Schedule View 

The Resource View

The Calendar View

The Bar Style group

The View group

The Timeline Range

2.3.2 The Bar Styles group

The Bar Styles Group
The cells of the Bar Styles group contain the bar styles defined for the schedule. You can use the Bar

Styles group to change the bar style applied to an activity, or, by clicking the dialog launcher, open the

Format Bar Styles dialog where you can design a new bar style or edit an existing bar style. 

Note:

When you select a new bar style new bars will be drawn in that style and, if an activity bar in the

timeline graph is selected when you choose a new bar style, that bar changes to the newly selected bar

style.

See also:
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The Schedule View 

The Resource View

The Calendar View

The Tools group

The View group

The Timeline Range

2.3.3 The Views group

The Views Group
There are three Views in FastTrack Schedule: the Schedule View, Calendar View, and Resource View.

The Views group, which is visible on every tab, allows you to switch from one View to another, instantly.

See also:

The Schedule View 

The Resource View

The Calendar View

The Tools group

The Bar Style group

The Timeline Range

2.3.4 The Timeline Range

The Timeline Range
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The Schedule, Resource, and Calendar Views can each show a different span, or range, of dates. The

Timeline Range gives you immediate access to the Start and Finish dates of the timeline in the

Schedule and Resource Views, and the calendar in the Calendar View. 

The dates you set in the Timeline Range affect only the View you are looking at and always correspond

to the Start and Finish dates displayed in the respective Format Schedule, Resource, or Calendar View

dialogs.

You can also use :

Go To Bar to take you to the first bar in a selected row. From the Home tab, on the Edit group, click Go

To and select Bar.

All Bars Range to display the timeline in a range that encompasses every bar. From the Project tab, on

the Timeline group, click All Bars Range.

Timeline Units to quickly change the units in which the timeline displays. From the Project tab, on the

Timeline group, click Timeline Units.

See also:

The Schedule View 

The Resource View

The Calendar View

The Tools group
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The Bar Style group

The View group

3 Schedule Files

3.1 Effort Driven and Fixed Duration Scheduling

Effort Driven and Fixed Duration Scheduling
There are three values considered in the scheduling of an activity: 1) the duration of the activity, 2) the
percentage of resource effort (be it human, equipment, material, etc.) assigned to an activity and 3) the
total work - which is initially derived by multiplying the Duration by the Percent Effort or can be entered
by the user.

When a task is Effort Driven, FastTrack Schedule keeps the total work constant. Changes to resource
assignments, and thus percentage of effort, impact the duration of the activity and not the total work.

Effort Driven scheduling truly begins when you assign additional resources to an activity. At the initial
creation, every activity has some value as its total work. Even if you don't explicitly assign a resource at
the time of the activity bar's creation, a default value of 1 unit of 100% effort is implicit to the task. When
you do explicitly assign that first resource, it simply puts a name to the resource giving that initial default
100% effort. When you begin assigning additional resources, the bar’s Duration is affected as you share
the effort while keeping the total work being done on that activity constant.

You can also tag an activity as Fixed Duration. You do this in the Bars tab of an activity's Information
form. Activity's designated as Fixed Duration, will keep their Duration unchanged, unless the activity is
Effort Driven, in which case, when assignments are changed, the Fixed Duration nature is overridden in
order to keep the activity's total work constant.

If you de-select the Apply Effort Driven Scheduling option in the Bars>Assignments tab of an activity's
Information form, the Duration will be kept constant.

You can determine the default setting for all three activity values in the Project tab of the Document
Options dialog, and you can change scheduling settings to all bars in the General tab of the Document
Options dialog.

See also:
Setting Project options
Assigning resources to bars
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3.2 Opening a schedule

Opening a schedule 
You can either open a new schedule or retrieve a schedule that has already been created. You can also

open a schedule template that allows you to build a schedule that is initially based on an existing

schedule. You select the schedule to use as a template, decide what information you want to keep for

the new schedule, and then generate the new schedule.

To open a new schedule:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, then click New.

    The Getting Started dialog opens.

2. Select New Schedule.

To open an existing schedule:

1.  Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, then click Open.

    The Open dialog opens.

2. Navigate to the location of the schedule you want to open and select it.

3. Click Open.

To open a schedule template:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, then click New.

    The Getting Started dialog opens.

2. Select New Schedule from Template.
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The Templates and Examples dialog opens.

3. Choose an application-defined template from the table or click the Browse button to locate a
FastTrack Schedule file on disk.

    The Open Template Options dialog opens.

4. From the drop-down list at the top of the dialog, select from the data options. 

    Keep Everything is the default option, but in the same drop-down list you can select Keep the
Following Data or Remove all Data which opens a completely blank schedule whose columns mirror
the schedule you used as a      template. 

5. If you have selected to Keep the Following Data, decide which elements of that schedule you want
to keep by selecting and/or clearing options from the Schedule, Resource, and Calendar tabs.

    Only data (not formatting) will appear in the new file.

6. Click OK to apply your changes and close the Open Template Options dialog.

Note:

Schedules built with version 8.0 or later can easily be converted to a later version of FastTrack Schedule.

If you have a schedule built with an earlier version, please contact technical support.

See also:

Converting files between Windows and Mac 

Saving a schedule

3.3 Saving a schedule

Saving a schedule
Saving a schedule copies to the disk all of the changes you have made to the file.

To save a file:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, then click Save.

If this is a new, unsaved schedule, you are asked to name the file and choose the location where it
will be stored.
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Don’t forget to enter data into the Properties dialog.

To save the file with a new name and/or location:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, then click Save As.

2. Select Save As to save the active file with a new name or in a new location, or select Save As

Template to save the file as a template which can be re-opened to create a similar file.

See also:

Converting files between Windows and Mac 

3.4 Converting files between Windows and Macintosh

Converting Macintosh Files to Windows Files
Converting a file means you can open, use, and save a file built in FastTrack Schedule for Mac® on a

machine running FastTrack Schedule for Windows® or vice versa.

Important:

Before you convert a schedule to another platform, be sure to save a copy of it with another name to

your hard drive. When you open schedules across platforms (Windows to Mac or vice versa), graphics

and OLE objects will be lost.

To convert a Macintosh file to a Windows file:

1. In the Windows version of FastTrack Schedule, click the Application Button which is the graphic 

 at the top left of the FastTrack Schedule window to open the Application menu, then select Open.

    The Open dialog opens.

2. Select the name of the file to be converted.



FastTrack Schedule 10 User Manual28

Copyright © 2010, AEC Software, Inc. All rights reserved.

3. Click Open.

4. With the converted file open, click the Application Button which is the graphic  at the top left of
the FastTrack Schedule window to open the Application menu, then select Save As.

5. Enter a new name and/or location for the file and click OK.

    This saves the schedule in a new name or location, converting it to the current platform. Entering a
new name and/or location preserves the original file in its native format.

To convert a Windows file to a Macintosh file:

1. In the Macintosh version of FastTrack Schedule, select Open from the File menu.

    The Open dialog opens.

2. Select the name of the file to be converted.

3. Click Open.

4. With the converted file open, from the File menu, select Save As.

5. Enter a new name and/or location for the file and click OK.

    This saves the schedule in a new name or location, converting it to the current platform. Entering a
new name and/or location preserves the original file in its native format.

Notes:

- For a schedule built with the Mac version of FastTrack Schedule, the Mac file must be saved with the ".
fts" extension, for example "schedule.fts."
- Because of differences in the fonts available for Windows and Mac, some text may appear differently
across platforms. FastTrack Schedule assigns fonts the best match possible.

See also:

Opening a schedule 

Saving a schedule

3.5 Converting schedules from previous versions

Converting schedules built with a previous version
Schedules built with FastTrack Schedule version 8 or later can be easily converted to a later version.

Schedules that were built with versions of FastTrack Schedule earlier than version 8 cannot be directly

converted; contact AEC Software Technical Support for assistance.
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The list below shows you which versions of FastTrack Schedule will open and convert schedules created

in other versions of FastTrack Schedule.

Schedules created using:

FastTrack Schedule Mac or Windows version 8 – can be opened on both Mac and Windows versions 8,
9 and 10
FastTrack Schedule Mac or Windows version 9 – can be opened on both Mac and Windows version 9
and 10
FastTrack Schedule Mac or Windows version 10 – can be opened on both Mac and Windows version 10

To convert an existing schedule:

1. Launch FastTrack Schedule 10.

2. In FastTrack Schedule 10, click the Application Button which is the graphic  at the top left of
the FastTrack Schedule window to open the Application menu, then click Open.

3. Open the file that you wish to convert to Version 10.

4. To convert the file to Version 10, select Save As from the Application menu and save the file under a
new name or in a new location.

This preserves the original for your archives. After a schedule is converted, it can no longer be opened in

the older version of FastTrack Schedule.

If you are attempting to convert a file before version 8, FastTrack Schedule will display an alert that the

file was created with a version of the application whose files are no longer supported. Click OK and call

AEC Software Technical Support.

Important:

If you do not have FastTrack Schedule Version 8 or later, please call AEC Software Technical Support at

(703) 450-2318 or email support@aecsoftware.com.
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3.6 Dragging and dropping files

Dragging and dropping files
You can automatically open dropped FastTrack Schedule files by dragging them into the open

application window. You can also paste the full path name of any application’s file into a column’s cell or

a text box. 

To drag and drop a FastTrack Schedule file:

1. Select a FastTrack Schedule file from outside the application and, holding down the mouse button,
position the cursor in the FastTrack Schedule application window, and then release the mouse button.

    This opens the dropped schedule file in FastTrack Schedule and shows the View in which that file
was last saved. 

To drag and drop a file name:

1. Select a file and, holding down the mouse button, position the cursor over a cell of a column that
supports text data or in a text box in the timeline, and then release the mouse button.

    If you have dropped a file, this pastes the full file name and path into the cell or text box over which
the cursor is positioned. For example, if you dropped a file called ‘letter’ from Microsoft Word, it would
paste ‘letter.doc' into the column cell.

Note:

See the instructions provided with your operating system for more information on dragging and dropping

files.

3.7 Using context menus

Using context menus
A context menu is the pop-up menu that appears when you click an item with the second, or right,

mouse button. This pop-up menu contains a list of context-specific shortcuts or operations that you can

perform on the item. 
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It is always a good idea to right-click an item to see what context menu options are available.

See also:

Keyboard shortcuts 

3.8 Navigating in the Views

Navigating in the Views
There are various methods for moving your cursor within the columns of the Schedule View or Resource

View. You can always use your mouse to click in a cell. To move your cursor a column to the right or

left you can use the Right and Left Arrow keys on your keyboard. You can also use the Tab key to move

right, but be sure that your cursor is to the right of any text in the Activity Name column. Pressing the

Tab key if the cursor is on the left will move that activity out one activity outline level. 

To move up or down a row, you can use the Up or Down Arrow keys on your keyboard. For all columns,

except those that contain text stored by row (such as the Activity Name column), you can press the

Enter/Return key to move your cursor down a row. Pressing the Return key in a column formatted to

save data by row will take you to the next line in that cell. 

3.9 Using the Project Information form

Using the Project Information form
The Project Information form is where you set the project work calendar, define the project’s start date

and time and view the finish date and time. The Project Finish Date is defined by the latest activity bar’s

finish date and time.
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The "project" is a subset of the data in your schedule determined by your definition of the Start Date.

Thus, there can be data scheduled before the Project Start date.

To set the Project Calendar:

1. From the Calendar drop-down list, select Standard (8 AM - 5 PM Monday-Friday), 24 Hour or Night
Shift, or the name of a custom work calendar you have created.

    Individual activities and resources can have there own work calendars.

To define the Project Start Date:

1. On the Project tab, in the Details group, click Project Information, and choose Define from the choice list.

    The Project Information dialog opens.

2. Use the controls to set the Project Start Date and Time.

3. Click OK to close the form.

    The Project Start Date dateline will now display as a vertical line in the timeline on the date and time
you have specified.

See also:

Formatting datelines 

3.10 Using the ExpressDate pop-up calendar

Using the ExpressDate pop-up calendar
The ExpressDate™  pop-up calendar allows you to enter a time quickly with a series of mouse clicks.

When you click in any date column a button appears in the cell that gives you one-click access to the

pop-up calendar.

To open the ExpressDate calendar:

1. Click in one of the cells of a column that you or the application have defined to have a date value (e.
g. Start Date, Finish Date, etc.). 

    A button will appear in the top right corner of the cell.

2. Click the button to open the ExpressDate calendar.
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    -or-

    Use the ExpressDate keyboard shortcut, Control + 9

    -or-

    Right-click in a column cell and select ExpressDate Calendar from the context menu.

To close ExpressDate without making a selection:

1. Click the Cancel button.

    -or-

    Press the Escape key.

To select a value from the ExpressDate calendar:

1. Click the top set of arrows to move backward or forward in months.

2. Click the bottom set of arrows to move forward or back in years.

    The dialog displays the calendar for that month and year.

3. Click on a day in the calendar. 

4. Click OK to enter the date or click Cancel to close the calendar without entering the date.

Notes:

- The ExpressDate only opens in column cells that are formatted to contain date data or plain text.
ExpressDate opens with the cell’s existing date value displayed. If there is no value in the cell, 
- ExpressDate opens with the current date displayed.

See also:

Using the pop-up clock 

3.11 Using the ExpressTime pop-up clock

Using the ExpressTime™ pop-up clock
The ExpressTime™ pop-up clock allows you to enter a time quickly with a series of mouse clicks.
When you click in any time columns a button appears in the cell that gives you one-click access to the
pop-up clock.

To open the ExpressTime clock:

1. Click in one of the cells of a column that you or the application have defined to have a time value (e.
g. Start Time, Finish Time, etc.). 

    A button will appear in the top right corner of the cell. 
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2. Click the button to open the ExpressTime™ clock. 

    -or-

    Use the ExpressTime keyboard shortcut, Control + 0 (zero)

    -or-

    Right-click the column cell and select ExpressTime Clock from the context menu.

To close ExpressTime without making a selection:
1. Click Cancel.

    -or-

    Press the Escape key.

To select a value from ExpressTime clock:

1. Use the hour and minute drop-down lists to select numerical values.

    -or-

    Use the back and forward buttons to change the time in one-minute increments.

    -or-

    Click and drag the hands of the clock until it shows the desired time.

2. In 12-hour mode, select AM, PM, or Mid (midnight) from the drop-down list.

3. Click OK to enter the time indicated in the ExpressTime pop-up clock window into the appropriate
cell.

    -or-

    Click Cancel to close the ExpressTime clock without entering a time.

Notes:

- The ExpressTime clock only opens in column cells that are formatted to contain time data or plain text.
- ExpressTime opens with the cell’s existing time value displayed. If there is no value in the cell,
ExpressTime opens with the current time displayed.
- The default format for hours in the clock, and throughout the application, is set in the Times tab of the
Application Options dialog .

See also:

Adding presets

Using the pop up calendar

3.12 Going to today

Going to today
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This command scrolls the Schedule, Calendar or Resource View to display the current day, as defined

by your operating system. 

To scroll to today:
1. On the Home tab, in the Editing group, click Go To and choose Today from the drop-down list.

See also:

Going to bar

Going to row number

3.13 Defining font attributes for a selected item

Defining font attributes for a selected item 
Most elements of, or items in, a schedule can be selected. Once something is selected you can define

the font attributes of that individual value, heading, text box, cell, etc.

To define font attributes for a selected item:

1. Using the Arrow tool, select an element of the schedule.

2. On the Home tab, in the Font group, use the options to format the selected items' font.

    -or-

1. Right-click the item and choose Font from the context menu.

2. Use the options in the Font dialog to format the item's font.

See also:

Setting preferences
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3.14 Checking for spelling errors

Checking for spelling errors
FastTrack Schedule allows you to check for spelling errors in visible columns, text boxes, or within each

View.

To check for spelling errors:

1. On the Tools tab, in the Proofing group, click the icon at the top of the group to check text in the
entire schedule.

    -or-

   On the Tools tab, in the Proofing group, click the word Spelling and choose Check All, Check
Columns, Check Text Boxes, or Check Selected Text – whichever fits your needs.

   The Spelling dialog opens with the first unrecognized word displayed in the Not in Dictionary box.

2. Select from the options described below.
 

This Option: Does This:

Ignore Leaves the word in the Not in Dictionary box unchanged in

the schedule.

Ignore All Leaves every occurrence of the word in the Not in Dictionary

box unchanged.

Change Replaces the word in the Not in Dictionary box with the

selected word in the Change To box.

Change All Replaces every occurrence of the word in the Not in

Dictionary box with the selected word in the Change To

box.
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Add Adds the word in the Not in Dictionary box to the User

Dictionary so that it will not be selected as a misspelled

word in the future.

Suggest Lists possible replacements for the word in the Not in

Dictionary box.

Options Opens the Spelling Options dialog which allows you to

select whether or not to:

-Add or delete words from the User Dictionary. Click a row

in the User Dictionary table to add a word. Select a word

and press the Delete key to delete a word.

-Ignore words in all uppercase lettering.

-Ignore words with unusual capitalization.

-Ignore words with numbers.

-Find two occurrences of the same word in a row.

-Enable the suggestions feature to split words.

-Supply a drop-down list of possible replacements for the

word in the Not in Dictionary box without requiring you to

click the Suggest button.

3. Click Close to close the Spelling dialog.

Notes:

- Only what is visible is spell checked. 
- You can open the Spelling Options dialog anytime by, from the Tools menu, selecting Spelling and
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choosing Spelling Options from the submenu.
- Words that are ignored or added to the User Dictionary are saved by the application per user. They are
applied to all future spell checks in all schedules.

See also:

Saving a schedule

Defining a FastSteps sequence

3.15 Defining find and replace text

Defining find and replace text

You can search for and replace text using the Find/Replace dialog. For instance, you could look for all

occurrences of the word, "Begin" and replace them with "Start." 

To use the Find/Replace dialog:

1. On the Home tab, in the Editing group, click Find.

    The Find/Replace dialog opens.

2. In the Find What box, enter the text for which you want to search.

3. In the Replace With box, enter the text that will replace the selected (Find) text.

4.  From the Find When Cell/Text Box drop-down list, select one of the following.

To find only if: Select:

Part of the cell equals

Find text

Contains

Start of the cell equals Starts With
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Find text

End of the cell equals

Find text

Ends With

Whole cell equals

Find text

Is

5. Select from the checkboxes below.

To do this: Select:

Find if in upper or

lower case

Ignore Case

Find if part of a word Whole Word ( not selected)

Find if standing alone Whole Word (selected)

Continue from the end

of the schedule

Wrap-Around

Search columns Search in Data Cells
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Search selected

column only

Search In Selected Columns Only

Search text boxes Search in Text Boxes

6. Click Find Next to begin the search and close the Find/Replace dialog.

Notes:

- Selected Columns Only is only available when you select a column heading or cell before opening the

dialog.

- Search in Text Boxes is only available when the schedule contains one or more text boxes.

- To replace all occurrences of the Find text without viewing each one, click the Replace All button. This

action cannot be undone. You may want to save the document before selecting Replace All.

3.16 Setting a schedule password

Setting a schedule password
 Assigning a password to a schedule file is used to control the access users have to that schedule.

To assign a password to a file:

1. From the Application menu, select Prepare and choose Restrict Access.

    The Set File Password dialog opens.

2. Select from the options described below.

This Option: Does This:

Password Defines the string of characters for the password. The
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password is case-sensitive and can be a maximum of 12

characters, including spaces and punctuation.

Do Now Allow

Others Any

Access

Users without the password will not be able to open the

schedule in FastTrack Schedule.

Allow Others Read

Only Access

Users without the password will be able to open the

schedule file, but they will not be able to save changes.

Allow Others Read/

Write Access

Users without the password will be able to open the

schedule file and save changes, but they will not be able

to change the password.

3. Click OK to apply your changes and close the Set File Password dialog.

    The Confirm Password dialog appears.

4. Enter the password in the Password box.

5. Click OK to close the Confirm Password dialog.

Notes:

- When a user opens a file with a password assigned to it, they are presented with a dialog requesting
the password. If the file is set to allow read only access, they can open the file by clicking the Open as
Read Only button.
- Security note – data is not encrypted. The password applies only to opening files in FastTrack
Schedule.

See also:

Setting preferences
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3.17 Editing file properties

Editing file properties
The Properties dialog stores metadata, or self-referential data, about a FastTrack schedule file. This

metadata is searchable using various OS level search tools.

Most of the data in the properties dialog is static, but some key data can be entered and edited by the

user.

To edit file properties:

1. From the Application menu, select Prepare and choose Properties to open the Properties dialog.

2. In the Summary tab, enter or edit as much of the requested data as you would like.

Note:

You can determine how much of a file’s property data is exposed by changing the Privacy settings for

the file.

See also:

Setting privacy preferences

3.18 Using XML files with FastTrack Schedule

Using XML files with FastTrack Schedule
When managing projects, it may be helpful to open data from other applications or export data from the

application in which you are working. XML, which stands for Extensible Markup Language, is a text

format designed to simplify the exchange of data between applications and on the Web. 
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There are many benefits to opening and saving files in the .xml extension. In addition to the transfer of

raw data: date and time formats, the work calendar, outline levels, and links are also preserved. XML

does not capture font attributes (for example: font color, font size, bar styles, etc.). 

Microsoft Project 2007 and 2010 recognize the XML file format.

What would you like to do?

 Open an XML file with FastTrack Schedule

 Export a FastTrack Schedule file in XML

See also:

Exporting data as a Microsoft Project XML file 

Importing data

Exporting data

3.19 Using MPX files with FastTrack Schedule

Using MPX with FastTrack Schedule
When managing projects, it may be helpful to open data from other applications or export data from the

application in which you are working. MPX, which stands for Microsoft Project exchange, is an ASCII file

format that automates and simplifies the process of opening data between applications. 

There are many benefits to opening and saving files in the .mpx extension. In addition to the transfer of

raw data: date and time formats, the work calendar, outline levels, and links are also preserved. MPX

does not capture font attributes (for example: font color, font size, bar styles, etc.). 
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Important:

Microsoft Project can only read MPX files. The data will have to be saved as some other file type, XML

for instance.

What would you like to do?

 Open an MPX file in FastTrack Schedule 

 Export FastTrack Schedule as MPX

See also:

Importing data

Exporting data

4 Ranges

4.1 Working with ranges

Working with ranges
Ranges are a saved span of dates. The range can be changed at any time to determine what days you

see in the schedule timeline and the calendar. You can access them easily from either the Timeline

Range group found on the Home tab, or the Timeline group found on the Project tab. Ranges can be

applied to each View or all Views at once.

See also:

Applying a range

Defining a range
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Editing a range

Deleting a range

Duplicating a range

The Master Range

The All Bars Range

4.2 Defining a range

Defining a range
Ranges can be created in the Define Range dialog.

To define a range:

1. On the Project tab, in the Timeline group, click Timeline Ranges, and choose Define from the drop-
down list.

    The Ranges dialog opens.

2. Click New.

3. In the Define Range dialog, enter a name for the range.

    Each range must have a unique name.

4. Set the dates of the range by choosing between today (plus or minus a given number of days), the
current week, the current month, or a custom span of dates.

5. Choose to apply the range to only the Current View or All Views.

6. Click OK to apply your changes and close the Define Range dialog.

7. Click OK to apply your changes and close the Ranges dialog.

    -or-

    Click Close if you do not want to apply the selected range at this time.

    The range is saved for future use.

Note:

Dates entered in the Timeline Range group on the Home tab are temporary and are not saved in the

Ranges dialog until you follow the steps described above to define them as a saved range or Master

Range.
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See also:

Applying a range

Editing a range

Deleting a range

Duplicating a range

The Master Range

The All Bars Range

4.3 Applying a range

Applying a range
When you apply a range, the timeline and/or calendar adjusts to display only the dates defined by the

range.

To apply a range:
1. On the Project tab, in the Timeline group, click Timeline Ranges and choose the desired range from
the drop-down list.

See also:

Defining a range

Editing a range

Deleting a range

Duplicating a range

The Master Range

The All Bars Range
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4.4 Editing a range

Editing a range
Ranges can be adjusted in the Define Range dialog.

To edit a range:

1. On the Project tab, in the Timeline group, click Timeline Ranges and choose Define from the drop-
down list.

    The Ranges dialog opens.

2. Click to select the name of the range you want to edit.

3. Click the Edit button.

4. In the Define Range dialog, use the options to edit the range.

5. Click OK to save your changes and close the Define Range dialog.

6. Click OK to apply your changes and close the Ranges dialog.

    -or-

    Click Close to close the dialog without applying the newly edited range.

    The range will be saved for later use.

See also:

Applying a range

Defining a range

Deleting a range

Duplicating a range

The Master Range

The All Bars Range

4.5 Deleting a range

Deleting a range
Ranges can be deleted in the Ranges dialog.

To delete a range:

1. On the Project tab, in the Timeline group, click Timeline Ranges and choose Define from the drop-
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down list.

    The Ranges dialog opens.

2. Select the range you wish to delete.

3. Click the Delete button.

    A confirmation dialog appears asking you to verify that the range will be deleted.

4. Click OK to delete the range or Cancel to retain the range.

    If you delete the range, it will no longer be available from the Ranges Toolbar or Ranges submenu.

5. Click OK to close the Ranges dialog and apply the currently selected range.

    -or-

    Click Close to close the Ranges dialog without applying a range.

See also:

Applying a range

Defining a range

Editing a range

Duplicating a range

The Master Range

The All Bars Range

4.6 Duplicating a range

Duplicating a range
Ranges can be duplicated in the Ranges dialog.

To duplicate a range:

1. On the Project tab, in the Timeline group, click Timeline Ranges and choose Define from the drop-
down list.

    The Ranges dialog opens.

2. Select the range you wish to duplicate.

3. Click the Duplicate button.

    The Define Range dialog opens.

4. Edit the new range.

5. Click OK to save the new range and close the Define Range dialog.

6. Click OK to close the Ranges dialog and apply the currently selected range.

    -or-

    Click Close to close the Ranges dialog without applying a range.
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See also:

Applying a range

Defining a range

Editing a range

Deleting a range

The Master Range

The All Bars Range

4.7 The MasterRange

The Master Range
The Master Range is designed to give you a quick way to return your file to a user-defined default range.

Each file has a unique Master Range. When you apply the Master Range it is applied to every View in

the current file. It can be changed at any time, in any View, to change the data shown in the schedule

timeline or calendar.

The Master Range is initially set to consist of the dates shown in a file’s Timeline Range when the file is

first opened. Once you explicitly define the Master Range as a specific set of dates, it will remain

defined as those dates until you redefine it. The Master Range is simply a range of dates.

To set the Master Range:

1. On the Project tab, in the Timeline group, click Timeline Ranges and select Set Range from the
drop-down list.

    The Format Schedule View, Format Resource View, or Format Calendar View dialog opens in the
Range tab. 

2. Enter or select the Start and Finish dates.

3. Select the Save Range as the Master Range checkbox.

    -or-

1. On the Project tab, in the Timeline group, click Timeline Ranges and select Define from the drop-
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down list.

    The Ranges dialog opens.

2. Select Master Range from the Ranges table and click Edit.

    The Define Range dialog opens.

3. Enter the start and finish dates you want to define as the Master Range.

4. Click OK to apply your changes and close the Define Range dialog.

5. Click OK to apply the Master Range and close the Ranges dialog.

    -or-

    Click Close if you do not want to apply the Master Range at this time.

    The Master Range setting is saved for future use.

To apply the Master Range:

1. On the Project tab, in the Timeline group, click Timeline Ranges and select Master Range from the
drop-down list.

See also:

Applying a range

Defining a range

Editing a range

Deleting a range

Duplicating a range

The All Bars Range

4.8 The All Bars Range

The All Bars Range
Applying the All Bars Range automatically adjusts the timeline and/or calendar to begin on the Start

Date/Time of the earliest task and end on the Finish Date/Time of the latest task immediately giving you

a view of every bar and milestone in your schedule.

To apply the All Bars Range:

1. On the Project tab, in the Timeline group, click All Bars Range.
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See also:

Applying a range

Defining a range

Editing a range

Deleting a range

Duplicating a range

The Master Range

5 Preferences

5.1 Accessing application preferences

Accessing application options
Setting application preferences defines the general operation; global formatting of dates, times, and

numbers; and the editing, automatic saving, archiving and updating settings of every FastTrack Schedule

file created thereafter.

To access application options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Select one of the following tabs:

General

Dates

Time

Numbers

Editing

Save
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AutoArchive

Update

4. Use the options in the dialog to set your preferences then click OK to close the dialog and apply your

preferences.

Note:

Saving a file as a template keeps both the per-Application and per-Document preference settings of the

original file.

See also:

Setting document preferences 

Setting general preferences

Setting date preferences

Settting time preferences

Settting number preferences

Setting editing preferences

Setting save preferences 

Setting auto-archive preferences 

Setting update preferences 

5.2 Setting general application preferences

Setting general application options
You can choose to set program start, new schedule default, recent file, FastTip and font options.

To set general options:
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1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Click the General tab.

4. Select from the options available.

5. Click OK to close the FastTrack Schedule Options dialog and apply your preferences.

See also:

Document options 

Setting application options

5.3 Setting date preferences

Setting date options
Defines the global format and application-wide use of the three date display styles used in format dialogs

and the general format of the dates used throughout the application.

Important: 

Date options are intended to be used infrequently. They allow you to set up styles you intend to use

later. If you want to change the appearance of individual dates in your schedule, we recommend making

those definitions in that particular date’s format dialog.

To set date options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.
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3. Click the Dates tab.

4. Select from the options described below.

This Option: Does this:

Date Order

mm/dd/yy Formats all dates in the Month/Day/Year order.

dd/mm/yy Formats all dates in the Day/Month/Year order.

yy/mm/dd Formats all dates in the Year/Month/Day order.

Date Format

Short Defines the display of the first format displayed in the format

dialogs.

Mid Defines the display of the second and third formats displayed

in the format dialogs. The Abbrev version in the format

dialogs abbreviates the Day and Month names.

Long Defines the display of the fourth and fifth formats displayed in

the format dialogs. The Abbrev version in the format dialogs

abbreviates the Day and Month names.
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Display

Weekday Defines the display of weekdays.

Month Defines the display of the month.

Day Defines the display of the day of the month.

Year Defines the display of the year.

Separators Allows you to enter any character to act as a separator for

the elements chosen above. For instance, you could enter

slashes (/) for the Short style.

Week Starts on Allows you to determine what day of the week the

application will consider the first day of the week.

5. Click OK to apply your changes and close the dialog.

See also:

Application preferences 

Setting document preferences 
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5.4 Setting time preferences

Setting time options
Defines the global format of the two time display styles used in format dialogs and the general format of

the time used throughout the application.

Important: 

Time options are intended to be used infrequently. They allow you to set up styles you intend to use

later. If you want to change the appearance of individual times in your schedule, we recommend making

those definitions in that particular time’s format dialog.

To change time options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Click the Times tab.

4. Select from the options described below.

This Option: Does This:

Time Format

12 Hour Defines the display of the 12 Hour format.

24 Hour Defines the display of the 24 Hour format.

12 Hours

Display 

Allows you to define the display of the options available in

the format dialogs.
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Hours Defines the hour of a time with or without leading zeroes.

Minutes Defines the minute of a time with or without leading zeroes,

or without this element.

Separators Allows you to enter any character to separate the elements

chosen above and the display of AM, PM, or Midnight.

5. Click OK to apply your changes and close the dialog.

See also:

Application preferences 

Setting document preferences 

5.5 Setting number preferences

Setting number options
Defines the global format of the numbers used in other format dialogs and the general format of numbers

used throughout the application.

To set number options:

1.  Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Click the Numbers tab.

4. Select from the options described below.
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This Option: Does This:

Decimal Point Defines the character used for the decimal point.

Thousands

Separator

Defines the character used between thousands.

List Separator Defines the character used for separating items in a list,

for instance multiple data displayed on a bar.

Reset to System

Default

Defaults to the number preferences set in your operating

system.

5. Click OK to apply your changes and close the dialog.

See also:

Application preferences 

Setting document preferences 

5.6 Setting editing preferences

Setting editing options
Editing options allow you to control the behavior of tools, the resizing of rows, the tracking of items, and
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high-resolution printing options.

To set editing options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Click the Editing tab.

4. Select from the options described below.

This Option: Does this:

Printing Options

Support High Resolution

Printing

Optimizes printing so that hairlines display

correctly in printed pages.

Row Resizing

Action Column Only Allows resizing of row height only in the Action

Columns. This helps avoid accidentally resizing

rows in other columns.

Data and Action Columns Allows resizing of row height in both the Action

Columns and the data columns.

Imported Files Allows you to select whether or not FastTrack will

streamline the appearance of the schedule to show

all data from imported .MPX and .XML files.
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5. Click OK to apply your changes and close the dialog.

See also:

Application preferences 

Setting document preferences

5.7 Setting save preferences

Setting save options
You can choose to automatically save your open FastTrack Schedule file at regularly scheduled

intervals.

To set save options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Click the Save tab.

4. Select from the options available.

5. Click OK to close the FastTrack Schedule Options dialog and apply your preferences.

See also:

Application preferences 

Setting document preferences
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5.8 Setting AutoArchive preferences

Setting AutoArchive options
You can choose to automatically archive your open FastTrack Schedule file by saving a snapshot of

your schedule in a specified location at regular intervals and with incremented naming. For example, you

can choose to append a numerical suffix to the schedule’s title and archive your schedule as Project

Alpha 0001, Project Alpha 0002, Project Alpha 0003, etc.

To set auto-archive options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

3. Click the AutoArchive tab.

4. Select from the options available.

5. Click OK to close the FastTrack Schedule Options dialog and apply your preferences.

Note:

These AutoArchive preferences are set for all of your files, but you must choose to activate the

AutoArchive feature within each file individually. Activate AutoArchiving in the Document Preferences

dialog.

See also:

Application preferences 

Setting document preferences
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5.9 Setting update preferences

Setting update options
You can determine at what, if any, interval you would like FastTrack to check for updates to the open

schedule file whenever a network connection is available.

To set update options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Application Options button at the bottom of the menu.

    The FastTrack Schedule Options dialog opens.

2. Click the Update tab.

3. Select from the options available.

4. Click OK to close the FastTrack Schedule Options dialog and apply your preferences.

See also:

Application preferences 

Setting document preferences

5.10 Accessing document preferences

Accessing document options
Setting document preferences defines the operation and formatting of currency, the behavior of bar and

cursor tracking, the content of QuickLook balloons, and the archiving and privacy settings for the

particular FastTrack Schedule file you are currently working with.

To access document options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.
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    The Document Options dialog opens.

3. Select one of the following tabs:

General

Project

Currency

Tracking

QuickLook

AutoArchive

Privacy

4. Click OK to close the dialog and apply your options.

Note:

Saving a file as a template keeps both the per-Application and per-Document preference settings of the

original file.

See also:

Setting application preferences

5.11 Setting project preferences

Setting project options
You can choose to set the work calendar and bar behavior options for your project.

To set project options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.

3. Click the Project tab.

4. Select from the options described below:
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This Option: Does This:

Calendar Calculations

Hours per day Determines how many work hours there are in a

Standard work calendar's work day. If you want a

work day to last from 9 AM - 5 PM rather than 8

AM - 5 PM, you would need to change the default

setting from 8.00 hours to 7.00 hours, assuming a 1

hour lunch break.

Hours per week Determines how many work hours there are in a

Standard work calendar's typical work week. If your

company considers Saturday a work day, then you

would want to adjust the default Hours per week

total to reflect that.

Days per month Determines how many work days there are in a

Standard work calendar's typical work month.

Lead/Lag Calendars Lets you choose which work calendar the lead/lag

time of linked activities will use to determine a bar's

behavior.

Units
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Duration Units Set the default units of activity durations in this

document.

Work Units Set the default work units in this document.

Defaults

Fixed durations... Sets newly created activity bars to have a set, or

fixed, duration.

Ignore resource... When there is a conflict between the activity's

calendar and the assigned resource's calendar, this

will ignore the resource's calendar and base the

total work possible on the calendar indicated in that

activity's Information form.

Apply effort-driven... When a resource is assigned to an activity, the

activity's duration is determined by the amount of

effort applied to that activity. This is the default

behavior. You can set individual activities to be

"Fixed Duration" by selecting that option in the

activity's Information form.

5. Click OK to close the Document Options dialog and apply your preferences.
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See also:

Document preferences 

Setting application preferences 

5.12 Setting general document preferences

Setting general document options
You can choose to set bar and range behavior in the open document.

To set general options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.

3. Click the General tab.

4. Select from the options described below.

This Option: Does this:

Change Settings on All

Bars

Leave settings on all bars

unchanged

Leaves the Fixed Duration, Effort Driven Scheduling

and Ignore Resource Calendar setting on all bars

unchanged.

Change settings on all Allows you to determine which settings will be
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bars changed and to what new setting they will be

changed when you make a change to all of the bars

in the schedule.

Fixed Duration settings Lets you choose how to change the settings of all

bars currently designated as Fixed Duration. You

can choose to: leave those bars unchanged, make

every bar in the document Fixed Duration, or make

no bars in the document Fixed Duration.

Effort Driven Scheduling

settings

Lets you choose how to change the settings of all

bars to which Effort Driven Scheduling is currently

applied. You can choose to: leave those bars

unchanged, apply Effort Driven Scheduling to every

bar in the document,  or apply Effort Driven

Scheduling to no bars in the document.

Ignore Resource Calendar

settings

Lets you choose how to change the settings of all

bars currently designated to Ignore Resource

Calendars. You can choose to: leave those bars

unchanged, make every bar in the document Ignore

Resource Calendars, or make no bars in the

document Ignore Resource Calendars.
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Restore All

Leave Range unchanged

after Restore All

Leaves the current timeline range unchanged after

using the Restore All option.

Apply Range after

Restore All

Allows you to select a range to be applied after

using the Restore All option.

Apply last range prior to

filtering

Applies the range last selected prior to running the

filter or sort that necessitated use of the Restore All

option. 

Apply All Bars Range Applies the All Bar Range after using the Restore

All option. The All Bar Range shows you a window

of time in the timeline that begins on your earliest

bar's Start Date/Time and ends on your latest bar's

Finish Date/Time.

5. Click OK to close the Document Options dialog and apply your preferences.

See also:

Document preferences 

Setting application preferences 
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5.13 Setting currency preferences

Setting currency options
You can choose to set the currency denominator of the open document to something other than the

application’s default language currency. This is especially helpful when you are working with businesses

in other countries.

To set currency options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.

3. Click the Currency tab.

4. Select from the options available.

5. Click OK to close the Document Options dialog and apply your preferences.

See also:

Document preferences 

Setting application preferences 

5.14 Setting tracking preferences

Setting tracking options
The Tracking tab defines what information is displayed in the Bar Tracking window and Cursor Tracking

area. Bar and Cursor tracking shows you information about the current position of the bar and cursor as

you drag a bar or move the mouse around the timeline or calendar. 

When you hover the cursor over a bar the Bar Tracking window pops up to show start, finish, and
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duration information about the selected activity bar. Cursor Tracking appears in the bottom right of the

application windows and can show the date and time over which the cursor is positioned. Both Bar and

Cursor Tracking help you to draw and drag bars with precision.

To set tracking options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.

3. Click the Tracking tab.

4. Select from the options described below.

This Option: Does This:

Cursor Tracking

Show Cursor

Tracking

Choose whether to display the Cursor Tracking window.

Show Date Displays, in the Cursor Tracking area, the date over which

the cursor is positioned in the timeline graph or the

calendar.

Show Time Displays, in the Cursor Tracking area, the time over which

the cursor is positioned in the timeline graph or the

calendar.

5. Click OK to apply your changes and close the dialog.
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See also:

Document preferences 

Setting application preferences 

5.15 Setting QuickLook preferences

Setting QuickLook options
QuickLook balloons allow you to view important information about activity bars, links, and Calendar View

bars. You simply hover your cursor over a bar or a link and a balloon containing information about that

item appears on your screen.

The key to QuickLook balloons is that they are completely editable. You can decide how much or how

little information to display. 

Currently QuickLook balloons are available for:
- Activity Bars – In the Schedule View and, if assigned, the Resource View
- Links – In the Schedule View
- Calendar View Bars – In the Calendar View (Though these appear the same as bars in the Schedule
View, they have their own QuickLook balloons because additional display options are available in the
Calendar View.)

To view a QuickLook balloon:

1. In the Schedule View, hover your cursor over an activity bar or over a link between bars.

    -or-

    In the Resource View, hover your cursor over an activity bar in the Assignments subrow.

    -or-

    In the Calendar View, hover your cursor over an activity bar.

To edit QuickLook balloons:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.
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    The Document Options dialog opens.

3. Click the QuickLook tab.

4. From the top drop-down list, select the QuickLook you want to modify (bars, calendar bars, or links).

5. Click the Show and Hide buttons to move selections between the Available and Shown table.

    The items in the Shown table display in QuickLook balloons.

6. Click OK to apply your changes and close the dialog.

Note:

Clicking the Hide All button removes every item in the Shown table. Clicking the Reset button returns the

QuickLook settings for the specified item to the application’s default configuration.

See also:

Document preferences 

Setting application preferences 

5.16 Setting document specific AutoArchive preferences

Setting document specific AutoArchive options
You can choose to automatically archive a document and set the location to which the archived

document will be sent.

To set document specific auto-archive options:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.

3. Click the AutoArchive tab.

4. Select from the options available.

5. Click OK to close the Document Options dialog and apply your changes.

Note:
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Additional AutoArchive options are available in the FastTrack Schedule Options dialog.

See also:

Document preferences 

Setting application preferences 

5.17 Setting privacy preferences

Setting privacy options
You can determine how much of the information shown in the Properties dialog will be exposed and thus

searchable.

To set privacy options:

1.  Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.

3. Click the Privacy tab.

4. Select from the options available.

5. Click OK to close the Document Options dialog and apply your changes.

See also:

Document preferences 

Setting application preferences 
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6 The Timeline

6.1 Changing the timeline range

Changing the timeline range
Changing the range of dates in a View allows you to see a different period, or "window," of time in the

timeline or calendar. The timeline runs anywhere from the year 0002 to the year 6000. The timeline can

represent any range of time you determine, in units of hours, days, weeks, months, quarters, and years.

To change the range of dates in the timeline:

1. On the Home tab in the Timeline Range group, enter a date in the Start box and the Finish box to

determine the range of time you will view.

    -or-

    In the Duration box, enter the number of timeline units you would like to appear in the timeline relative

to the Start Date.

Notes:

- You only have to enter a Start Date and Finish Date or a Start Date and Duration.
- Activity bars, items, assigned bars, and usage graphs positioned before or after the timeline range are
not deleted, just not in view. You can still see these items by setting a new range that encompasses
them.

See also:

Changing the timeline units

Working with ranges
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6.2 Changing the timeline units

Changing the timeline units
In the Schedule and Resource View, changing the timeline's units allows you to see the timeline in

hours, days, weeks, months, quarters, or years. For instance, if the timeline is in timeline units of

Weeks, there will be one timeline-column for every week. If you want to view the timeline graph in more

detail, you could change the timeline’s units to Days – each timeline-column would then represent one

day.

To change the timeline units:

1. In  the Schedule or Resource View, on the Project tab, in the Timeline group, click Timeline Unit and

choose a new unit from the drop-down list.

    -or-

    On every tab, in the Views group, click the action box.

    The Format Schedule/Resource View dialog opens.

2. In the Display tab, click the drop-down list under Timeline Units and select a new unit.

3. Click OK to apply your changes and close the dialog.

See also:

Changing the timeline graph range 

Changing resource duration units 

Changing schedule duration units

6.3 Changing the schedule duration units

Changing the schedule duration units
FastTrack Schedule allows you to view duration in different units of time. This allows you to view the

length of an activity bar in calendar or work hours, days, weeks, months, quarters, or years. For
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instance, if the schedule shows durations in units of Weeks and you want to see durations in units of

Days instead, you can use the Format Schedule View dialog to change the duration units. Your changes

affect values in all Duration columns: (Scheduled) Duration, Revised Duration, and Actual Duration.

Calendar units are based on a 24 hours a day 7 days a week model, which allows you to schedule tasks

anywhere within those parameters. An activity lasting one calendar day has a duration of 24 hours, 12

AM to 12 Midnight. An activity lasting one work day has an 8 hour duration, 8 AM to 5 PM, or the length

of time you have defined for a work day in the Work Calendar.

To view durations in a different unit of time:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The Document Options dialog opens.
3. In the Project tab, from the Duration Units drop-down list, select the unit of time.

4. Click OK to apply your changes and close the Document Options dialog.

    Durations will be calculated in the unit chosen from the drop-down list.

Notes:

- When you set Duration Units to be calculated in 24-Hour Calendar units, the Custom Work Calendar,
while viewable, is no longer applied to the schedule.
- If you select the Use Custom Work Calendar option, durations will be calculated according to the Work
Calendar and this may cause bars to jump as you draw or drag them in the timeline graph.

See also:

Changing the timeline units 

Using the work calendar 

Changing the resource duration units 
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6.4 Changing the resource duration units

Changing the resource duration units
Duration, in the Resource View, is the amount of time allotted for a resource to work on a task  (the

resource’s allocation). Duration can be calculated in various units. If the schedule’s duration units are

calculated in work units, only work units will be available in the Duration Units drop-down list. If the

schedule’s duration units are calculated in calendar units, only calendar units will be available in the

Duration Units drop-down list.

To view resource duration in a different unit of time:

1. In the Resource View, in the View group, click the Dialog Box Launcher.

    The Format Resource View dialog opens. 

2. From the Timeline Units drop-down list, select a unit of time.

3. Click OK to apply your changes and close the Format Resource View dialog.

    Resource allocation is calculated in the units chosen in the drop-down list.

See also:

Changing the timeline units 

Using the work calendar 

Changing schedule duration units

6.5 Resizing timeline-columns

Resizing timeline-columns
Resizing timeline-columns proportionally changes the width of individual columns in the timeline and
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timescale rows. Making the timeline graph narrower will let you see more of the timeline. Making the

timeline graph wider can make drawing and dragging bars more accurate.

To change the width of the timeline-columns:

1. Position the cursor over a vertical gridline in the timescale row that displays the base timeline unit. 

    The cursor changes to the Horizontal Resize cursor. The timescale row that contains the base

timeline unit (the smallest timeline unit) is the one that defines the size of columns in the timeline

graph. 

2. Drag to the left to make all of the columns narrower or drag to the right to make all of the columns

wider.

Notes:

- If the width of the timeline-column is not wide enough to display the entire timescale label, the label is
partially hidden.
- You will not be able to resize the timeline-columns if Fit to Pages (Width) is selected in the Page
Options dialog. Fit to Pages sets the timeline-columns at a width that will allow them to print to the
specified number of pages. If you want to resize timeline-columns, select Standard or Wall Chart (Tiled)
from the Page Options dialog.

See also:

Changing the width of columns 

Changing the timeline range 

6.6 Formatting the timeline's gridlines

Formatting the timeline’s gridlines
Formatting gridlines defines the display of gridlines in columns and the timeline graph in the Schedule

and Resource Views.
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To format gridlines in a timeline:

1. On the Format tab, in the Display group, click Gridlines.

2. Select from the options described below.

This Option: Does This:

Define Gridlines

Optimize Automatically defines separate gridlines for display and

printing. When displayed on screen, gridlines are gray or

dotted. When printed to a dot matrix printer, gridlines are

dotted. When printed to a high-resolution printer (300 dpi or

greater), gridlines are solid hairlines.

Custom Setting Allows you to design your own gridlines. Define the size,

style, and color of the gridlines.

Show Gridlines

Column

Horizontal 

Displays horizontal gridlines in columns.

Column Vertical Displays vertical gridlines in columns.

Timeline

Horizontal 

Displays horizontal gridlines in the timeline graph.
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Timeline Vertical Displays vertical gridlines in the timeline graph.

Gridline Divisions

Per Timeline Unit

Allows you to subdivide a timeline unit with the number of

gridlines you specify.

3. Click OK to apply your changes and close the dialog.

    Changes made to the Schedule View’s gridlines do not apply to the Resource View gridlines and vice

versa.

Note:

The Gridline Divisions per Timeline Unit box allows you to enter the number of columns you want shown

in each timeline unit.

See also:

Setting preferences 

Defining font attributes for a selected item 

6.7 Using Shift Schedule

Using Shift Schedule
Using Shift Schedule moves your bars in the timeline graph forward or backward a chosen number of

units.
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To shift your schedule  the Schedule View timeline:

1. On the Tools tab, in the Shift group, click Schedule.

    The Shift Schedule dialog opens.

2. Select from the options described below.

This Option: Does This:

Shift Forward/

Backward

Defines in which direction of time the items will be moved.

(Number) Defines the number of units the items will be moved.

Units Defines the units of time described by the (Number) box.

For instance, you could move an item Forward four Work

Days or Forward four Calendar Days.

3. Click Shift to shift items and keep the Shift Schedule dialog open.

    -or-

    Click Done to close the Shift Schedule dialog without shifting items.

See also:

Dragging activity bars and milestones 

Shifting Items in Timeline Graph 
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6.8 Shifting items in the timeline

Shifting items in the timeline
In the Schedule View, you can shift moves pictures, text boxes and legends in the timeline graph

forward or backward a chosen number of units.

To shift pictures, text boxes and legends in the Schedule View timeline:

1. On the Tools tab, in the Shift group, click Items.

    The Shift Items dialog opens.

2. Select from the options described below.

This Option: Does This:

Shift Forward/

Backward

Defines in which direction of time the items will be moved.

(Number) Defines the number of units the items will be moved.

Units Defines the units of time described by the (Number) box.

For instance, you could move an item Forward four Work

Days or Forward four Calendar Days.

Apply To Defines which items this move affects. If an option is

grayed out, the timeline does not contain any items of

this type.
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3. Click Shift to shift items and keep the Shift Items dialog open.

    -or-

    Click Done to close the Shift Items dialog without shifting items.

See also:

Dragging activity bars and milestones 

Moving text boxes 

Moving pictures 

6.9 Formatting datelines

Formatting datelines
A dateline is a way to graphically highlight, in the timeline, a date and time key to your schedule. You

can choose to hide or show datelines in the timeline, and you can format each dateline’s appearance.

To format the Dateline:

1. On the Format tab, in the Display group, click Datelines.

    The format dialog opens in the Datelines tab.

2. In the Dateline Display area, select from the options described below.

This Option: Does This:

Dateline Allows you to display the following: 

- Dateline

- Project Start Dateline

- Project Finish Dateline
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- Up to 10 custom datelines

Show Dateline When selected, displays a vertical line in the timeline

drawn at the appropriate date.

Size Defines the thickness of the dateline.

Pattern and Color Sets the pattern and color for the dateline.

Define Dateline By

Auto Update Every

"X" Minutes

Sets the number of minutes between dateline Auto

updates,

Set Date/Time To Sets the fixed date and time for the dateline.

3. If you are formatting the Dateline, you can select the Auto Update Every option to determine how often

the Dateline should update. 

    The Dateline will display on the current date and time, as shown in the Schedule View or Resource.

    -or-

    If you are formatting the Dateline or a Custom Dateline, you can select the Set Date/Time To option to

set a static date and time for the dateline.

4. Click OK to apply your changes and close the dialog.
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Note:

The Dateline can move in real time by Auto Updating per the options you set. Custom datelines and the

Dateline can also be set to appear in the timeline on the static date and time which you set. The

location of the Project Start and Finish datelines is determined by the activity data in your schedule.

See also:

Using the Project Information form 

7 Rows

7.1 Working with rows

Working with rows
Rows, which are found in the Schedule View, contain all of the information pertaining to a particular

activity. 

Resource rows, which are found in the Resource View, contain all of the information pertaining to a

particular resource.

What would you like to do?

 Inserting rows

 Entering activity and resource names

 Outlining activities

 Collapsing activities and resource subrows

 Expanding activities and resource subrows
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 Resizing rows

 Moving rows

 Changing the font attributes of rows

 Formatting rows in the Schedule View

 Formatting rows in the Resource View

 Formatting summary bars

 AutoFitting row height

7.2 Selecting rows

Selecting rows
There are multiple ways to select a row or rows in the Schedule and Resource Views. 

To select a row or rows:

1. Click in the Row Number action column of the row you wish to select.

    -or-

    To select contiguous rows, hold down the Shift key, click in the Row Number action column and drag

the mouse to select multiple rows.

    -or-

    To select non-contiguous rows, hold down the Control key and click their Row Number action

columns. 

    -or-

    Select all rows in the schedule by right-clicking the the Row Number action column and choose

Select All from the context menu.

Note:

You can also select timescale rows, summary graphs and the rows of any of the tables in the program

using the Shift and Control keys.
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See also:

Outlining activities

Inserting rows 

7.3 Inserting rows

Inserting rows
Inserting a row adds a new row, or series of rows, between existing rows. 

To insert new rows in the Schedule View or Resource View:

1. Select the rows above which you would like new, blank rows to appear.

    If you want to insert three new rows, select three existing rows. The new rows will appear above the

topmost of the selected rows.

2. Right-click the Row Number action column, and select Insert Row from the shortcut menu.

    -or-

1. Select the rows above which you want the new rows to appear.

2. On the Insert tab, in the Rows & Columns group, click Row.

Notes:

- You can also insert a series of non-contiguous rows by holding down the Control key and clicking the
Row Number action columns of the rows above which you would like a new row to appear.
- Inserted rows will default to the outline level of the row above which they were inserted.
- In the Schedule View, inserting a new row when the schedule has been sorted or when rows are hidden
(either by filtering, hiding, or through the Tools menu) can affect your activity outline levels.
- To insert a single row, you can also hold down the Control key and click between two rows.

See also:



FastTrack Schedule 10 User Manual88

Copyright © 2010, AEC Software, Inc. All rights reserved.

Entering activity names 

7.4 Entering activity and resource names

Entering activity and resource names
An activity or resource name gives a row its purpose. 

To enter activity names for new activities:

1. In the Schedule View, click in the first empty cell of the Activity Name column.

2. Enter a name for the activity.

To change the name of an activity:

1. In the Schedule View, select a value in the Activity Name column.

2. Enter a new value.

To enter resource names for new resources:

1. In the Resource View, click in the first empty cell of the Resource Name column.

2. Enter a name for the resource.

To change the name of a resource:

1. In the Resource View, select a value in the Resource Name column.

2. Enter a new value.

See also:

Outlining activities 

Inserting rows 
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7.5 Outlining activities

Outlining activities
In the Schedule View, outlining activities creates a hierarchy of activity levels; for instance, projects,

phases, activities, and subactivities. By indenting and outdenting activity names, you can create as

many outline levels as you would like. Once outlined, activity levels can be collapsed and expanded to

show different levels of detail.

To indent an activity underneath another activity:

1. Click on the Activity Name cell of the row you wish to indent.

2. On the Home tab, in the Outline group, click the Indent button.

    -or-

1. Click to place the blinking insertion point before the Activity Name value.

2. Press the Tab key on your keyboard.

To "outdent" an activity by moving it to the level above:

1. Click on the Activity Name cell of the row you wish to outdent.

2. On the Home tab, in the Outline group, click the Outdent button.

    -or-

1. Click to place the blinking insertion point before the Activity Name value.

2. Press the Backspace key on your keyboard.

See also:

Collapsing activities

Expanding activities
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Formatting summary bars 

Displaying outline levels

7.6 Displaying outline levels

Displaying outline levels
You can show or hide specific outline levels in the whole schedule at once using the Outline Toolbar or

the menubar.

To display outline levels:

1. On the Home tab, in the Outline group, click the Show Level drop-down list and select the number of

outline levels you wish to display. 

    If outline levels exist beyond your selection, they will be collapsed.

See also:

Outlining activities 

7.7 Collapsing activities and resource subrows

Collapsing activities and resource subrows
Collapsing an activity "rolls-up" all of the outline level's subactivities that are indented beneath it. The

information in the subactivities will no longer be visible. Collapsing a resource subrow "rolls-up" all of the

subrows that are indented beneath a resource row. The information in the subrows will no longer be

visible. In the Schedule View, you also have the option of displaying a summary bar that shows the

earliest start and latest finish per each bar style in the subactivities.
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To collapse an activity outline level or resource subrow:

1. In the Expand/Collapse action column, click the downward-facing triangular handle next to the activity

or resource subrow you want to collapse. 

    -or-

1. Select the row or subrow you want to collapse.

2. Right-click the Row Number action column, and select Collapse from the context menu.

    -or-

1.On the Home tab, in the Outline group, click the Collapse All button.

    This collapses all subactivities.

Notes:

- Collapsible activities have subactivities indented beneath them.
- Collapsible activities are the only ones with an Expand/Collapse triangular handle in the Action
Column. When activities are collapsed, their Expand/Collapse triangular handle turns to the right. In the
Schedule View, their Activity Name is followed by an ellipsis (...).
- Operations performed on a collapsed outline level affect all collapsed subactivities beneath it. For
instance, if you move or delete a collapsed activity, you move or delete all of its collapsed subactivities.

See also:

Outlining activities

Expanding activities

Formatting summary bars 
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7.8 Expanding activities and resource subrows

Expanding activities and resource subrows
Expanding activities "rolls-down" collapsed activities, allowing you to see all of the level's subactivities. It

makes all of the information in the subactivities visible. Expanding subrows "rolls-down" collapsed

subrows, allowing you to see all of the resource row’s subrows. It makes all of the information in the

subrows visible.

To expand an activity outline level or resource subrow:

1. In the Expand/Collapse action column, click the downward-facing triangular handle next to the activity

or resource subrow you want to expand. 

    -or-

1. Select the row or subrow you want to expand.

2. Right-click the Row Number action column, and select Expand from the context menu.

    -or-

1. On the Home tab, in the Outline group, click the Expand All button.

    This expands all subactivities.

Note:

In the Schedule View, when activities are collapsed, their Expand/Collapse triangular handle turns to the

right, and their Activity Name is followed by an ellipsis (...).

See also:

Outlining activities

Expanding activities

Formatting summary bars 
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7.9 Resizing rows

Resizing rows
Resizing a row changes its height.

To resize a row:

1. In the Row Number action column, position the cursor over the row's horizontal bottom gridline.

2. Drag the gridline up or down to adjust the row height.

    -or-

1. In the columns, position the cursor over the row's horizontal bottom gridline.

2. Drag the gridline up or down to adjust the row height.

    This method only works when you have chosen to resize rows in Data and Action Columns in the

Editing tab of the Application Options dialog.

To resize multiple rows:

1. Select the rows that you want resized to the same height.

2. Resize one of the rows as described above.

Notes:

- In the Schedule and Resource Views, rows have two heights: when expanded (usual) and when
collapsed. To set either, expand or collapse the row and then resize the row.
- You can also resize rows in the Format Row and Format Resource Row dialogs – each of which you
can open by double-clicking in a row’s Row Number action column. Size changes made in the Format
Resource Row dialog affect the subrows only (Percent Usage, Allocated Time Usage, and
Assignments). The selected size is used for all three subrows.
- In the Schedule View, AutoFit can automatically enlarge or reduce row height to fit text as you enter it.

See also:

AutoFitting row height 
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7.10 Moving rows

Moving rows
Moving rows up or down in the schedule allows you to change the order in which you view activities and

resources.

To move a row:

1. Click in the Row Number action column and select the row you want to move. 

    Once you have selected a row, the cursor changes to the Move cursor.

2. Click and drag the selected row up or down.

To move multiple activities in an outline level:

1. In the Schedule View, collapse the subactivities of an outlined activity.

2. Drag the collapsed activity as described above.

3. Expand the activity again.

Notes:

- In the Schedule View, moving a row when the schedule has been sorted or when rows are hidden
(either by filtering, hiding, or through the Tools menu) can affect your activity outline levels.
- You can also change the arrangement of activities and resources using sorts.

See also:

Sorting activities and resources

7.11 Showing and hiding rows

Showing and hiding rows
You can hide and show rows using commands in the Editing group on the Home tab. This allows you to

select individual rows to be hidden.
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To show only the selected rows:

1. Select the row or rows.

2. Right-click and choose Hide Unselected from the context menu.

    This leaves visible only the rows that are selected, hiding all other rows.

To hide rows:

1. Select the row or rows.

2. On the Home tab, in the Edit group, choose Hide Selected Rows.

    -or-

    Right-click and choose Hide from the context menu.

    This hides all selected rows leaving visible only the rows that are unselected.

Note:

Once you have hidden rows, through the menu or with a filter, you can show them all again by restoring

the rows. This shows all hidden rows and rearranges them so that they resume their original, Master

Sort order. Right-click a visible row and choose Restore All from the context menu. Restoring does not

necessarily return your View to the same appearance it had before you hid rows. If you have made

changes that affect the order of activities or resources, these changes cannot be restored. Changes that

affect the order of rows include: moving, inserting, deleting, cutting, and pasting rows.

See also:

Restoring hidden rows

Filtering and sorting
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7.12 Showing and hiding resource subrows

Showing and hiding resource subrows
In the Resource View, you can show and hide resource subrows in the Define Layouts dialog.

To show and hide resource subrows:

1. In the Resource View, on the Project tab, in the Layout group, click Layouts and choose Define from

the submenu.

    The Layouts dialog opens.

2. To design a new layout, click the New button.

    -or-

    To edit an existing layout, select the layout from the Layouts table and click the Edit button.

    The Define Layout dialog opens.

3. Click the Resource Subrows tab.

4. Select a row from the Available Rows table and click the Show button to send it to the Shown Rows

table.

    Rows in the Shown Rows table are displayed in the Resource View.

    -or-

    Select a row from the Shown Rows table and click the Hide button to send it to the Available Rows

table.

    Rows in the Available Rows table are not displayed in the Resource View.

    -or-

    Click Hide All to send all the rows in the Shown Rows table to the Available Rows table.

    All subrows will be hidden in the Resource View.

5. Click OK to save your layout and close the Define Layout dialog.

6. Click OK to apply the selected layout and close the Layouts dialog.

See also:
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Outlining activities 

Working with resources 

7.13 Formatting rows in the Schedule View

Formatting rows in the Schedule View
Formatting rows allows you to set the height, background color and pattern, and bottom line color and

pattern of rows.

To format rows in the Schedule View:

1. Select the row or rows.

2. On the Format tab, in the Display group, click Format Selected.

    -or-

    Double-click the Row Number action column of the select row or rows.

    The Format Row dialog opens.

3. In the dialog's Display tab, select from the options described below.

This Option: Does this:

Use Outline Styles Allows you to format the appearance of a row in relation

to its outline level.

Define Outline

Styles

Click to open the Outline Level Styles dialog in which you

can set the background and bottom line colors and

patterns for each outline level.
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Height

Expanded Determines at what row height the activity will display

when its outline levels are expanded.

Collapsed Determines at what row height the activity will display

when its outline levels are collapsed or hidden.

Background 

Color Sets a background color to display in the row.

Pattern Sets a background pattern to display in the row.

Display Location Allows the color and pattern you have selected to display

on: columns only, the timeline only, the columns and

timeline, or not at all.

Bottom Line 

Color Sets a bottom line color to display in the row.

Size Sets a line size for the bottom line pattern you are opting

to display in the row.
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Display Location Allows the color pattern and line size to display on:

columns only, the timeline graph only, the columns and

timeline, or not at all.

Page Break After

this Row

Sets a page break after the row you are currently

formatting.

4. Click OK to apply your changes and close the Format Row dialog.

Notes:

- If you are formatting several rows at once, selecting Page Break After this Row puts a page break after
each row.
- The Set as Default option makes the selected settings the default for all newly created rows.

See also:

Formatting summary bars 

7.14 Formatting rows by outline level

Formatting rows by outline level
The row background and bottom lines can also be set by outline level. For instance, you could apply a

different background color to rows in outline level 1 and 2.

To change the formatting of rows by outline level:

1. In the Schedule View, select the row or rows whose outline level styles you wish to format.

    Important: You must have a row selected for outline level styles to apply to it. If you merely select one



FastTrack Schedule 10 User Manual100

Copyright © 2010, AEC Software, Inc. All rights reserved.

row, only that row will be formatted. 

2. On the Format tab, in the Display group, click Format Selected.

    -or-

    Double-click the Row Number action column of the select row or rows.

    The Format Row dialog opens.

3. In the Display tab, select the Use Outline Styles checkbox.

4. Click the Define Outline Styles button.

    The Outline Level Styles dialog opens.

5. From the Outline Level table, select the outline level you wish to format.

6. Select from the options described below.

This option: Does this:

Background 

Color Allows you to set a background color to display in the

row.

Pattern Allows you to set a background pattern to display in the

row.

Display Location Allows the color and pattern you have selected to display

on: columns only, the timeline only, the columns and

timeline, or not at all.

Bottom Line 
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Color Allows you to set a bottom line color to display in the

row.

Size Allows you to set a line size for the bottom line pattern

you are opting to display in the row.

Display Location Allows the color pattern and line size you have selected

to display on: columns only, the timeline graph only, the

columns and timeline, or not at all.

7. Click OK to apply your changes and close the Outline Level Styles dialog.

8. If you wish, change the row height or page break options.

9. Click OK to apply your changes and close the Format Row dialog.

Notes:

- Rows must be visible (not collapsed or hidden) to have outline level styles applied to them. 
- If you select the Set as Default button, the outline level styles will be applied to the rows that you have
selected to be formatted and all new rows.
- If you indent or outdent rows to change outline levels, formatting changes will automatically update.
- Click the Copy All button to copy the complete set of outlines style to the Clipboard. To apply outline
styles from the Clipboard, click the Paste All button.

See also:

Formatting summary bars 

Formatting rows 
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7.15 Changing the font attributes of rows

Changing the font attributes of rows
Changing the font attributes of individual rows allows you to customize the appearance of the text in the

body of the schedule. For instance, you can change the font attributes (such as font, size, and color) of

individual rows or groups of rows.

To change the font attributes of an individual row or a group of rows:

1. To select a single row, click in the Row Number action column of the row you wish to select.

    To select contiguous rows, hold down the Shift key, click in the Row Number action column and drag

the mouse to select multiple rows. 

    To select non-contiguous rows, hold down the Control key and click in the Row Number action

column of the rows you wish to select. 

2. On the Home tab, use the options in the Font group to change the font, size, style, color, justification,

and line spacing.

    -or-

1. Control-click in the Row Number action column of a selected row and choose Font from the context

menu.

2. In the Font dialog, select the font attributes.

3. Click OK to apply your changes and close the Font dialog.

Note:

Collapsed rows have to be made visible and then selected for font styles to be applied to them. 

See also:

Selecting rows 

Formatting rows in the Schedule View 

Formatting rows by outline level 
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Changing font attributes of cells 

Changing font attributes of column headings 

7.16 Formatting rows in the Resource View

Formatting rows in the Resource View
Formatting resource rows allows you to set the height, background color and pattern, and bottom line

color of resource rows.

To open the Format Resource Row dialog:

1. Select the resource row or rows you want to format.

2. Double-click the Row Number action column of the selected resource row or any one of the multiple
selected resource rows.

    The Format Resource Row dialog opens.
2. In the Display tab, from the Format Subrow drop-down list, select the part of the resource row you

wish to change the display of.

3. Select from the options described below.

This Option: Does this:

Row

Background

Attributes:

Display Location Allows the color and pattern you have selected to display on:

columns only, the timeline only, both the columns and the

timeline, or not at all.
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Color Allows you to set a background color to display in the resource

row as a whole or in the specified subrow.

Pattern Allows you to set a background pattern to display in the

resource row as a whole or in the specified subrow.

Bottom Line

Attributes:

Display Location Allows the color you have selected to display beneath: columns

only, the timeline only, both the columns and the timeline, or

not at all.

Color Allows you to set a bottom line color to display in the resource

row as a whole or in the specified subrow.

Size Set the size, or thickness, of the bottom line.

Height: (only available when formatting a resource subrow)

Expanded Determines at what row height the resource subrow will display

when it is expanded.

Collapsed Determines at what row height the resource subrow will display
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when it is collapsed or hidden.

Options:

Page Break After

this Row

Sets a page break after the resource you are currently

formatting.

Show Scale Displays the scale for the graph.

Show Parent Tree Displays the contents of the Parent Tree column (the activity

preceded by all of its parents) in the Assignments subrow.

4. Click OK to apply your changes and close the Format Resource Row dialog.

Notes:

- If you are formatting several rows at once, selecting Page Break After this Row will put a page break
after each row.
- Clicking the Set as Default button makes the selected settings the default for all new resource rows.

See also:

Working with resources 

7.17 Formatting summary bars

Formatting summary bars
If you wish to include summary bars, they can be used whenever subactivities exist.



FastTrack Schedule 10 User Manual106

Copyright © 2010, AEC Software, Inc. All rights reserved.

To display summary bars:

1. Format the row to show summary bars.

To format a row to show summary bars:

1. Select the row or rows.

2. On the Format tab, in the Display group, click Format Selected.

    -or-

    Double-click the Row Number action column of the selected row or rows.

    The Format Row dialog opens.

3. Click the Summary Bar tab.

4. Select the Summary Bar option.

    This option is selected by default. When not selected, no summary bars will be displayed.

5. Use the pop-up list to choose the summary bar’s bar style.

6. You can also from the Additional Summaries options described below.

Display: Does this:

Bars By Style Displays, in a single row, a summary bar for

each bar style in an activity’s outline levels. The

start of a particular bar style’s summary bar is

the earliest Start Date and Time of all bars of

that bar style. The finish of a particular bar

style’s summary bar is the latest Finish Date

and Time of all bars of that bar style. The

duration of a particular bar style’s summary bar

is the length of time in the schedule’s Duration
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units between the earliest start and the latest

finish of that bar style.

Milestones Displays a summary milestone either in a single

style, which you can specify, or, for each style

of milestone in an activity’s outline levels.

7. Click OK to apply your changes and close the Format Row dialog.

To assign values to summary bars:

1. Select from the Summary Bar Values options.

    Summary Bar value options are not available when formatting columns in the Resource View.

Note:

Summary bars can be dragged up and down in the row but not left to right. The application automatically

calculates their horizontal position.

See also:

Outlining activities

Collapsing activities

Formatting rows

7.18 AutoFitting row height

AutoFitting row height
AutoFitting row height automatically resizes the height of activity or resource rows to fit the text and



FastTrack Schedule 10 User Manual108

Copyright © 2010, AEC Software, Inc. All rights reserved.

items (bars, pictures, text boxes) in each row's cells. This can be done automatically as you type, or

you can apply it afterwards.

To adjust a rows height as you enter new text:

1. On the Tools tab, in the Arrange group, click AutoFit and choose AutoFit Options from the drop-down

list.

    The AutoFit Options dialog opens.

2. Select the Allow Row Height to Grow and Allow Row Height to Shrink checkboxes to set rows to grow

or shrink as text is entered and edited.

    You can also set minimum Row Height Options and AutoFit Considerations from the AutoFit Options

dialog.

3. Click OK to apply your changes and close the AutoFit Options dialog.

To resize rows to best fit the amount of text in each row:

1. In the Schedule View or Resource View, make sure no rows or column headings are selected by

clicking in the timeline.

2. On the Tools tab, in the Arrange group, click AutoFit and choose View.

    This resizes all rows to heights based on the height of text in each row's cells.

Note:

The AutoFit [Selected] command changes with your selection. For instance, select a row to autofit a row

height and a column heading to autofit a column width.

See also:

Resizing rows
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7.19 Going to row number

Going to row number
This command scrolls the Schedule View or Resource View to display the row whose number you enter.

This is helpful when viewing files with a large number of rows.

To scroll the schedule to see a specific row number:

1. On the Home tab, in the Editing group, click Go To and choose Row from the submenu. 

    The Go To Row # dialog opens. 

2. Enter the number of the row you want to view.

3. Click OK to display the row and close the Go to Row # dialog. 

See also:

Working with rows 

Row Number Action Column 

8 Columns

8.1 Working with columns

Working with columns
FastTrack Schedule stores columns in three distinct ways. Columns for the Schedule View are stored

either per row or per bar. Columns for the Resource View are stored per resource row. 

Every column in the Schedule View and Resource View is application-defined. Columns are hidden until

you choose to insert them into a layout. No column can truly be deleted and the Column Map can help
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you keep track of which of the hundreds of available columns you have inserted and, possibly, renamed.

You change the look of your schedule by showing, hiding, and arranging columns. Groups of selected

columns are called layouts.

What would you like to do?

 Insert a column

 Understand available Schedule View columns

 Format the display of column data

 Change the column name

 Change a column’s font attributes

 Change a column heading’s font attributes

 Define default values

 Define a value list for a column

 Define column summaries

 Using the Column Map

8.2 Schedule View Column Guide

Schedule View Column Guide
The tables below will give you a description of every available column in the Schedule View broken down
by column type.

Calculation ID/Code
Cost Image
Date Number
Duration Text
Flag Time
Hyperlink Work

Calculation columns
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Column Name: Description:

Calculation 1-100 Define a formula to calculate using data in the

schedule.

Cost columns

Column Name: Description:

Baseline Cost 1-10 Capture activity costs at up to 10 points in

time for the lifetime of the project

Cost 1-10 Formatted to display monetary values

Fixed Cost Lump sum costs for the activity, feeds into

Total Cost

Resource Cost Pre-defined calculation of the assigned

resource’s rate x work

Total Cost Pre-defined calculation of Fixed Cost +

Resource Cost

Date columns

Column Name: Description:

Actual Finish Date Date on which an activity actually finished

Actual Start Date Date on which an activity actually started

Baseline Finish Date 1-10 Capture activity finish dates

Baseline Start Date 1-10 Capture activity start dates

Constraint Date Date to be used with constraint type

Date 1-10 Formatted to display dates

Early Finish Date Earliest date activity can finish

Early Start Date Earliest date activity can start

Finish Date Originally estimated finish date "Scheduled"
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Finish Date 1-10 Formatted to display dates

Late Finish Date Latest date an activity can finish before project

finish date is affected

Late Start Date Latest date an activity can start before project

finish date is affected

Revised Finish Date Revision to activity's scheduled finish date

Revised Start Date Revision to activity's scheduled start date

Start Date Originally estimated start date "Scheduled"

Start Date 1-10 Formatted to display dates

Duration columns

Column Name: Description:

Actual Duration (Days) Duration of time it actually took an activity to

be completed

Baseline Duration 1-10 Capture activity durations at up to 10 points in

time for the lifetime of the project

Duration 1-10 Formatted to display durations

Duration Originally estimated duration "Scheduled"

Finish Float Number of days activity's finish date can slip

before project finish date is affected

Free Float Number of days an activity can slip before next

activity is affected

Revised Duration Revision to activity's scheduled duration

Start Float Number of days activity's start date can slip

before project finish date is affected

Total Float Number of days activity can slip before project

finish date is affected

Total Resource Duration The total duration, in hours, of resource work

time allocated to an activity
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Flag columns

Column Name: Description:

Critical Yes/No – Yes indicates that the activity is on

the critical path

Effort Driven Yes/No - Yes indicates that the activity's

duration is driven by resource effort

Flag 1-20 Formatted to display Yes/No option

Ignore Resource Calendars Yes/No - Yes indicates that the activity is to

ignore the assigned resource's calendar

Hyperlink columns

Column Name: Description:

Hyperlink 1-10 Formatted to display hyperlink items - email

address, URL, file

ID/Code columns

Column Name: Description:

Activity Row ID ID to identify row

Activity Row Number Number to identify row

Bar ID Unique identifier for bar

Bar Row ID Unique identifier for bar row

Constraint Type Parameter applied to activity to control its

behavior as project changes

Parent Tree Activity name complete with parent rows, when

using outline levels

Predecessors Displays which activity row(s) an activity is

dependent on, including link type and lead/lag

Priority Number field to prioritize your tasks

Resources Assigned Linked to Resource View; defines assigned

resources to activity

Status Automatically calculated, based on %

Complete, % Used and Current Dateline
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Subproject Activity Row ID In a consolidated file, displays the original Row

ID of activities in a subproject.

Subproject WBS In a consolidated file, displays the original

numerical hierarchy of activities in a subproject

based on their outline levels before

consolidation

Successors Displays which activity rows are dependent on

what other activity rows, including link type and

lead/lag

Task Calendar Assign/Edit an activity’s calendar (Standard,

24 hour, Nightshift, etc.)

WBS A numerical hierarchy of activities based on

outline levels

Image columns

Column Name: Description:

Image 1-10 Formatted to display images

Number columns

Column Name: Description:

% Complete Percentage of activity completed

% Used Percentage of a resource’s time used

Number 1-50 Customizable to display numerical values

Text columns

Column Name: Description:

Activity Name Project tasks/activities

Attendees iCal/Outlook event attendees

Location iCal/Outlook event location

Notes When text is entered, a notes indicator

appears in the Information Form action column
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Text 1-100 Customizable to display text data

Time columns

Column Name: Description:

Actual Finish Time Time activity actually finished

Actual Start Time Time activity actually started

Baseline Finish Time 1-10 Capture activity finish times

Baseline Start Time 1-10 Capture activity start times

Constraint Time Time to be used with constraint type and date

Early Finish Time Earliest time on Early Finish Date activity can

finish

Early Start Time Earliest time on Early Start Date activity can

start

Finish Time Originally estimated finish time "Scheduled"

Finish Time 1-10 Formatted to display time

Late Finish Time Latest time on Late Finish Date an activity can

finish before project finish date is affected

Late Start Time Latest time on Late Start Date an activity can

start before project finish date is affected

Revised Finish Time Revision to activity's scheduled finish time

Revised Start Time Revision to activity's scheduled start time

Start Time Originally estimated start time "Scheduled"

Start Time 1-10 Formatted to display time

Work columns

Column Name: Description:



FastTrack Schedule 10 User Manual116

Copyright © 2010, AEC Software, Inc. All rights reserved.

Baseline Work 1-10 Capture activity work

Work The amount of work hours available to be

allocated to resources.

8.3 Displaying columns

Displaying columns
Showing columns displays columns that are currently hidden. This allows you to see different views of

your data. 

To show, or insert, a hidden column:

1. Select the column heading to the left of the intended position.

2. On the Insert tab, in the Rows & Columns group, click Column.

    The Insert Column dialog opens. 

3. Select the type of column you want to insert from the Show pop-up list.

    If the column you want to insert does not fit into the listed types, leave the Show setting at "All" and

choose from the list of every available column shown in the Column Display Name table.

4. Select the name of the column you wish to show from the Column Display Name table.

    Hold down the Control key and you can select multiple columns names in the table.

5. Click OK to insert the selected column and close the Insert Column dialog.

    The column now displays in your schedule. 

To show and arrange multiple columns at one time:

1. Select any column in the schedule.

2. On the Home tab, in the Editing group, click Select and choose Unhide from the drop-down list.

    The Define Layout dialog opens.

3. In the Columns tab, select the column you wish to view from the Available Columns table and click
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the Show button to move it to the Shown Columns table.

4. Click and drag on the column names in the Shown Columns table to arrange the display order of the

columns.

5. Click the lock column of the Shown Columns table to keep selected columns fixed on the screen

while you scroll the timeline.

6. Click OK to save your layout and close the Define Layout dialog.

7. Click OK to apply the selected layout and close the Layouts dialog.

    -or-

    Click Close to close the Layouts dialog without applying the layout.

    Even if it is not applied at this time, the layout is saved for later use.

Notes:

- The Column Display Name table contains all existing but hidden columns. If the column you want to
insert is not listed, it is already shown. You may have changed its name. Use the Column map, found on
the Tools tab in the Tracking group, to discover what name you've given the column.
- Layouts are time savers. If you find yourself showing, hiding, and moving columns often, you should
define a new layout that automatically produces that view of the Schedule View or Resource View for
you. See Using Layoutsfor more information.
- Once you have defined which column is displayed, you can use the Format Column dialog to change

the column’s name and the appearance of its data.

See also:

Working with columns

Using Layouts

Using the Column Map

8.4 Hiding columns

Hiding columns
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Hiding columns that are currently displayed allows you to simplify the appearance of the Schedule View

or Resource View. 

To hide columns:

1. To hide a column, select the heading of the column you wish to hide.

2. Right-click and select Hide. 

    -or-

1. To hide multiple columns, on the Project tab, in the Layout group, click Layouts and choose Define

from the drop-down list.

    The Layouts dialog opens.

2. Select the name of the layout you wish to view in the Layouts table.

3. Click the Edit button.

    The Define Layout dialog opens.

4. In the Columns tab, select the name of a column you want to hide from the Shown Columns table.

5. Click the Hide button to move the column out of the Shown Columns table and back to the Available

Columns table.

6. Repeat until all the columns you want to hide have been removed from the Shown Columns table.

    -or-

    Click the Hide All button to hide all columns.

7. Click OK to save your layout and close the Define Layout dialog.

8. Click OK to apply the selected layout and close the Layouts dialog.

    -or-

    Click Close to close the Layouts dialog without applying the layout.

    The layout is saved for later use.

Notes:

- Hiding a column hides its information. You can delete data, but you cannot delete a column; you can
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only hide it.
- Layouts are time savers. If you find yourself showing, hiding, and moving columns often, you should
define a new layout that automatically produces that view of the Schedule View or Resource View for
you. See Using Layoutsfor more information.

See also:

Working with columns

Displaying columns 

Using Layouts

8.5 Moving columns

Moving columns
Changing the position of a column in the Schedule View or Resource View allows you to define the left-

to-right order of the information. It also allows you to position columns to the right of the timeline. Moving

columns can be done graphically or by using the Define Layout dialog.

To move a column by dragging:

1. Click in the column heading to select the column you wish to move.

    Once you have selected a column, the cursor changes to the Move cursor.

2. Click and drag the column to the left or right until it is correctly positioned.

    If you do not drag the cursor far enough past the destination column, the column snaps back to its

original position.

    -or-

    To move a column to the other side of the timeline by dragging, click the desired column heading and

drag its outline past the edge of the timeline graph.

    If you are dragging to the right, the right edge of the timeline must be visible. If you are dragging to the

left, the left edge of the timeline must be visible.
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To move columns by modifying the layout:

1. On the Project tab, in the Layout group, click Layouts and choose Define from the drop-down list.

    The Layouts dialog opens.

2. Click Edit.

    The Define Layout dialog opens.

3. In the Columns tab, click and drag on the column names in the Shown Columns table to change the

position of the columns in this layout.

4. Click OK to save your layout changes and close the Define Layout dialog.

5. Click OK to apply the selected layout and close the Layouts dialog.

    -or-

    Click Close to close the Layouts dialog without applying the layout.

    The layout is saved even if it is not applied at this time.

See also:

Working with columns

Using Layouts

8.6 Locking and unlocking columns

Locking and unlocking columns
You can lock columns to the left and right of the timeline. If you do so, then only the area between the

columns will scroll. This allows you to keep the timeline and locked columns in view. 

To lock a column:

1. Select the column you want to lock by clicking in that column’s heading.

2. Right-click and select Lock.
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To unlock a column:

1. Select the column you want to unlock by clicking in that column’s heading.

2. Right-click and select Unlock.

Notes:

- You can lock one column to the left of the timeline and one column to the right. If you do so, then only
the area between the locked columns will scroll.
- You can also lock and unlock columns within the Columns tab of the Define Layout dialog, accessed
through the Layouts button on the Project tab.
- Locked columns can also be used to define which columns repeat on every page when you print the
Schedule View or Resource View. This is defined in the Page Options dialog, accessed by selecting
Print in the Application menu.

See also:

Working with columns

Using Layouts

Choosing Page Options 

8.7 Using the column map

Using the column map
The Column Map is a reference that allows you to see, side by side, the default and custom name of

every column available for use in the program. The Column Map also indicates if data in that column is

stored per row or per bar.

To open the Column Map:

1. On the Tools tab, in the Tracking group, click Column Map.

    The Column Map dialog opens.

2. Click OK to close the Column Map dialog.
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See also:

Working with columns

Using Layouts

Displaying columns

8.8 Changing the column name

Changing the column name
Column names are changed in the Format Column dialog.

To edit the name of a column:

1. Select the column heading of the column you want to format.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Column dialog opens.

3. In the Options tab, in the Customized Column Name box, enter or edit the name you would like to

display in the column heading.

    The Default Column Name is static and will always appear in the option box below the column’s

customized name should you need to reference it.

4. If the options are available for this column, you can also choose how data in the column is stored,

either in relation to an activity row, "Per Row" or in relation to an activity bar, "Per Bar."

5. If you do not want the column to display in the Columns table of the Information Form, deselect the

Show in Information Form option.

6. Click OK to apply your changes and close the Format Column dialog.

    The new column name appears in the column heading.
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Notes:

- When you change a column name, it automatically changes in any layouts, filters, or sorts you have
created. 
- To automatically show units in the column headings of the duration columns, select the Show Units in
Column Name checkbox in the Display tab of the Format Column dialog.

See also:

Working with columns

Locking columns 

8.9 Defining default values

Defining default values
When you insert a column, you can assign default values to that column. These values appear in the

column when a new activity, a new activity bar, or a new resource is created, depending upon the format

of the column.

Date, time, duration, image, WBS, and percent complete columns cannot have default values.

To assign default values to a column:

1. Double-click the column heading of the column to which you would like to add default values. 

    The Format Column dialog opens.

2. Click the Default Values tab.

3. Select from the options described below.

This option: Does this:

No Default Removes existing default value options from dialog choices
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Values (but not from existing cells) and prevents default values from

appearing when you enter data into the column.

Static Value Enters any value data that you would like to appear as this

column’s value in every new cell created.

Date/Time Stamp Enters a row’s date, time, or date and time of creation.

Auto-Increment

Number

Assigns to each new row an auto-incrementing number. It

can be a unique ID or serial number, or any series of

numbers you want. You determine this by entering the

base, or next, value as well as the number by which that

value will increase in each successively created row.

Value Cannot be

Modified

Prevents the assigned default value of a column from being

changed or overwritten. If you do not select this, the

column’s default values can be modified.

4. Click OK to apply your changes and close the Format Column dialog.

Notes:

- Changing a default value option only affects entries created after that change. Previously entered values
are not altered.
- A default value displays only when data is entered into another cell in that row.
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See also:

Working with columns

Creating Value lists 

8.10 Defining column summaries

Defining column summaries
A column summary can display the total, average, standard deviation, minimum, maximum, and/or

count of values currently shown in a column’s cells.

To define column summaries for the column:

1. Double-click the column heading of the column you want to format.

    The Format Column dialog opens.

2. Click the Summaries tab.

3. From the available Column Summaries, select those you want to display below the column.

Column

Type:

Summary Operation: Description:

Number Total Adds all values

Average Averages all values

Standard Deviation Displays standard deviation of all

values
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Minimum Displays minimum value

Maximum Displays maximum value

Count Counts the number of values

Date Minimum Displays earliest value

Maximum Displays latest value

Count Counts the number of values

Time Minimum Displays earliest value

Maximum Displays latest value

Count Counts the number of values

Text and

Image

Count Counts the number of values
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%

Complete

Average Displays the total of the percent

complete values divided by the

number of bars in the summary

bar.

Weighted Average Displays the percent complete as

the total time of completed work

divided by the total time the

summary bar lasts.

4. Format the Label Display of each selected summary type.

5. Click OK to apply your changes and close the Format Column dialog.

    The summary or summaries should now display below the selected column.

Notes:

- Column summaries appear only if the Column Summaries & Timescale (Bottom) option is chosen in
the Define Layout dialog.
- Summaries are based only on visible values. Values in hidden activities and collapsed subactivities are
not included.
- Summary bars are formatted in the Summary Bar tab of the Format Row dialog.

See also:

Working with columns

Defining value lists 

Formatting summary bars 
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8.11 Defining value lists

Defining value lists
Value lists provide a fast and accurate method of entering data into the Schedule and Resource Views.

For any column into which you can enter data, you can define a list of choices that appear when you

move into or click on a cell of that column.

To define value lists:

1. Double-click the column heading of the column you want to format.

    The Format Column dialog opens.

2. Click the Value List tab.

3. Select from the options described below.

Select: To:

No Value List Erase any value lists and prevent choices from appearing when

you enter column data. Data already entered using a value list

will not be erased.

Custom Value

List 

Display the values as a list that drops down from the cell,

allowing you to select a value either by clicking or typing the

first few characters.

ExpressDate™

Calendar

Display the ExpressDate™ pop-up calendar, allowing you to

enter dates with a series of mouse clicks.

ExpressTime™

Clock

Display the ExpressTime™ pop-up clock, allowing you to

enter times with a series of mouse clicks.
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4. If you choose the Custom Value List option, enter values into the preset Value List table as you want

them to appear.

    You can click on a value and drag it up or down to change the order of the list.

    -or-

    Use the buttons described below to help you build the list.

Click: To:

Copy List Store the values in the table so that you can paste them

into another column’s value list or into other applications.

Paste List Enter the values copied from another column’s value list or

another application. If there is an existing value list, this

replaces it.

Clear List Erase all values in the value list table.

Build From

Column

Automatically create an entry in the value list table for each

unique value currently stored in the column.

Sort Ascending Reorder the values in the table into alphabetically ascending

order: 0–9, A–Z, a–z.

Sort Descending Reorder the values in the table into alphabetically
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descending order: z–a, Z–A, 9– 0.

    To move a row up or down in the Value List table, select the row and drag it up or down to the desired

position.

    When a row is selected a drag icon appears in the right hand side column. This is the drag handle for

this row. Click and drag to move the row up or down in the Value List table.

5. Click OK to apply your changes and close the Format Column dialog.

See also:

Working with columns

Using value lists 

Using the pop up calendar 

Using the pop-up clock 

8.12 Using value lists

Using value lists
Using value lists makes data entry faster and more accurate. In order for the value list to appear, you

need to have defined a value list for the column. You do this in the Value List tab of the Format Column

dialog.

To enter a value using a value list:

1. Click and hold the left mouse button in a cell or move into a cell of the value list column.

2. If using a custom list, use your mouse to select a value from the list or enter the first letter of the

desired value to select it and then press the Enter key.
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Note:

If you have defined a value list for a column, that value list will appear in the Value cells in the Information

form, Resource Information form, and Column/Value Criteria tab of the Define Filter dialog.

See also:

Working with columns

Defining value lists for a column 

8.13 Entering and editing hyperlinks

Entering and editing hyperlinks
When you insert a column of the type "Hyperlink" you will create hyperlinks, or shortcuts to opening files

and URL addresses, in the cells of the column. Hyperlinks are entered and edited in the Define Hyperlink

dialog, accessed through the hyperlink column or the Information form. Hyperlinks display as blue

underlined text.

To enter a value in a hyperlink column:

1. Double-click in the blank cell of a hyperlink column.

    The Define Hyperlink dialog opens.

2. Select from the options described below.

Use this

option:

To do this:

Display

Name

Type or paste text in the Display Name box. The text you enter

here will display as hypertext in the column in lieu of the full path

or address. For instance, you can have "AEC Homepage"
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display rather than "www. aecsoftware.com".

File or URL Type or paste text in the File or URL box or use the Browse

button to enter the exact path to a file.

Launch URL Click the Launch URL button to test your links before entering

them.

3. Click OK to close the Define Hyperlink dialog.

To edit a value in a hyperlink column:

1. Right-click in the hyperlink column cell whose data you wish to edit.

    The Define Hyperlink dialog opens.

2. Use the options described above to edit a hyperlink.

3. Click OK to close the Define Hyperlink dialog.

    -or-

1. Click the Information Form action column of the activity or resource row in which you are working.

    In the Schedule View the Information form opens.

    In the Resource View, the Resource Information form opens.

2. In the Rows tab, select the Columns tab. 

3. Within the Column Name/Values table, click the hyperlink symbol corresponding to the hyperlink

column you want to edit.

    The Define Hyperlink dialog opens.

4. Use the options described above to edit a hyperlink.

5. Click OK to close the Define Hyperlink dialog.
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Notes:

- Files must be entered as a complete path, not simply the file name.
- When entering URL addresses, you must include the "www." portion of the address, though typing
"http://" is not necessary.

See also:

Working with columns

Creating hyperlinks 

Launching a file or URL address 

8.14 Launching a file or URL address

Launching a file or URL address
Launching opens the file or URL (internet address) that is defined by the value in a hyperlink cell. 

To launch a file:

1. Click the value in the hyperlink-defined column.

    This opens the application associated with the file you have selected and opens the file. 

    For example, if you double-click a hyperlink with the path "c:\My Documents\letter.doc," Microsoft

Word opens and then the "letter.doc" file opens (assuming files with the ‘.doc’ extension are set by

default to open with Microsoft Word). 

To launch a URL (internet) address:

1. Click the value in the hyperlink-defined column.

    This opens the default Internet browser or the mail application and goes to the address assigned to

that hyperlink. 
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    For example, if you click a hyperlink with the address "www. aecsoftware.com," your default Internet

browser (for instance Microsoft Internet Explorer, Mozilla Firefox, etc.) opens and goes to the Internet

address (in this case, the AEC Software home page on the world wide web).

See also:

Working with columns

Creating hyperlinks 

Entering and editing hyperlinks 

8.15 Formatting the display of column data

Formatting the display of column data
Changing the display of values in the column allows you to customize the appearance of the data it

contains. For instance, you could change the display of dates from "6/18" to "June 18." The display of

values in a column is part of its format.

To format the display of data in a column:

1. Double-click the column heading of the column you want to format.

    The Format Column dialog opens.

2. Click the Display tab. 

    If display options are available for that column, they will appear.

3. Use the available options to format the display of the selected column’s data.

4. Click OK to apply your changes and close the Format Column dialog.

Notes:

- Remember that the settings you have selected in the Application Options dialog affect the display
options that appear in this dialog. For instance, if you set dates to appear as yy/mm/dd in the Dates tab
of the Options dialog, then all display options will reflect this format.
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- To change the units displayed for Duration columns, use the Duration Units drop-down list in the
Display tab of the Format Schedule View or Format Resource View dialogs.
- You cannot change the type of data displayed in columns. Column types are application defined.

See also:

Working with columns 

8.16 Changing font attributes of column headings

Changing font attributes of column headings
Changing the font attributes of column headings customizes their appearance and can help fit large

column names in small heading cells without widening a column. For instance, if a long column name

(such as Revised Start Date) is wrapping awkwardly, you could change its font and type size to make it

fit in the current width of the heading. 

To change the font style of column headings:

1. Right-click the column heading you would like to change and choose Font from the context menu.

    The Font dialog opens.

2. Select the font attributes.

3. Click OK to apply your changes and close the Font dialog.

Note:

- To select contiguous column headings, hold down the Shift key, click and drag the mouse to select
multiple column headings. To select non-contiguous cells, hold down the Control key and click on the
column headings you wish to select.

See also:

Working with columns

Changing the font attributes of cells 
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Formatting font styles by outline level

8.17 Changing the font attributes of cells

Changing the font attributes of cells
Changing the font attributes of individual cells allows you to customize the appearance of the text in the

body of the schedule. For instance, you can change the font attributes (such as font, size, and color) of

individual cells, ranges of cells, or entire columns.

To change the font attributes of individual cells or ranges of cells:

1. To select a single cell, hold down the Shift key and click on the cell.

    To select contiguous cells, hold down the Shift key, click and drag the mouse to select multiple

cells. 

    To select non-contiguous cells, hold down the Control key and click on the cells you wish to select. 

2. Use the options in the Font group, found on the Home tab, to change the font, size, style, color,

justification, and line spacing.

To change the font attributes of an entire column:

1. Double-click on the column heading of the column you would like to format.

    The Format Column dialog opens.

2. Click the Font tab. 

3. Use the available options to change the font, size, style, color, justification, and line spacing.

4. Select Apply to All Cells in Column and Set as Default to apply the font attributes to every cell in the

selected column and all new cells in the column.

    -or-

    Click Apply to Unformatted Cells and Set as Default to apply the selected font attributes to just those
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cells whose font attributes you have not specifically changed and any new cells in the column. 

    Specifically formatted cells are those which you have formatted somewhere other than the Format

Column dialog. 

    For instance, if you have changed a cell using the Font Toolbar, Font Extras Toolbar, or Font dialog

these cells are considered formatted and would not change if you selected Apply to Unformatted Cells

and Set as Default.  Formatted cells will only change if you select the Apply to All Cells in Column and

Set as Default option.

5. Click OK to apply your changes and close the Format Column dialog.

Note:

Collapsed rows do not have to be visible for column font styles to be applied to them. 

See also:

Working with columns

Changing font attributes of column headings 

Formatting columns by outline level 

8.18 Formatting font styles by outline level

Formatting font styles by outline level
Font attributes can also be set by outline level. For instance, you can apply a larger font to activities in

the Activity Name column that are in outline level 1 than to activities in the Activity Name column that

are in outline level 2. 

To change the font attributes of columns by outline level:

1. Double-click on the column heading of the column you would like to change.
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    The Format Column dialog opens.

2. Click the Font tab.

3. Select the Use Outline Styles checkbox.

4. Click the Define Outline Styles button.

    The Column Outline Level Styles dialog opens.

5. In the Outline Level table, select the outline level to which you want to apply font attributes.

6. Use the available options to change the font, size, style, color, line spacing, and justification. 

7. Click OK to close the Column Outline Level Styles dialog.

8. Select Apply to All Cells in Column and Set as Default to apply the font attributes to every cell in the

selected column and all new cells in the column.

    -or-

    Click Apply to Unformatted Cells and Set as Default to apply the selected font attributes to just those

cells whose font attributes you have not specifically changed and any new cells in the column. 

    Specifically formatted cells are those which you have formatted somewhere other than the Format

Column dialog. 

    For instance, if you have changed a cell using the Font Toolbar, Font Extras Toolbar, or Font dialog

these cells are considered formatted and would not change if you selected Apply to Unformatted Cells

and Set as Default.  Formatted cells (whose styles were not set by column) will only change if you

select the Apply to All Cells in Column and Set as Default option.

9. Click OK to apply your changes and close the Format Column dialog.

Notes:

- Clicking the Copy All button copies the outline styles to the Clipboard. Clicking the Paste All button
pastes the outline style from the Clipboard.
- Collapsed rows do not have to be visible for column font styles to be applied to them.
- You can design outline styles without applying them by clicking the Define Outline Level button without
selecting the Use Outline Styles checkbox. When you are ready to apply the outline styles, you merely
select the Use Outline Styles checkbox and the styles you designed previously will be applied.
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See also:

Working with columns

Changing font attributes of column headings 

Changing the font attributes of cells 

8.19 Showing and hiding column headings

Showing and hiding column headings and timescales
You can hide and show column headings without affecting the rest of the column.

To show and hide headings and timescales:

1. On the Project tab, in the Layout group, select Layouts and choose Define from the submenu.

    The Layouts dialog opens.

2. Click the Edit button.

    The Define Layout dialog opens.

3. In the Columns tab, select or clear the check boxes described below.

Selecting this: Does this:

Column

Headings &

Timescale (Top)

Causes column headings and the top timescale to display in

the schedule.

Column

Summaries &

Timescale

(Bottom)

Causes column summaries, if any are defined, and a bottom

timescale to display in the schedule.
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Mirror Timescale

from Top

Causes the bottom timescale to appear as a mirror reflection

of the top timescale. Column Summaries & Timescale (Top)

must be selected if you want to mirror the top timescale.

4. Click OK to save your layout changes and close the Define Layout dialog.

5. Click OK to apply the selected layout and close the Layouts dialog.

    -or-

    Click Close to close the Layouts dialog without applying the layout.

     The layout is saved even if it is not applied at this time.

See also:

Working with columns

Using Layouts 

Applying a layout 

8.20 Using a work breakdown structure

Using a work breakdown structure
When you indent a row beneath another in your schedule, it creates outline levels. These outline levels

produce a hierarchical structure in your schedule known as a work breakdown structure (WBS). The key

strategy of a WBS is to divide the project into manageable pieces that can be individually planned,

estimated, and controlled. A WBS uses codes to represent an activity’s location in the hierarchy.

To create a WBS, organize your tasks using outline levels and insert a WBS column in your schedule.

In the Work Breakdown Structure dialog, assign each outline level a numeric or alphanumeric code that
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will label its position in the hierarchy. The default setting is to use numbers separated by a period.

To insert the WBS column:

1. Click on the column heading to the left of which you want to insert a column.

2. On the Insert tab, in the Rows & Columns group, click Column.

    The Insert Column dialog opens.

3. From the Insert Column table, select WBS.

4. Click OK to create the new column and close the Insert Column dialog.

To set codes for the WBS column:

1. On the Project tab, in the Details group, click WBS.

    The Work Breakdown Structure dialog opens.

2. If you wish, in the WBS Code Prefix box, enter text to precede each WBS code.

3. In the Sequence column next to outline level 1, select the type of characters for the WBS code.

4. In the Length column, select or type the maximum number of characters in the WBS code for outline

level 1.

    You will receive an alert message if the number of characters exceeds this amount.

5. In the Separator column select the character that separates the code in one outline level from the

code in the next outline level. 

6. Click OK to apply your changes and close the Work Breakdown Structure dialog.

Note:

Like all other columns, properties for the WBS column can be set in the Format Column dialog. You can

also access the Work Breakdown Structure dialog by clicking the Format WBS button in the Display tab

of the Format Column dialog.
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See also:

Working with columns

Displaying columns 

8.21 Changing the width of columns

Changing the width of columns
Changing the width of a column allows you to resize it to make the text in its heading and the data in its

cells fit better.

To change the width of a column:

1. Position the cursor over the right vertical gridline of the column heading you want to resize.

2. When the Horizontal Resize cursor appears, hold down the mouse button and drag the gridline to the

right to make the column wider or to the left to make the column narrower.

Note:

You can also resize the column width in the Display tab of the Format Column dialog.

See also:

Working with columns

Changing the width of timescale & timeline columns 

8.22 AutoFitting column width

AutoFitting column width
AutoFitting column width automatically resizes the width of columns to fit the longest line of text in a
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column. You can choose this option after the text is entered. Once you select the option, that width will

remain until you resize the column.

To autofit column width:

1. Select the heading of the column you want to autofit.

2. On the Tools tab, in the Arrange group, click AutoFit and choose Column Width from the drop-down

list.

    This will resize the column width to fit the longest line of text with no carriage returns.

See also:

Working with columns

AutoFitting row height 

8.23 Showing and hiding Action Columns

Showing and hiding Action Columns
Action Columns can be shown and hidden individually or as a group. When displayed, they appear to the

left of the application window. Action Columns, like all columns, cannot be displayed in the Calendar

View.

To show or hide Action Columns:

1. On the View tab, in the Show/Hide group, click Action Columns and select or deselect action

columns in the drop-down list.

    -or-

1. Right-click in any Action Column header and select or deselect action columns in the context menu.
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See also:

Working with columns

Using action columns 

Using layouts 

8.24 Using Action Columns

Using Action Columns
Action Columns simplify operations performed on activities and resource rows. There are four types of

Action Columns.

Action Column: Behavior:

Row Number/Row

Select

Shows row numbers in the Action Column area to the

left of the schedule. Clicking a row number selects that

row. To select a block of rows, click a row number and,

holding the mouse button down, drag up or down. Once

selected, rows can be moved by dragging them up or

down. To resize rows, click the bottom gridline in a row's

Row Number action column and, when the vertical resize

cursor appears, drag up or down.

 Page Break Click in a row's Page Break action column to place a

page break in the row. Rows with page break icons are

the last row on the printed page.
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 Information Form Opens the Information form in the Schedule View and

the Resource Information form in the Resource View.

Entering data in an Information form is ideal because, no

matter which columns you have hidden in the current

layout, you can enter data for every column in one

location. (Unless you have specifically chosen not to

display a column in the Information Form.)

 Expand/Collapse Shows expand and collapse triangular handles in the

Action Column area to the left of the window. When a

row's outline level is collapsed, its triangular handle

points to the right. Click this handle to expand, or "roll

down," its collapsed subactivities or, in the Resource

View, subrows. When a row is expanded, its Expand/

Collapse action column contains a triangular handle

pointing down. Click this handle to collapse, or "roll up,"

its subactivities or subrows. When a row has no

activities indented beneath it, or no data in its subrows,

its Expand/Collapse action column is empty.

See also:

Working with columns

Showing action columns 

Using layouts 
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9 Activity Bars & Milestones

9.1 Working with activity bars and milestones

Working with activity bars and milestones

An activity bar is used to denote a task that occurs over a period of time. Activity bars consist of three
elements:

A milestone is used to denote a task that occurs in a single moment of time, such as a meeting or a
deadline. These types of tasks have no duration. Thus, milestones consist of just one point that has a
start but not a finish.

Activity bars and milestones are the graphical representation of the activities you are scheduling. One
of FastTrack Schedule's most powerful features is the ease and totality with which users can
manipulate graphic items. The application does not attach any meaning to the appearance of a bar
style so you are free to customize bars, endpoints, and milestones.

What do you want to do?

 Draw activity bars

 Drag activity bars

 Type dates to draw activity bars

 Edit activity bar styles

 Design custom point styles

 Add, editing, and removing labels from activity bars

 Link activity bars

9.2 Drawing activity bars and milestones

Drawing activity bars and milestones

Drawing an activity bar in the timeline of the Schedule View, or within the calendar of the Calendar
View, enters a start date and time, finish date and time, and duration in timeline units for the activity in
that row. When you draw a bar in the timeline graph, FastTrack Schedule calculates its position. That
position is then converted to a date and time and entered in the corresponding columns.
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To draw an activity bar:

1. On the Home tab, in the Tools group, click the Bar tool.

2.  On the Home tab, in the Bar Styles group, select the bar with the desired style from the list.

3. Position the cursor in the timeline or calendar where you want the bar to begin.

4. Clicking and holding the mouse button down, drag to the right and release your mouse.

    This draws a bar and generates the activity's start, finish, and duration. Values appear in the Start
Date and Time, Finish Date and Time, and Duration columns if you choose to show those columns in
your current Layout.

To draw a milestone (a single point, such as a deadline):

1. On the Home tab, in the Tools group, click the Bar tool.

2.  On the Home tab, in the Bar Styles group, select a bar style that contains a single point, such as a
single diamond-shape.

3. Position the cursor in the timeline or calendar where you want the milestone to appear.

4. Click once to draw the milestone.

    This enters the Start Date and Time for the activity. Values appear in the Start Date and Time
columns if you choose to show those columns in your current Layout.

Note:

Bars drawn with the Bar tool have a default Constraint type of Start On Or After. Creating a bar by
entering dates, times and durations gives the resulting bar a default Constraint type of As Soon As
Possible.

See also:

Working with bars and milestones

Typing dates to draw bars

9.3 Dragging activity bars and milestones

Dragging activity bars and milestones

Moving activity bars changes their start, finish, and/or duration. When you drag a bar in the timeline or
calendar, FastTrack Schedule calculates its new position in the timeline or calendar and converts it to
a date and time that is then displayed in the corresponding columns. 

If you drag a bar outside of the parameters of its Constraint Type, the constraint will convert to a type
that supports the bars new position.

If a resource has been assigned to a task and the task's activity bar displays in the Resource View,
you can drag the assigned bars in the resource timeline, which also affects an activity's start, finish,
and/or duration. If you drag bars in the Calendar View, an activity's start, finish, and/or duration is also
affected.
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Important:

Dragging bars in any View affects the bars in all Views.

Dragging a bar to change its start, finish, and/or duration:

1. Using the Arrow tool, click and drag the part of the bar that you want to change.

Dragging
this:

Changes this:

Middle Style Start Date & Time, Finish Date & Time

Start Point Start Date & Time, Duration

End Point Finish Date & Time, Duration

Milestone Start Date & Time

Note:

Move multiple bars by holding the Shift key and clicking them or drawing a selection box to include
bars in the box. When you move one bar, they will all move.

See also:

Working with bars and milestones

9.4 Typing dates to draw activity bars and milestones

Typing dates to draw activity bars and milestones

Typing or editing existing values in the date, time, or duration columns draws or changes the position
of the activity bar in the timeline graph. This can only be done in the Schedule View or Information
form.

Entering a value in the Duration column will draw a bar beginning “now,” as defined by your computer,
and ending the specified number of duration units later. You can type to draw a bar on a specific date
or time by entering both a Start Date and a Finish Date or a Start Date/Time and a Duration in the
respective columns.

Because its dates, times and durations determine a bar's position in the timeline or calendar, changing
a bar's dates, times and durations changes the position of the bar.
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To draw an activity bar by typing:

1. On the Home tab, in the Bar Styles group, select a bar style from the list.

2. With the appropriate columns inserted in the layout, enter a value in a cell of the Duration column.

3. Click out of that cell.

    A bar is drawn starting on "today" and lasting the number of Duration units you entered.

    -or-

1. Select a bar style from the Bar Styles drop-down list.

2. Enter a value in the Start Date or Start Time column and a value in the Duration column.

3. Press the Enter key on your keyboard or click out of the cell.

    A bar is drawn beginning on the specified Start Date/Time and lasting the number of Duration units
you entered.

To draw or move a milestone by typing:

1. On the Home tab, in the Bar Styles group, select a milestone from the list.

2. Enter a value in the Start Date or Time cell.

3. Press the Enter key on your keyboard or click out of the cell.

Notes:

- The Duration is entered as the number of units you would like the activity to last. For instance, if the
schedule is displaying durations in units of Days, entering "4" in the Duration column draws a bar
beginning on the present day and ending four days later.

- Entering just a Duration gives the resulting bar a default Constraint type of As Soon As Possible.
Bars drawn with the Bar tool have a default Constraint type of Start On Or After.

See also:

Working with bars and milestones

Showing columns

9.5 Changing a bar or milestone to a different style

Changing a bar or milestone to a different style

At any time, you can change a bar already drawn in the timeline and calendar to a different bar style
which already exists in the Bar Styles Toolbar.

To change a bar to an existing bar style:

1. Select the activity bar(s) or milestone(s) whose style you want to change.

2. On the Home tab, in the Bar Styles group, select a different bar style from the list.

Note:

If you change activity bars to milestones, it erases the selected bars' finish and duration data.
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See also:

Working with bars and milestones

Designing a new bar style

Editing a bar style

9.6 Deleting a bar or milestone

Deleting a bar or milestone

You can only delete a bar or milestone in the timeline graph of the Schedule View or in the Calendar
View. 

To delete a bar or milestone:

1. Select a bar or milestone in the timeline.

2. Press the Backspace or Delete key.

    -or-

    Right-click and select Delete.

    All the Date/Time and Duration data for that bar will be deleted as well.

See also:

Working with bars and milestones

Dragging activity bars and milestones

9.7 Going to a bar

Going to a bar

This command scrolls the Schedule View or Resource View to display the bar or bars in a selected
row. 

To scroll to see a specific bar:
1. Select the row in the Schedule or Resource View containing the bar or bars to which you would like
to go.
2. On the Home tab, in the Editing group, click Go To and choose Bar.

    -or-

    Use the keyboard shortcut: Control + D

    In the Schedule View, the first bar in the row will appear on screen. If there is more than one bar in a
row, continue to use the keyboard shortcut and this will bring you to each subsequent bar in the row.

    In the Resource View, the first task assigned to a resource will appear on screen. If there is more
than one task assigned to a resource, continue to use the keyboard shortcut and this will bring you to
each subsequent task
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Note:
In the Schedule View, if a bar you go to lies outside of the Timeline Range, the Timeline Range will
change to include the dates of that bar.

See also:

Working with activity bars and milestones

Dragging activity bars and milestones

9.8 Formatting a bar style

Formatting a bar style

Formatting a bar style allows you to create a new bar style or edit the appearance of an existing style.

What would you like to do?

 Design a new bar style

 Edit an existing bar style

 Create custom point styles

 Use bar labels

 Define bar alignment

See also:

Working with bars and milestones

9.9 Creating a new bar style

Creating a new bar style

When you design a new bar style, you create it in the Format Bar Style dialog and it is added to the
library of bar styles displayed in the Bars Styles Toolbar. A new bar style can be created in the
Schedule, Resource, and Calendar Views.

While you can select options in any order, to design a basic bar, we recommend you do the following.
For more information, open the Format Bar Style dialog.

To create a new bar style:

1. Select a bar in your schedule.

2. On the Format tab, in the Display group, click Format Selected.
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    The Format Bar Style dialog opens.

2. From the Type drop-down list, choose Bar (to track start, finish, and duration) or Milestone (to track
a single date like a deadline).

3. From the Component drop-down list, select Scheduled, Revised, or Actual.

4. Click the Parts tab.

5. From the Part to Edit drop-down list, choose the part of the bar style you wish to format.

6. If you choose to edit a part of the Actual or Revised component, you will receive the following
choices in the component options section:

Options: Does this:

Show Revised as a Bar Displays the Revised component as a bar positioned
relative to the Scheduled bar.

Show Revised as Points Displays the Revised component as points extending off of
the Scheduled points. 

Always Show Revised Shows the Revised component all of the time.

Show Revised Only if
Different than Scheduled

Shows the Revised component only when the bar's Revised
dates differ from the Scheduled dates.

Show Actual as a Bar Displays the Actual component as a bar positioned relative
to the Scheduled bar.

Show Actual as a Fill Displays the Actual component as a pattern and color
filling the Scheduled or Revised bar.

7. If you receive these options, based on your selections above, choose attributes in the Points, Fill,
Border, and Offsets areas.

8. If you want to format other components of the bar or milestone, select them from the Component
drop-down list and select their formatting options. 

9. Click OK to accept the new bar style and add it to the Bars Styles Toolbar.

Notes:
- The Scheduled component is the basic component of a bar or milestone. The other components are
used for progress tracking.

- If you format a milestone, you need only design its point. 
- To see the design of all the components in the example area, select the Show All Components While
Editing checkbox. This allows you to view all the components while you are editing one of them. 
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See also:

Working with bars and milestones

Editing a bar style

Formatting a bar style

9.10 Editing an existing bar style

Editing an existing bar style

Editing an existing bar style changes the appearance of the bar style using the Format Bar Style
dialog. You can edit a bar style in the Schedule, Resource, and Calendar Views. Editing a bar style
changes every instance of that bar style.

The steps below show you how to edit a basic bar. For more information, open the Format Bar Style
dialog.

To edit the appearance of a bar style:

1. In your schedule, select the bar you want to edit.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Bar Style dialog opens.

3. From the Part to Edit list, select the bar element you want to edit.

    -or-

    In the picture of the bar at the top of the dialog, click on the bar element you want to edit.

4. Based on the choice you have made, use the options described below.

To change this: Do this:

Point Shape From the Shape list, select an existing point
style and size. Click the New button to create
a new point style or the Edit button to edit an
existing point style.

Bar/Point/Fill From the Bar/Point/Fill area, select a color,
pattern, and size.

Bar/Point Border From the Border area, select a color, pattern,
and size.

Part Position Relative From the Offsets area, select the horizontal
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to Bar Style and vertical alignment.

5. Click OK to apply your changes and close the Format Bar Style dialog.

Notes:
- Depending on which part you choose to edit, different formatting options are available in the Parts tab.
- Odd number values entered into Size boxes draw better on the screen.
- You can also copy over bar styles from the 200 More Bar Styles template available in FastTrack
Schedule.

See also:

Working with bars and milestones

Formatting a bar style

9.11 Understanding constraints

Understanding bar constraints

Constraints are the parameters you can assign to activities to control the behavior of bars as your
project changes. Constraints in FastTrack Schedule are based on the CPM (Critical Path Method)
project management model and follow the CPM standards.

A constraint categorized as Soft will allow activities in your schedule to begin and end within an elastic
window of time, until the activity’s start or finish comes into conflict with another dependency.

A constraint categorized as Moderate will not allow activities in your schedule to begin and end before
or after the date or time you have specified.

A constraint categorized as Hard will not allow activities in your schedule to begin or end on any date
or time except those which you specified. A hard constraint effectively locks your bar finish or start
and, if the bar is linked, bypasses the defined dependency if that dependency conflicts with its
specified start or finish.

Constraint

name:

Catego

ry:

Behavior:

As Soon As
Possible

Soft The activity is scheduled to begin at the earliest possible

moment, taking into account other scheduled activities. There is

no specified Constraint Date, however the Project Start Date often
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acts as the Constraint Date. This is the default constraint type

when bars are created by entering the Duration.

As Soon As
Late

Soft The activity is scheduled to begin at the latest possible moment,

taking into account other scheduled activities. There is no

specified Constraint Date.

Start On Or

After

Modera

te

The activity is scheduled to begin no earlier than on the

Constraint Date you specify. If necessary, it may begin later. This

is the default constraint for new activities that are entered by

drawing bars.

Start On Or

Before

Modera

te

The activity is scheduled to begin no later than on the Constraint

Date you specify. If necessary, it may begin earlier.

Finish On Or

After

Modera

te

The activity is scheduled to end no earlier than on the Constraint

Date you specify. If necessary, it may end later.

Finish On Or

Before

Modera

te

The activity is scheduled to end no later than on the Constraint

Date you specify. If necessary, it may end earlier.
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Must Start On Hard The activity will only begin on the specified Constraint Date.

Must Finish

On

Hard The activity will only end on the specified Constraint Date.

See also:

Working with bars and milestones

Formatting a bar style

Setting bar constraints 

Showing data columns 

9.12 Setting bar constraints

Setting bar constraints

Constraints are the parameters you can assign to activities to control how much or how little slippage
you will allow in their Start Dates and Times.

To set constraints on an activity:

1. Double-click on the activity bar or milestone.

    The Information form opens to the Bars>Tracking tab.

2. From the Constraint Type drop-down list, select the desired constraint type.

    -or-

1. Insert the Constraint Type, Constraint Date and, if needed Constraint Time columns into your
schedule.

2. Enter the appropriate data into the Constraint Date and/or Constraint Time column.

3.  Click in the Constraint Type column and use the drop-down indicator to select the desired 
constraint type.

See also:

Working with bars and milestones

Formatting a bar style

Understanding constraints 

Showing data columns
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9.13 Creating custom point styles

Creating custom point styles

Designing new point styles allows you to customize the appearance of your bar styles. New point
styles can be either polygons (shapes similar to the pre-defined styles) or pictures (images you paste
from the Clipboard).

To design a new polygon point:

1. Open the Format Bar Style dialog for the bar style to which you want to add custom points.

2. From the Part to Edit drop-down list, select either the Schedule or Revised Start or End Point.

3. In the Shape area, click the New button.

4. From the Type drop-down list, select Polygon.

5. In the grid, click to add dots and create the polygon.

    The last dot will automatically connect to the dot created before it. 

6. To close the polygon, select the Connected checkbox.

7. Click the Remove button to remove a selected dot.

8. Click the Clear button to remove the polygon and begin again.

9. Click the Revert button to return to the original point. 

    Only use Revert when editing an existing polygon point.

10. Click the Split button to insert a point in the middle of a line.

11. Click the Weld button to create a middle point in a selected line and delete the start and end point
of the line. 

12. From the drop-down list, choose a ratio for displaying the polygon in this dialog.

13. Click OK to close the Format Point dialog.

14. Click OK to apply your changes and close the Format Bar Style dialog.

To design a new picture point:

1. Copy the picture you would like use as a point to the Clipboard, following the same rules as if you
were pasting a picture to the schedule.

    Pictures should be no larger then 1024K.

2. Open the Format Bar Style dialog for the bar style to which you want to add custom points.

3. From the Part to Edit drop-down list, select either the Schedule or Revised Start or End Point.

4. Click the New button.

5. From the Type drop-down list, select Picture.

6. Click the Paste button.

7. Click OK to close the Format Point dialog.

8. Click OK apply your changes and close the Format Bar Style dialog.

See also:

Working with bars and milestones
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Formatting a bar style

Designing a new bar style

Editing a bar style

Pasting pictures to the timeline graph

9.14 Working with bar labels

Working with bar labels

To emphasize certain data, you can attach text to a bar style. You can add date, time, duration, %
complete, and other row or bar information as the label. Labels can be attached to a bar or milestone.
You can have as many labels on an item as you wish. 

In the Format Bar Style dialog you can create separate Schedule labels and Resource labels. You can
also apply Schedule labels to bars in the Resource View. Bar labels created in the Format Bar Style
dialog do not display in the Calendar View. Use the Format Calendar View dialog to create bar labels in
the Calendar View.  

To show data on a bar:

1. Select a bar in your schedule.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Bar Style dialog opens.

3. Click the Schedule View Labels or Resource View Labels tab.

4. If you wish to apply labels set in the Schedule View Labels tab to bars in the Resource View, click
the Use Schedule View Labels checkbox.

5. From the Show Label on Part drop-down list, select on which part of the bar you would like to
display data.

6. From the Available Columns table, select the data you would like displayed on the bar.

7. Click the Show button to send the data to the Shown Columns table.

8. In the Offsets boxes, enter the Horizontal and Vertical distance from the selected element.

9. If desired, click the Format Label button to open the Format Bar Label dialog and access the options
described below:

This tab: Does This

Font Controls the font, size, style and color of the text in your
labels. You can choose to apply these font attributes to a
selected cell only (e.g. Activity Name) or to all bar labels
(every label on every element of that bar style).

Borders Allows you to: place a border and a shadow around a bar
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label, set the border and shadow line widths, set the corner
radius of the border, and select background and line colors.
You can also choose to apply the border attributes to all bar
labels (every label on every element of that bar style) or to a
selected cell only (e.g. Activity Name).

Display Determines the appearance of any numbers, dates, times,
and duration data in the Shown Columns table.

10. If you have chosen to format the bar label, click OK to apply your changes and close the Format
Bar Label dialog.

11. Click OK to apply your changes and close the Format Bar Style dialog.

Notes:
- You can add as many pieces of data as you would like to a part of the bar by making multiple
selections in the Show Label on Part drop-down list. They will be separated with the character defined
as the List Separator in the Numbers tab of the Application Options. They are ordered from top-to-
bottom.
- To erase a label, select the data you wish to erase from the Shown Columns table and click Hide.
Click Hide All to remove all data from the Shown Columns table. No bar labels will be displayed.
- In the Schedule View, in order for a bar label to be spell checked, the activity outline level to which it
corresponds must be visible.
- When placed in a label, column data stored per bar reflects the current bar position, no matter where
you might move the bar. Label data stored per row, however, will reflect the row in which the bar is
located.

See also:

Working with bars and milestones

Formatting a bar style

Designing a new bar style

Editing a bar style

9.15 Defining activity bar alignment

Defining activity bar alignment

Defining the alignment of a bar style allows you to fine-tune the position of an activity bar relative to the
alignment grids. You can define the alignment of a bar style from the Schedule, Resource, and
Calendar Views.

To define the alignment of a bar style:

1. Select the bar style for which you want to define the aligned position.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Bar Style dialog opens.
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3. Click the Alignment tab.

4. Using the check boxes, select which elements of the bar will snap to the alignment grids.

5. If you want to change the position of the bar relative to the alignment grid, enter horizontal and
vertical offset values.

6. Click OK to apply your changes and close the Format Bar Style dialog.

Notes:
- As you make your changes, notice how it affects the bar in the Example window relative to the
alignment grids.
- Existing bars will not automatically snap to the revised alignment settings. You must select the
existing bars, from the Tools menu select Arrange, and choose Align from the submenu.
- Choosing both Start Point and End Point can change the duration of the activity fit between alignment
grids.

See also:

Working with bars and milestones

Formatting a bar style

Using alignment grids

10 Progress Tracking

10.1 Scheduled, Revised, and Actual dates

Scheduled, Revised, and Actual dates
You would usually change the dates of an activity by dragging that activity’s bar. Some situations, and

some companies, require a way of tracking these changes. This is called progress tracking.

At all times, FastTrack Schedule automatically tracks the progress of activities as three sets of dates:

- Scheduled – Dates that reflect when your schedule was originally planned, also called the "baseline"
or "promised" dates.
- Revised – Dates as they are currently projected, accounting for adjustments since the project began.
- Actual – Dates as they actually happened, also tracked as a percentage complete, or "work-in-place."

What would you like to do?

 See an example of progress tracking

 Define Scheduled dates
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 Define Revised dates

 Define Actual dates & % Complete

 Display Scheduled, Revised, and Actual dates on activity bars

10.2 Progress tracking example

Progress tracking example
This example tracks the progress of an activity in the design phase of a new product.

Example: Schedule #1. As an example, the graphic below represents what a schedule would look like

when you first plan the project. At this stage, the activity bars represent the Scheduled starts and

finishes. In this example, the Scheduled component is the blank bar, the Revised component does not

display at this time for this bar style, and the Actual component will not display until work has begun.

Schedule #2. Now some of the start dates have slipped and the Revised bar element now displays.
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Schedule #3. Now take a look at the schedule since work has begun. We have completed the first

three activities, as shown by the red Actual fill pattern. We can also see that activity 2, Research, was

completed on time – the Scheduled, Revised, and Actual dates are all the same. We have also

completed 50% of the Design activity, as shown by the red Actual fill in half of the Revised bar. 

Notice that links always connect the Revised elements of activity bars.

Schedule #4. The last schedule shows that all activities have been completed. Their bars show the

difference between their Scheduled and Revised dates.

See also:

Defining Scheduled dates 

Defining Revised dates 
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Defining Actual dates & % Complete 

Displaying on activity bars 

10.3 Defining Scheduled dates

Defining scheduled dates
When you draw a bar with the Bar tool or enter data in Start, Finish, or Duration columns, you are

entering the Scheduled dates. The label "Scheduled" is omitted from the columns so as not to confuse

novice users.

To define Scheduled dates by drawing:

1. In the Schedule or Calendar Views, on the Home tab, in the Tools group, select the Bar tool

2.  On the Home tab, in the Bar Styles group, select the bar style cell that contains the desired style for

the bar.

3. Position the cursor in the timeline or calendar where you want the bar to begin.

4. Clicking and holding the mouse button down, drag to the right or left and then release your mouse.

    If you want to draw multiple bars, check the Lock Tools box after selecting the Bar Tool.

To define Scheduled dates by typing:

1. In the Schedule View, enter values in the activity's Duration, Start Date, Start Time, Finish Date,
Finish Time columns.

See also:

Defining Revised dates 

Defining Actual dates & % Complete 

Displaying on activity bars 
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10.4 Defining Revised dates

Defining revised dates
Defining an activity's Revised dates updates the currently projected start, finish, and/or duration of the

activity. 

For instance, if changes to earlier activities will force the activity to slip, starting and ending later, these

changes can be made to Revised dates. This leaves the Scheduled dates as they were originally

planned, allowing you to see the difference between the original schedule and the currently projected

schedule.

You can always define a task’s Revised dates from the Schedule and Calendar Views. If a task has

been assigned to a resource, you can also revise its dates from the Resource View.

To define Revised dates by dragging:

1. In the Schedule or Calendar Views, on the Home tab, in the Tools group, select the Revise tool.

2. Click a position in the bar whose Revised dates you want to enter or edit and holding the left mouse

button down, drag to the right or left and release your mouse.

    If you want to draw multiple bars, check the Lock Tools box after selecting the Revise Tool.

To define Revised dates by typing:

1. If not already displayed, show the Revised date, time and/or duration columns using layouts or the

Insert Column dialog.

2. Enter values in the activity's Revised Start Date, Revised Start Time, Revised Finish Date, Revised

Finish Time, or Revised Duration columns.
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    -or-

    Click in the Information Form action column, select the Bars>Columns tab, and enter values in the

Revised Date/Time and Duration boxes.

Notes:

- The Revised dates are automatically entered when you enter Scheduled dates. Until there are changes,
the Revised (currently projected) dates are the same as the Scheduled (original) dates.
- The display of the Revised data on the bar is defined by the format of the bar style.The Revised dates
appear as another bar or extending points and can be shown all of the time or just when they differ from
the Scheduled dates.

See also:

Defining Scheduled dates 

Defining Actual dates & % Complete 

Displaying on activity bars 

10.5 Defining Actual dates and Percent Complete

Defining actual dates and % complete
Defining Actual dates and % Complete defines how much work has been done on a task. You can

always define a task’s Actual dates from the Schedule and Calendar Views and, if a task has been

assigned to a resource, you can also edit its Actual dates from the Resource View.

Note: 

% Complete can be tracked by itself, without any reference to Scheduled, Revised, and Actual dates.

This works well for simple schedules that still require a way of displaying how much work has been done

on a task.

To define % Complete by drawing:
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1. If not already displayed, show the % Complete column using layouts or the Insert Column dialog.

2.  In the Schedule or Calendar Views, on the Home tab, in the Tools group, select the Percent tool.

3. Click a position in the bar whose % Complete dates you want to enter or edit and holding the left

mouse button down, drag to the right or left and release your mouse.

    If you want to draw multiple bars, check the Lock Tools box after selecting the Percent Tool.

To define % Complete by typing:

1. If not already displayed, show the % Complete column using layouts or the Insert Column dialog.

2. Enter a number in the % Complete column.

    -or-

1. Click in the Information Form action column, select the Bars>Columns tab, and enter a value in the %

Complete box.

To define Actual dates by drawing:

1. In the Schedule or Calendar Views, on the Home tab, in the Tools group, select the Percent tool.

2. Click anywhere to the right of the start point of the bar to enter the Actual Start Date and Time.

    -or-

    Click the end of the bar to enter the Actual Finish Date and Time and Actual Duration.

To define Actual dates by typing:

1. If not already displayed, show the Actual columns using layouts or the Insert Column dialog.

2. Enter values in the activity's Actual Start Date, Actual Start Time, Actual Finish Date, Actual Finish

Time, or Actual Duration columns.

    -or-

    Click in the Information Form action column, select the Bars>Columns tab, and enter values in the

Actual Date/Time and Duration boxes.



Progress Tracking 167

Copyright © 2010, AEC Software, Inc. All rights reserved.

Notes:

- The display of the % Complete and Actual dates is defined by the format of the bar style.
- The Actual dates are always the same as the Revised dates because the Revised dates represent the

current projections – actual work on a task is done in relation to the currently projected dates and times.

- If showing %Complete on the bar as a fill pattern, the fill is drawn in the Revised component if the

Revised component is displayed.

See also:

Defining Scheduled dates

Defining Revised dates 

Displaying on activity bars 

10.6 Displaying Scheduled, Revised, Actual bars

Displaying scheduled, revised, and actual bars
You can define how each bar style displays the Scheduled, Revised, and Actual components. This gives

you an almost infinite amount of ways to track progress on the activities in your schedule. You can edit

the display of bar styles from the Schedule, Resource, and Calendar Views.

To open the Format Bar Style dialog:

1. Select a bar in your schedule.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Bar Style dialog opens.

To design the Scheduled component of a bar (this is the basic bar component):

1. From the Type drop-down list, choose to design a Bar (to track start, finish, and duration) or a
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Milestone (to track a single date like a deadline).

2. From the Component drop-down list, select Scheduled.

3. In the Parts tab, choose from the available options.

To design the Revised component of a bar:

1. From the Type drop-down list, choose to design a Bar (to track start, finish, and duration) or a

Milestone (to track a single date like a deadline).

2. From the Component drop-down list, select Revised.

3. Select from the Component Options described below.

Options: Does this:

Show Revised as a Bar Displays the Revised component as a bar positioned

relative to the Scheduled bar.

Show Revised as Points Displays the Revised component as points extending off of

the Scheduled points.

Always Show Revised Shows the Revised component all of the time.

Show Revised Only if Different

than Scheduled

Shows the Revised component only when the bar's Revised

dates differ from the Scheduled dates.

4. In the Parts tab, choose from the formatting options that appear.
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To design the Actual component of a bar:

1. From the Type drop-down list, choose to design a Bar (to track start, finish, and duration) or a

Milestone (to track a single date like a deadline).

2. From the Component drop-down list, select Actual.

3. Select from the Component Options described below.

Options: Does this:

Show Actual

as a Bar 

Displays the Actual component as a bar positioned relative

to the Scheduled bar.

Show Actual

as a Fill

Displays the Actual component as a pattern and color filling

the Scheduled or Revised bar.

4. In the Parts tab, choose from the formatting options that appear.

See also:

Example of progress tracking 

Defining Scheduled dates 

Defining Revised dates 

Defining Actual dates & % Complete 

10.7 Resetting Actual dates

Resetting actual dates
Within Scheduled, Revised, and Actual progress tracking, resetting the Actual date returns the selected

bar's Actual dates to the Revised dates. For instance, you could have changed the Actual dates of an
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activity by defining a % complete. 

If you wish to return the activity to 0% percent complete, Reset Actual does this automatically.

Remember that unless you have explicitly changed them, the Revised dates are the same as the

Scheduled dates.

To reset a bar's Actual dates to its Scheduled dates:

1. Use the Arrow tool to select the desired bar or bars. 

    -or-

    Right-click and choose Select All from the Context menu.

2. On the Tools tab, in the Tracking group, click Reset Actual.

See also:

Scheduled, Revised, and Actual dates 

Resetting revised dates 

10.8 Resetting Revised dates

Resetting revised dates
Within Scheduled, Revised, and Actual progress tracking, resetting the Revised date sets the selected

bar's Revised dates to match the original Scheduled dates. For instance, you could have changed the

Revised dates of an activity, slipping it later. If those revisions no longer apply, you want to return the

Revised dates back to their original Scheduled dates. Reset Revised does this automatically.

To reset a bar's Revised dates to its Scheduled dates:

1. Use the Arrow tool to select the desired bar or bars. 
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    -or-

    Right-click and choose Select All from the Context menu.

2. On the Tools tab, in the Tracking group, click Reset Revised.

Notes:

- If the Revised component of the bar style is currently visible in the schedule but the Show Revised Only
if Different than Scheduled option is selected in the Format Bar Style dialog, resetting the Revised dates
will hide the Revised component.
- Applying Reset Revised to a bar resets the Actual and Revised dates and times to the Scheduled
dates and times. The % complete is returned to zero.

See also:

Scheduled, Revised, and Actual dates 

Resetting actual dates 

11 Linking Bars

11.1 Linking

Linking activities

Linking two activity bars creates a dependency whereby, if the dates of one activity change, all
dependent activities’ dates change accordingly.

What would you like to do?

 Manage links

 Define types of links

 Link activity bars

 Drag linked bars

 Unlink bars

 Show or hide links

 Format the appearance of links
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11.2 Managing links

Managing links

Linking is a means of controlling how changes to the dates and times of one activity impact the
scheduling of other activities in your schedule. To link is to create dependencies between activities in
your schedule.

For example, if you were scheduling a construction project and a key activity, such as framing, were to
slip, then all the projects that can only occur when framing is done, such as drywall-ing, plastering and
painting, will all need to be rescheduled accordingly. By linking all these activities in your schedule,
you save yourself from having to manually change each affected activity. 

Linking in FastTrack Schedule is based on the CPM (Critical Path Method) project management model
and follows the standards therein.

Use constraints and lag time to control how activity bars and milestones react to changes in the
originally scheduled dates and times.

The Information Form 

The Bars>Links tab of the Information form allows you to set and modify important link information. You
can create links by opening the Information form for a particular bar and then entering information about
the predecessor and successor bars to which you want to link that bar.

Predecessor Bar – In the From/To relationship that defines a link Type, for example From Finish To
Start, the predecessor bar is the "From" and the bar whose information you are currently viewing in the
Information form is the "To." So if a link in the Predecessors table is classified as Type “Finish to
Start,” the link originates from the Finish point of the predecessor bar.

Successor Bar – In the From/To relationship that defines a link Type, the successor bar is the "To"
and the bar whose information you are viewing in the Information form is the "From." So if a link in the
Successors table is classified as Finish to Start, the link extends to the Start point of the successor
bar.

The labels predecessor and successor have nothing to do with a bar location in the timeline or its
dates. The terms relate only to the From/To direction that defines a link Type.

Below is an explanation of each column in the Predecessors and Successors tables located in the
Bars>Links tab of the Information form.

In this
column:

Do this:

Click the icon to open the Information form for the
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predecessor or successor bar.

Row Enter or edit the row number of the predecessor or
successor bar.

Bar Enter or edit the Bar ID of a bar you want to be linked from
(predecessor) or link to (successor).

Activity
Name

View the activity name of the predecessor or successor
bar. When you have entered a Bar ID and/or Row number,
the name of the activity is filled in. Once it appears in the
cell, you can edit the activity name of a predecessor or
successor bar.

Type Select the origin and destination of the link. FastTrack
Schedule supports Finish to Start, Finish to Finish, Start
to Start, and Start to Finish links.

Lead/Lag Enter or edit the lead or lag time for this link. This is the
number of duration units that this link can move, or slip,
before the constraint parameters you have set for the
linked tasks are affected.

Link
Duration

Displays the duration of the link in duration units.

Notes:
- In this help system, a > indicates a tab within a tab. For example, the Bars>Links tab signifies that
there is a Links tab within the Bars tab.
- The unit for the Lag and Duration are listed in the bottom of the dialog. The unit can be changed in the
Format Schedule View dialog.

See also:

Showing and hiding links

Linking activity bars 

Dragging linked bars 

Defining types of links 

Entering data in the Bars>Links tab of the Information Form 
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11.3 Defining types of links

Defining types of links

FastTrack Schedule supports four types of links - Finish to Start, Start to Start, Finish to Finish, and
Start to Finish links.

This link

type:

Looks like this: And works this way:

Finish to

Start

 

Activity 1 must finish

before Activity 2 starts.

This is the most

commonly used link type.

Start to Start

 

Activity 2 must not start

until Activity 1 starts. 

Finish to

Finish

Activity 2 must not finish

until Activity 1 finishes.

Start to

Finish

 

Activity 2 must not finish

until Activity 1 starts.
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See also:

Linking activities

Managing Links 

11.4 Understanding Lead and Lag time

Understanding Lead and Lag time
When setting up task dependencies, consider that there may be scenarios where certain tasks are
unable to start until their predecessor tasks have completed. In other cases, a task may need to start
before its predecessor task is completed.  In these descriptions, a task will need to consider its Lag or
Lead (Lag/Lead)duration:

Lag:  A unit of duration used as a delay between two tasks.  Lag durations are entered as positive
values. An example of this could be the predecessor task of pouring concrete prior to the successor
task of building a house.  If the concrete takes 2 days to cure and dry, the dependency link would
require a lag of 2 days.

Lead: A unit of duration used to provide an overlap, or “head-start”, between two linked tasks.  Lead
durations are entered as negative values.  An example of this could be the predecessor task of 
completing the shooting of a film, with a finish to start dependency on a successor task of editing film. 
If editing film can begin 7 days prior to the end of completing the shooting of a film, then the dependency
link would require a lead of -7 days.

Editing the Lead or Lag time of a link:

1. Double-click an activity bar whose lag/lead time you would like to edit.

2. In the Bars>Links tab of the Information form, edit the Lag/Lead time in the Predecessors or
Successors table.

    -or-

1. Double-click a link whose lag/lead time you would like to edit.

2. In the Link Information form, edit the lag/lead time for the selected link.

See also:

Linking activities

11.5 Linking activity bars

Linking activity bars

Bars can only be linked in the Schedule View. Linking activity bars creates a dependency from a point
on one bar (the "predecessor") to a point on a second bar (the "successor"). This dependency
illustrates the relationship that the dates of one task have to another.
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For instance, if the start of the task "Interview for Position" cannot begin until the task "Read
Resumes" has ended, the two are dependent and should be linked in a Finish to Start relationship.

To draw links between bars:

1. On the Home tab, in the Tools group, click the Bar Link tool.

2. Click the finish or start of one bar and drag to the start or finish of a second bar.

To link selected bars:

1. Select the bars between which you want to create dependencies.

2. On the Home tab, in the Link group, click Link.

To create links in the Information form:

1. Double-click an activity bar.

2. In the Bars>Links tab of the Information form, create a link by entering data in either the
Predecessors or Successors table.

Note:

Clicking Link after selecting bars automatically draws links from the finish point to the start point of the
selected bars. The application also supports Finish to Finish, Start to Start and Start to Finish links.

See also:

Showing and hiding links

Dragging linked bars 

Managing links 

11.6 Unlinking activity bars

Unlinking activity bars

Unlinking activity bars removes dependencies between activities, allowing you to drag the bars without
affecting other bars.

To delete a specific link:

1. Click the line that graphically represents the link you want to delete.

    This selects the link.

2. Press the Delete key.

    -or-

1. Double-click on one of the bars in the link relationship you wish to delete.

2. In the Bars>Links tab of the Information form, delete the ID of the other bar in the link relationship.

3. Click OK to delete the link and close the Information form.
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To unlink all dependent activities from a single bar:

1. Select the activity bar from which you want all links removed.

2. On the Home tab, in the Link group, click Unlink.

    -or-

1. Double-click on the bar whose links you wish to delete.

2. In the Bars>Links tab of the Information form, delete the ID of every bar in the Predecessors and
Successors tables.

3. Click OK to delete the links and close the Information form.

To unlink all dependent activities from several bars:

1. Select multiple bars whose dependencies you wish to delete.

2. On the Home tab, in the Link group, click Unlink.

Notes:
- By deselecting Links in the Show/Hide group on the View tab, links can be hidden without being
deleted.
- When you drag linked bars, the constraint type of the link is reset to Start On Or After. 

See also:

Showing and hiding links 

Linking activity bars 

Dragging linked bars 

11.7 Dragging linked bars

Dragging linked bars

Linking activities throughout the schedule allows you to see how changing one bar will affect the final
outcome of the schedule.

Dragging linked bars moves the selected bar and all bars which are dependent upon it. A dependent
bar will not move, however, if moving would conflict with that dependent bar's Constraint Type
parameters, or if the activity represented by the dependent bar has actually started.

When you drag a bar, moving that bar beyond its Constraint Type parameters will cause the Constraint
Type to change to “Start On Or After” – the default Constraint Type. 

To drag a linked activity:
1. Click either the linked point or the middle of the bar and drag to the left or right. 

Notes:
- Linking in FastTrack Schedule is based on the CPM (Critical Path Method) project management
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model and the behavior of linked bars adheres to that standard.
- Changing the Revised and Actual dates may change Revised or Actual dates of dependent bars.

- While dragging a linked bar, only the selected bar moves. Dependent bars, if their constraints allow
the move, move only once you stop dragging the selected bar and release the mouse.

See also:

Understanding constraints 

Tracking Scheduled, Revised, and Actual dates 

Linking bars

11.8 Showing and hiding links

Showing and hiding links

Hiding links hides the lines between dependent activities but retains the same linked behavior. This
allows you to view or print a less complicated looking schedule. You can only hide or show links in the
Schedule View.

To hide or show links:

1. In the Schedule View, on the View tab, in the Show/Hide group, click Links.

    When the links are displayed, the Links button is highlighted in the Show/Hide group.

See also:

Linking bars 

Unlinking bars 

Designing links 

11.9 Formatting links

Formatting links

Designing links allows you to customize the appearance of links to fit personal styles or standards put
forth by your company or organization.

To design links:

1. In the Schedule View, on the Format tab, in the Display group, click Link.

    The Format Link dialog opens.

2. Select from the options described below..
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To: Do this:

Change
arrowhead shape

Select a style from the Shape list under Arrows.

Change line
thickness

Select a line from the Size list.

Change the
pattern and color

Select a new pattern and color for the line and the
arrowhead from the lists.

Change the link
path

Select from diagonal, out-and-down, or down-and-out.

Optimize the
appearance of
lines when
printing with a
high-resolution
printer

Select Optimize Hairline.

3. Click OK to change your link style and close the Format Link dialog.

Note:

It is a good idea to design links and Critical Path(s) in such a way that you can tell them apart.

See also:

Showing and hiding links

Linking activity bars 

Dragging linked bars 

Formatting the display of critical path 

11.10 What is a critical path?

What is a critical path?

In FastTrack Schedule, the critical path is the route between linked bars, in a group of linked bars, with
the smallest total slack between tasks. Slack is determined by subtracting a link Minimum lead/lag
time from a link duration. 
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Suppose you have a software project due for delivery in two weeks. In the two weeks before it is due
you must accomplish two things: you must write the software and you must create a graphic for the
box in which the software will ship. Writing the software will take two weeks; creating the graphic will
take one day. 

 

Because you can create the graphic anytime in those two weeks, there is greater elasticity, or slack,
to that task. It must happen before the project is due, but it can happen on the last day and still not
affect your delivery date. Writing, however, is the more critical activity; it cannot slip without affecting
your delivery time. Thus, the task "Write" is on the critical path of your schedule. 

Because a critical path is defined by the dependency of one task on another, only linked bars are
considered part of a critical path. 

See also:

Critical path and bar priority 

Formatting the display of critical path 

Showing and hiding critical paths 

11.11 Critical path and bar priority

Critical path and bar priority

Bar priority is a way of ranking linked bars with identical start dates and times so that you direct the
application to highlight the chosen critical path. This is the only situation wherein a bar's priority
ranking has any affect on the schedule. 

To set a bar priority:

1. Double-click on an activity bar.

    The Information form opens in the Bars>Tracking tab.

2. In the Priority box, enter a number to indicate the specified bar's priority ranking.
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    The higher the Priority number the lower the importance of the task. A priority of "0" means that that
task is the most critical. A priority "1" bar is more critical than a priority "2" bar. A bar with no priority
ranking (null, the Priority box is empty in the Information form), however, is less important than a
priority "2" bar. 

3. Click OK to apply your changes and close the Information form.

Notes:
- You can show the Priority column in the Schedule View by inserting it in a layout.
- The Priority column supports up to 9 decimal places. This allows you to add a more critical task to
the schedule without needing to renumber every task you have already prioritized. To view Priority
values with decimal places, format the Priority column in the Format Column dialog so that it displays
decimal places.

See also:

What is critical path? 

Formatting the display of critical path 

Showing and hiding critical paths 

11.12 Showing and hiding the critical path

Showing and hiding the critical path

You can select whether or not to display the critical path between tasks in your schedule.

To show critical paths in your schedule:

1. In the Schedule View, on the View tab, in the Show/Hide group, click Critical Paths.

    When the critical path is displayed, the Critical Paths button is highlighted in the Show/Hide group.

Notes:
- A critical path displays only if bars in your schedule are linked.
- When show Critical Path is selected, the critical path or paths in your schedule update instantly as
you make changes.

See also:

What is critical path? 

Critical path and bar priority 

Formatting the display of critical path 

11.13 Formatting the display of a critical path

Formatting the display of a critical path

You control the appearance of the lines that represent the Critical Path. There are critical path displays
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available in any file. These can be edited to suit your needs. 

To format the display of a critical path:

1. In the Schedule View, on the Format tab, in the Display group, click Link.

    The Format Link dialog opens in the Critical Path tab.

2.   From the Critical Path Style drop-down list, select a level of critical path.

    -or-

    Click the New button to create a new critical path.

3. Select from the options described below.

To: Do this:

Change line
display

Choose the thickness of the line, and then set the color
and pattern of the line that displays the critical path.

Optimize the
appearance of
lines when
printing with a
high-resolution
printer.

Select the Optimize Hairlines checkbox.

Change the Arrow
display

From the Shape list, in the Arrows area, select the style
of arrowhead you would like to display. Then set the
arrowhead size, pattern, and color. You do not have to
display an arrowhead on the path; it is merely an option.

Change the Path
display

Choose to display the path between critical tasks as: a
diagonal line, a line that moves over-down-over, or a line
that moves down-over-down.

4. Click OK to save your critical path changes and close the Format Link dialog.

Note:

It is a good idea to design links and Critical Path(s) in such a way that you can tell them apart.

See also:

What is critical path? 

Critical path and bar priority 

Formatting the display of critical path 
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Showing and hiding critical paths 

12 Information Forms

12.1 Opening Information forms

Opening Information forms

The Information form has its own Action Column. In the Schedule View, clicking in the  Action
Column opens the Information form in the Activity tab. In the Resource View, the same action column
opens the Resource Information form in the Information tab.

To open the Information form in the Schedule View:

1. Click in a row's Information Form action column.

    -or-

1. Double-click a bar in the schedule to open the Information form in the Bars>Columns tab.

    -or-

1. Select a schedule row.

2. On the Project tab, in the Details group, click Activity Information.

    If resources are assigned to the selected activity, you can open their Resource Information forms by
clicking Resource Information in the Details group.

 

To open the Resource Information form in the Resource View:

1. Click in a resource row's Information Form action column.

    -or-

1. Select a resource row.

2. On the Project tab, in the Details group, click Resource Information.

See also:

Entering and editing data in the Activity tab of the Information form 

Entering and editing data in the Bars tab of the Information form 

Using Action Columns 

12.2 Working in the Row tab of the Information form

Working in the Row tab of the Information form

In the Row tab you have access to data for all of the columns, relating to a particular activity, which
store data per row rather than per bar.

To enter data in the Row tab:
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1. Click in a row Information Form action column.

    The Information form opens in the Row tab.

2. Enter or edit data using the options described below.

This option: Does this:

Activity Name
window

Displays the name of the activity whose data is currently
being shown in the form. Enter and edit the activity name
from this window.

Notes tab

Notes Enter or edit any notes you have about this activity.

Columns tab

Show Allows you to select which custom columns will display…

Column Name Displays the names of any columns whose data is stored
per row.

Column Value Displays the values of any columns whose data is stored
per row. If you have defined a value list for a column, that
value list will appear when you click in the Value cell.

3. Click OK to apply your changes and close the Information form.

See also:

Opening Information forms 

Entering and editing data in the Bars tab of the Information form 

12.3 Working in the Bars tab of the Information form

Working in the Bars tab of the Information form

In the Bars tab of the Information form you can view and edit the following data:

This option: Does this:
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Bars

Bar ID Displays the Bar ID of the bar whose information form you
are viewing.

Hidden Indicates whether or not there is a lock on the bar, thus
fixing it into place on the timeline graph and preventing
start, finish, and duration data from being edited.

Bar X of X When there is more than one activity bar or milestone in a
row, the number of that bar in relation to all the bars in that
row is displayed (e.g. Bar: 1 of 7). You can use the arrow
keys beside the Bar display window to navigate to other
bars in the row. Does not appear in the dialog if there is
only one activity bar or milestone in the row.

Bar window Displays the bar whose data is currently being shown in
the Bars tab.

Bar Style Allows you to change the current bar style by selecting a
new one from the list.

Duration Change the duration of the activity bar.

Fixed Duration Determine whether or not the activity bar or milestone will
have a fixed duration.

The Bars tab of the Information form has four additional tabs – Tracking, Columns, Links, and
Assignments.

What would you like to do?

 Enter and edit data in the Bars>Tracking tab

  Enter and edit data in the Bars>Columns tab

  Enter and edit data in the Bars>Links tab

  Enter and edit data in the Bars>Assignments tab
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12.4 The Bars>Tracking tab of the Information form

Entering and editing data in the Bars>Tracking tab of the Information Form

In the Bars>Tracking tab you have access to data that pertains to the movement of a bar, within a
particular activity.

To enter data in the Bars>Tracking tab of the Information form:

1. Double-click on an activity bar.

    The Information form for that bar opens in the Bars> Tracking tab.

2. Enter or edit data using the options described below.

This option: Does this:

Tracking

Scheduled
Boxes

Show Date, Time, and/or Duration data for the bar's
scheduled element.

Revised Boxes Show Date, Time, and/or Duration data for the bar's revised
element.

Actual Boxes Show Date, Time, and/or Duration data for the bar's actual
element. Actual data reflects the % complete.

% Complete Shows how much of the task represented by the particular
bar has been completed. The % complete affects the
Actual Dates and Times.

Priority Indicates the bar's assigned priority.

Constraints

Constraint
Date

Enter or edit the date for all Moderate and Hard Constraint
Types.

Constraint
Time

Enter or edit the time for all Moderate and Hard Constraint
Types.

Constraint Choose the Constraint that best suits the behavior you
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Type would like the activity bar to exhibit.

Calendars

[Calendar
select]

Choose what, if any, work calendar, you want to apply to
this activity.

New Create a new calendar to apply to the activity and choose
the existing calendar off of which you would like the new
one to be based.

Edit Opens the Work Calendar dialog so that you can edit the
calendar you selected to assign to this activity.

Ignore
Resource
Calendars

When no calendar has been selected, you can choose for
the activity to ignore the calendars of any resources
assigned to it.

3. Click OK to apply your changes and close the Information form.

Note:
The current duration units are displayed under the Duration column. Duration units are changed in the 
Project tab of the Document Options dialog.

See also:

Understanding Constraints 

Setting bar constraints 

Opening the Information forms 

Entering and editing data in the Activity tab of the Information form 

12.5 The Bars>Columns tab of the Information form

Entering and editing data in the Bars>Columns tab of the Information form

In the Bars>Columns tab you have access to data for all of the columns, relating to a particular activity,
which store data per bar rather than per row.

To enter data in the Bars>Columns tab of the Information form:

1. Double-click on an activity bar.

    The Information form for that bar opens in the Bars>Columns tab.

2. Enter or edit data using the options described below.
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This option: Does this:

Columns

Show Allows you to choose which type of columns to display in
the table, e.g. All columns, Calculation columns only,
Date columns only.

Name Displays the names of any columns you have created
whose data is stored per bar.

Value Displays the values of any columns you have created
whose data is stored per bar. If you have defined a value
list for a column, that value list will appear when you click
in the Value cell.

3. Click OK to apply your changes and close the Information form.

See also:

Opening the Information forms 

Entering and editing data in the Activity tab of the Information form 

12.6 The Bars>Links tab of the Information form

Entering and editing data in the Bars>Links tab of the Information form

In the Bars>Links tab you have access to all the information about an activity bar's links. You view the
information in terms of links to predecessor and successor bars.

To enter data in the Bars>Links tab of the Information form:

1. Double-click on an activity bar.

    The Information form for that bar opens in the Bar>Columns tab.

2.  Click the Bars>Links tab.

3. Enter or edit the link data in the Predecessors and Successors tables.

4. Click OK to apply your changes and close the Information form.

Go to "Managing Links" for a complete discussion of every option in the Bars>Links tab of the
Information form.

See also:
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Entering and editing data in the Activity tab of the Information form 

Entering and editing data in the Bars tab of the Information form 

Opening Information forms 

Managing links 

12.7 The Bars>Assignments tab of the Information form

Entering and editing data in the Bars>Assignments tab of the Information form

In the Bars>Assignments tab you have access to all the information about an activity barassigned
resources.

To enter data in the Bars>Assignments tab of the Information form:

1. Double-click on an activity bar.

    The Information form for that bar opens in the Bars>Columns tab.

2. Click the Bars>Assignments tab.

3. Enter or edit the resources assigned to the activity.

4. Click OK to apply your changes and close the Information form.

Go to the Assigning resources to bars section for a complete discussion of the Bars>Assignments tab
of the Information form.

See also:

Entering and editing data in the Activity tab of the Information form 

Entering and editing data in the Bars tab of the Information form 

Opening Information forms 

12.8 Understanding the Resource Information form

Understanding the Resource Information form

Use the Resource Information form to enter and edit resource information. Though you can enter data
directly into the columns of the Resource View, you may not want to display every column. The
Resource Information form gives you immediate access to every resource column, hidden or shown.

Using the Information tab of the Resource Information form:

The table below is a breakdown of the options in the Information tab of the Resource Information form.

In this box: Do this:
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Resource
Name

Enter a name for the resource as you would like it to display in
schedule columns, bar labels and summary graphs. It is a
good idea to be as specific as possible, because no two
resources can have the same name. For example, typing
"Mike" instead of "Mike Stuart" could lead to trouble if another
Mike works on the project.

Per Use Cost Enter a dollar amount that is charged every time this resource
is assigned to a task. Think of this as a flat fee paid to use
this resource. If this resource is assigned to several tasks in
the project, the dollar amount you enter here will be factored
into the Total Cost of each task.

Standard
Rate

Enter a dollar amount that is calculated per hour, day, week,
month, quarter, or year in relation to the task’s duration. The
default rate is per hour.

Overtime
Rate

Enter a dollar amount that is calculated per hour, day, week,
month, quarter, or year when the resource works overtime.
Entering a "0" means the resource will receive NO overtime
pay; leaving this blank means the resource’s Overtime Rate is
equal to the Standard Rate.

Type Enter a descriptive word to categorize the resource. For
example, you might just enter "Human," if it is a person, or
you may want to be more specific and enter something like
"Software Developer." This value is for your reference only and
does not affect the data in any way. Think about how you
would like to use Type information in filters and sorts.

Initials/Code/
Group

Enter data in these fields to assist you in filtering and sorting
resource information.

Additional
Resource
options

Use the additional options to enter detailed contact data for
the resource.

Using the Work Calendar tab of the Resource Information form:

Create a work calendar specific to this resource. Create and edit exceptions for specific dates that this
resource will not be available.
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Using the Other Columns tab of the Resource Information form:

Use this table of additional resource columns to enter more information about the resource.

1. Click in the Value column to the left of the Column Name into which you wish to enter data.

2. Enter a value.

See also:

See also:

Working with resources 

13 Layouts

13.1 Using layouts

Using layouts
Using layouts, you can create different groupings of columns and change between them quickly and

easily. Layouts are available in the Schedule and Resource Views. Layouts show, hide, and move

columns, the timeline graph, Action Columns, timescale areas, (in the Schedule View) summary graphs,

and (in the Resource View) resource subrows. You cannot apply layouts created in the Schedule View

to the Resource View or vice versa.

Select one of the following topics:

Applying a layout 

Defining a layout 

13.2 Defining a layout

Defining a layout
Defining a layout allows you to create and edit views of the Schedule and Resource Views. Layouts are

created and edited in the Layouts and Define Layout dialogs.



FastTrack Schedule 10 User Manual192

Copyright © 2010, AEC Software, Inc. All rights reserved.

To open the Define Layout dialog:

1. On the Project tab, in the Layout group, click Layouts and choose Define from the drop-down list.

    The Layouts dialog opens.

2. Click the New button to design a new layout.

    -or-

    Click the Edit button to edit the existing layout you select from the Layouts table.

    The Define Layout dialog opens.

In the Columns tab of the Define Layout dialog (Schedule and Resource Views):

1. In the Layout Name box, enter or edit the layout name.

2. From the Available Columns table, select a column name.

3. Click the Show button to send the column to the Shown Columns table.

4. Repeat this process until all the columns you want to include in the layout are in the Shown Columns

table.

    -or-

    Click the Hide button to remove a column from the Shown Columns table.

5. If you wish, click and drag on column names in the Shown Columns table to change the order of

columns in the layout.

    You can place columns on either side of the timeline graph.

6. If you wish, click in the Lock column to lock or unlock the column. 

    Locking a column prevents it from scrolling out of the window. It can be used for setting the left and

right scroll boundaries of the schedule.

7. Select Column Headings & Timescale  (Top) to display column headings and the top timescale area.

8. Select Column Summaries & Timescale (Bottom) to display column summaries and a bottom

timescale area.

9. Select Mirror Timescale from Top to display a bottom timescale that mirrors the top timescale. 
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    Column Headings and Timescale (Top) must be selected if you want to mirror the top timescale.

To display summary graphs (Schedule View only):

1. Click the Summary Graphs tab of the Define Layout dialog.

    Any summary graphs you have created appears in the Available Rows table.

2. Click Show to send the summary graph to the Shown Rows table.

3. If you wish, click and drag on summary graph row names in the Shown Rows table to change the

order of rows in the layout.

    -or-

1. Click the Create New Summary Graph Row button to create a new summary graph and open the

Format Summary Graph dialog.

Notes:

- Use the Hide and Hide All buttons to remove Summary Graph rows from the Shown Rows table.
- The Shown Columns table displays the left-to-right order of columns.

See also:

Using Layouts 

Applying a layout 

Inserting new summary graphs 

13.3 Deleting a layout

Deleting a layout
Layouts can be deleted in the Layouts dialog.

To delete a layout:
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1. On the Project tab, in the Layout group, click Layouts and choose Define from the drop-down list.

    The Layouts dialog opens.

2. Select the layout you wish to delete.

3. Click the Delete button.

    A confirmation dialog appears asking you to verify that the layout will be deleted.

4. Click OK to delete the layout or Cancel to retain the layout.

    If you delete the layout, it will no longer be available from the Layouts drop-down list.

5. Click OK to close the Layouts dialog and apply the layout that is currently selected.

    -or-

    Click Close to close the Layouts dialog without applying a layout.

See also:

Using Layouts 

Defining a layout

Applying a layout

13.4 Duplicating a layout

Duplicating a layout
Layouts can be duplicated in the Layouts dialog.

To duplicate a layout:

1. On the Project tab, in the Layout group, click Layouts and choose Define from the drop-down list.

    The Layouts dialog opens.

2. Select the layout you wish to duplicate.

3. Click the Duplicate button.
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    The Define Layout dialog opens.

4. Edit the new layout.

5. Click OK to save the layout and close the Define Layout dialog.

6. Click OK to close the Layouts dialog and apply the layout that is currently selected.

    -or-

    Click Close to close the Layouts dialog without applying a layout.

See also:

Using Layouts 

Defining a layout

Applying a layout

13.5 Applying a layout

Applying a layout
Applying a layout is a shortcut to showing, hiding, and moving elements of the Schedule and Resource

Views.

To apply a layout:

1. On the Project tab, in the Layout group, click Layouts and choose the layout you wish to apply from
the drop-down list.

See also:

Using Layouts 

Defining a layout 
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14 The Calendar View

14.1 The Calendar View

The Calendar View

The Calendar View displays information from the Schedule View in the traditional look of a wall
calendar, though you are not constrained to viewing a month at a time. Time is displayed horizontally
in the Schedule and Resource Views, but in the Calendar View it is displayed vertically.

In the Calendar View you can:

- Draw bars
- Move bars
- Hide bars
- Filter activities to view only those bars you want to see
- Edit Scheduled, Revised, and Actual dates and times
- Apply Ranges and FastSteps 
- Print the calendar in current, monthly, and custom configurations

Note:

Links do not display in the Calendar View.

What would you like to do?

 Print the Calendar

 Set Page Options for the Calendar View

 Format the Calendar View

14.2 Printing the Calendar View

Printing the Calendar View

The Calendar View yields a hardcopy calendar that is both attractive and functional and displays
whatever range of dates you determine. 

To print the Calendar View:

1. In the Calendar View, from the Application menu, select Print and choose Print from the submenu.

2. In the Print dialog, choose a printer and click Print.

    If you are connected to a printer, this will print the range of dates shown in the Timeline Range in
calendar form.

    -or-

1. from the Application menu, select Print and choose Print Preview from the submenu.

    Use the options in the Print Preview layer to determine the appearance of the printed calendar.

2. From the Application menu, select Print and choose Print from the submenu.
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3. In the Print dialog, choose a printer and click Print.

    If you are connected to a printer, this will print the range of dates shown in the Timeline Range in
calendar form.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

14.3 Setting the Calendar View page options

Setting the Calendar View page options

The Page Options control how a calendar will print. The Page Options for the Calendar View are
different than those available in the Schedule and Resource Views. Because of the vertical orientation
of the calendar, special layout and date options are available.

To set the Calendar View Page Options:

1. In the Calendar View, from the Application menu, select Print and choose Page Options from the
submenu.

    The Calendar View Page Options dialog opens.

2. Use the options described below to set the printed dates, calendar layout, page margins, and
alignment of the printed calendar.

This option: Does This:

Format

Full Month Per
Page

Prints every month encompassed by the specified range of dates. So, if
your specified range was 02/15/07 – 04/12/07, this option will print the
complete months of February, March, and April – each on its own page.

Fit to Single
Page

Prints a calendar consisting of the specified range of dates on one page;
to force the fit, cells are resized and bars can be hidden from view – you
should be sure to view this in the Print Preview window before printing.

Current
Calendar
Layout

Prints the specified range of dates in a calendar with the same cell
dimensions as those currently being displayed in the Calendar View –
pages break at natural points of division, never mid-cell.

Printed Dates
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Current Start/
Finish

Prints a calendar consisting of the days currently shown in the
QuickRange Toolbar.

Defined Range Prints a calendar consisting of the days included in a previously defined
Range. Select this range from the drop-down list.

Custom Prints a calendar consisting of the ranges of dates specified in the Start
Date and Finish Date boxes.

Margin Allows you to determine the number of inches from the top, bottom, right,
and left of the printed page to set the calendar.

Alignment Allows you to determine where along the horizontal and vertical axes of
the printed page the calendar will sit.

3. Click OK to apply your changes and close the Calendar View Page Options dialog.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

14.4 Formatting the Calendar View

Formatting the Calendar View

Each display element of the calendar can be customized in the Format Calendar View dialog.

To format the display of the Calendar View:

1. In the Calendar View, on any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View opens.

2. Click the Display, Range, Font, Bars, Bar Labels or Gridlines tab to format the appearance of that
element of the calendar.

3. Click OK to apply your changes and close the Format Calendar View dialog.

What would you like to do?
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 Format the display of the calendar

 Set the Calendar View range

 Format the display of text

 Format the display of bars

 Format the display of bar labels

 Format the display of bar label text

 Format the appearance of gridlines

14.5 Formatting the display of the calendar in the Calendar View

Formatting the display of the calendar in the Calendar View

You can format the calendar title, the Cell Header style and the shading of each element of the
calendar in the Display tab of the Format Calendar View dialog.

To format the display of the calendar in the Calendar View:

1. On any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View opens.

2. Click the Display tab.

3. From the Calendar Title Format drop-down list, select the title format you would like to appear at the
top of the calendar.

4. From the Cell Header Style drop-down list, select the style in which you would like the Cell Header
to appear.

5. From the Shading drop-down list, select the calendar element you wish to shade.

6. Use the Fill Color and Fill Pattern controls to format the display of the shading on the selected
element.

7. Click OK to apply your changes and close the Format Calendar View dialog.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

Formatting the appearance of gridlines in the Calendar View 

14.6 Formatting the display of bars in the Calendar View

Formatting the display of bars in the Calendar View

Activity bars display differently in the Calendar View than they do in the Schedule View. This is due to
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how they display when wrapping vertically and how they print.

To format the display of bars in the Calendar View:

1. On any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View dialog opens.

2. Click the Bars tab.

3. Use the options described below to determine how activity bars display in the Calendar View.

This option: Does This:

Bar Styles

Use
Schedule
View Bar
Styles

Makes the bars in your calendar appear as they do in the
Schedule View, except the size of the bars, end points, and
milestones reflect the size here.

Use Generic
Bar

Causes every bar in your schedule to display in a single style
in the Calendar View. You select the bar and milestone styles
from the drop-down lists.

Options

Show End
Points

Shows or hides bar endpoints to streamline the appearance of
the bars in your calendar.

Bar Size Determines the number of pixels high you would like bars in the
calendar to display.

End Point
Size

Determines the number of pixels high you would like endpoints
in the calendar to display.

Milestone
Size

Determines the number of pixels high you would like
milestones in the calendar to display.

Snap Bars
to Cell Edge

Begins display of milestones and the endpoints of bars at the
edge of a cell rather than the middle.
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4. Click OK to apply your changes and close the Format Calendar View dialog.

Note:

Bar formatting in the Format Calendar View dialog applies only to the Calendar View. The appearance
of bars in the Schedule and Resource Views are not affected.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

14.7 Formatting text in the Calendar View

Formatting text in the Calendar View

You can change the display of calendar text in the Format Calendar View dialog.

To format text in the Calendar View:

1. On any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View dialog opens.

2. Click the Font tab.

3. From the Format drop-down list, select which calendar text you wish to format.

4. Use the options to set the font name, size, style, color and justification for the selected text.

5. Click OK to apply your changes and close the Format Calendar View dialog.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

14.8 Formatting the display of bar labels in the Calendar View

Formatting the display of bar labels in the Calendar View

Labels on bars in the Calendar View are a separate item from the data displayed on bars in the
Schedule View and the Resource View’s Assignments subrow.

To format the display of bar labels in the Calendar View: 
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1. On any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View dialog opens. 

2. Click the Bar Labels tab.

3. Select or clear the check boxes in the Show column to toggle between showing and hiding the
corresponding columns’ data on bars in the calendar.

    Every column available in the Schedule View is available in the table.

4. Use the options to set the Background, Line, Shadow and Corner attributes for calendar bar labels.

5. Select or deselect the Wrap Label Text option.

    When this option is deselected, all of the label text may not display.

6. Click OK to apply your changes and close the Format Calendar View dialog.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

14.9 Formatting the text of bar labels in the Calendar View

Formatting the text of bar labels in the Calendar View

In the Calendar View, bar label text is formatted in the Format Calendar View dialog.

To format the text of bar labels in the Calendar View:

1. On any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View dialog opens.

2. Click the Font tab.

3. From the Format drop-down list, select Bar Label.

4. Select the font name, size, style, and justification for calendar bar labels.

5. Click OK to apply your changes and close the Format Calendar View dialog.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 
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14.10 Formatting the appearance of gridlines in the Calendar View

Formatting the appearance of gridlines in the Calendar View

You can change the size and color of the gridlines of the calendar in the Calendar View.

To set bar labels in the Calendar View:

1. On any tab, in the View group, click the Dialog Box Launcher.

    -or-

    In the Calendar View, right-click in any cell of the calendar and select Format View.

    The Format Calendar View dialog opens.
2. Click the Gridlines tab.
3. Use the options described below to format the appearance of gridlines in the Calendar View.

This option: Does This:

Define
Gridlines

Width Sets the width of each day cell in the calendar.

Height Sets the height of each day cell in the calendar.

Line Color Determines the color in which calendar gridlines will display.

Line Size Determines the number of pixels high you would like gridlines in
the calendar to display.

Months
Separator
Line

Show When checked, this option displays a line separating the
months that are showing in your calendar.

Line Color Determines the color in which the month separator lines in the
calendar will display.

Line Size Determines the number of pixels high you would like month
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separator lines in the calendar to display.

4. Click OK to apply your changes and close the Format Calendar View dialog.

See also:

The Calendar View 

Working in the Calendar View 

Formatting the Calendar View 

15 Resources and Assignments

15.1 Working with Resources

Working with Resources

Tracking who or what is responsible for completing the tasks you are scheduling is one of the most
important parts of managing a project. Resources are the people or equipment that help you
accomplish the tasks in your schedule. A resource can be anything from a photocopier to a bulldozer
to a Chemical Engineer to Jane Doe.

Every resource has a finite amount of time it can be used and effort it can exert. Every resource also
has a cost attached to it -- whether it is a flat fee, a standard rate, an overtime rate, or any combination
thereof. Each of these elements can be charted and controlled in the Resource View of FastTrack
Schedule.

What do you want to do?

  Use the Resource Information form

  Create resources

  Work with Assignments

  Assign resources to bars

  Format rows in the Resource View

  Format text in the Resource View

  Format graph data in the Resource View

15.2 Understanding the Resource Information form

Understanding the Resource Information form

Use the Resource Information form to enter and edit resource information. Though you can enter data
directly into the columns of the Resource View, you may not want to display every column. The
Resource Information form gives you immediate access to every resource column, hidden or shown.

Using the Information tab of the Resource Information form:
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The table below is a breakdown of the options in the Information tab of the Resource Information form.

In this box: Do this:

Resource
Name

Enter a name for the resource as you would like it to display in
schedule columns, bar labels and summary graphs. It is a
good idea to be as specific as possible, because no two
resources can have the same name. For example, typing
"Mike" instead of "Mike Stuart" could lead to trouble if another
Mike works on the project.

Per Use Cost Enter a dollar amount that is charged every time this resource
is assigned to a task. Think of this as a flat fee paid to use
this resource. If this resource is assigned to several tasks in
the project, the dollar amount you enter here will be factored
into the Total Cost of each task.

Standard
Rate

Enter a dollar amount that is calculated per hour, day, week,
month, quarter, or year in relation to the task’s duration. The
default rate is per hour.

Overtime
Rate

Enter a dollar amount that is calculated per hour, day, week,
month, quarter, or year when the resource works overtime.
Entering a "0" means the resource will receive NO overtime
pay; leaving this blank means the resource’s Overtime Rate is
equal to the Standard Rate.

Type Enter a descriptive word to categorize the resource. For
example, you might just enter "Human," if it is a person, or
you may want to be more specific and enter something like
"Software Developer." This value is for your reference only and
does not affect the data in any way. Think about how you
would like to use Type information in filters and sorts.

Initials/Code/
Group

Enter data in these fields to assist you in filtering and sorting
resource information.

Additional
Resource
options

Use the additional options to enter detailed contact data for
the resource.
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Using the Work Calendar tab of the Resource Information form:

Create a work calendar specific to this resource. Create and edit exceptions for specific dates that this
resource will not be available.

Using the Other Columns tab of the Resource Information form:

Use this table of additional resource columns to enter more information about the resource.

1. Click in the Value column to the left of the Column Name into which you wish to enter data.

2. Enter a value.

See also:

See also:

Working with resources 

15.3 Creating resources

Creating resources

Resources can be created using the Resource Information form. 

To create a new resource:

1. In the Resource View, click in the Information Form action column of the selected row.

    The Resource Information form opens.

2. In the Information tab, if you desire, enter name, rate type and contact data about the resource.

3. Click the Work Calendar tab to define the work days and hours of this resource.

4. Click OK to apply your changes and close the Resource Information form.

Note:

By selecting Create Resource from the Resource Name drop-down list, you can also open a new
Resource Information form from the Bars>Assignments tab of the Information form.

See also:

Working with resources 

Assigning resources to bars

15.4 Creating and editing a resource work calendar

Creating and editing resource work calendars

Every resource you create in FastTrack Schedule has it's own work calendar. Defining a resource work
calendar allows you to setup the hours of the day for typical and specific days. If you have a resource
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that is only available Monday through Wednesday, you can set Thursday - Sunday to be non-work
days for that resource, though they are still work days in the Project work calendar. 

Use the Resource Information form to determine a resource's work calendar.

To create or edit a resource work calendar:

1. In the Resource View, click in the Information Form action column of the selected row.

    The Resource Information form opens.

2. Click the Work Calendar tab.

3. Define the Work Calendar with the options described below.

4. Click OK to apply your changes and close the Resource Information form.

To set the work hours for a Specific day and create Exceptions:

1. In the Define Specific Days area, select a month and year to display from the drop-down lists.

    The month appears in the calendar below. 

2. Select a day from the calendar. 

3. Click the Create Exception button.

4. Enter a descriptive name for the exception in the Exceptions table.

5. Click out of that day in the calendar to create an exception with "0" work hours, i.e. a full day-off.

    -or-

5. Deselect the "Use typical work day shifts on base calendar" option.

6. Edit the Work Shift Details to create an exception with something other than "0" hours.

    The total work hours for that specific day appear in the calendar.

To set the work hours for the Typical day of the week (such as Monday):

1. In the Define Typical Week Days area, click on the day of the week for which you want to define
typical hours.

2. In the Work Shift Details table, enter the periods of time that should be considered work hours for
that day.

    The total number of work hours appears under that day in the Define Typical Week Days area.

3. Repeat this procedure for every day you wish to set.

To define the Base Calendar:
1. From the Base Calendar drop-down list, choose Standard (Project Calendar), 24 Hours or Night
Shift.

Notes:
- Only specific (non-typical) days are displayed in the calendar in the dialog.
- In the Hours area, you must enter periods of time in both the Start and Finish columns. For instance,
the Standard calendar's default work day is 8:00 AM to 12:00 PM and 1:00 PM to 5:00 PM.
- The Copy Day button copies the work shift details for a typical or specific day to the Clipboard. The
Paste Day button pastes work shift details from the Clipboard to a typical or specific day. The Copy
Calendar button copies the contents of the work calendar to the Clipboard. The Paste Calendar button
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pastes a work calendar from the Clipboard to a new schedule.
- The work shift details from a typical day can be pasted to a specific day or vice versa.

See also:

Working with resources 

15.5 Assigning resources to bars

Assigning resources to bars

Assignments link a resource and all its data to a task or tasks in the schedule. The Schedule and
Resource Views draw from two different pools of information. Assignments act to bridge those two
pools of information. 

You can create a schedule full of tasks and you can create numerous resources complete with work
calendars and cost data, but until you actually assign a resource to a task, the Schedule and
Resource Views cannot interact.

To assign a resource to a bar:

1. In the Schedule View, click in a row’s Information Form action column.

    -or-

    In the Schedule View, double-click on the bar or milestone that represents the task to which you
want to assign a resource.

    The Information form opens in the Tracking tab.

2. Click the Assignments tab.

3. Use the options described below to assign resources to an activity's bar.

With this
option:

Do this:

Apply Effort
Driven...

Determine whether or not assigning a resource will set the
activity to be effort driven or to have a fixed duration.

Clear
Assignments

Click to clear every assignment in the table.

Assignments
table

Click the icon to open the Resource Information form for the
resource selected in the Resource Name drop-down list.
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Resource Name Select a resource from a drop-down list containing every
defined resource that is not already assigned to this task. Or
select Create New Resource to define a new resource you
want to assign to the bar.

Work (Units) Edit the number of work units for the activity to which you are
making an assignment.

% (Effort) Enter or edit the percentage of the resource’s time you want
devoted to the specific task.

Contour Determine the manner in which this resource's effort will be
applied.

Per Use Cost Enter or edit the dollar amount that will be charged every time
this resource is assigned to this particular task. This is a flat
fee paid to use this resource. If this resource is assigned to
several tasks in the project, it can have different Per Use
Costs in every assignment.

Standard Rate Enter or edit a dollar amount that will be calculated per hour,
day, week, month, quarter, or year in relation to the task’s
duration. The default rate is per hour. Enter "$150.00/d" for the
Rate Per Day, "$150.00/w" for the Rate Per Week, etc.

Overtime Rate Enter or edit a dollar amount that will be calculated per hour,
day, week, month, quarter, or year when the resource works 
overtime. A "0" in this cell means the resource will receive NO
overtime pay. This cell blank means the resource’s Overtime
Rate is equal to its Standard Rate. The default time period is
Rate Per Hour.

Cost View the assignment Cost, where Cost = (Per Use Cost) +
(Standard Rate * Duration) + (Overtime Rate * Overtime
Duration)

4. Click OK to save your changes and close the Information form.
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See also:

What is overtime? 

What is spot allocation? 

Working with resources 

Creating resources

15.6 Understanding Contours

Understanding Contours

Contours allow you to quickly apply a resource's work effort to an activity in a manner that best suits
your needs. 

For example, let's say you are scheduling the creation and distribution of a new software application. As
part of that project, you are employing testers. Though some testing can be done as the product is
developed, the majority of a tester's work will be done towards the end of development. Therefore when it
comes time to assign a tester to a software feature, you would want to choose for that resource the
contour "Back Loaded" in the Assignments tab of the Information form. The tester's Percent Work Usage
will be low at the beginning of the activity and increase gradually until it reaches 100% at the end of the
activity.

FastTrack Schedule supports the following contouring models:

This
Contour:

Looks like this: Does this:

Flat Applies the same amount of
the resource's effort
throughout the activity's
duration

Back
Loaded

Applies more of the resource's
effort at the end of the
activity's duration

Front
Loaded

Applies more of the resource's
effort at the beginning of the
activity's duration
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Double
Peak

Applies the resource's effort
so that there is a peak of effort
towards the beginning of the
activity's duration and another
peak of effort towards the end
of the activity's duration.

Late Peak Applies the resource's effort
so that there is a peak of effort
towards the end of the
activity's duration.

Early Peak Applies the resource's effort
so that there is a peak of effort
towards the beginning of the
activity's duration.

Turtle Applies the resource's effort
so that there is a gradual
increase of effort as the
activity progresses and a
gradual decrease of effort
towards the end of the
activity's duration.

Bell Applies the resource's effort
so that there is a sharp
increase of effort towards the
middle of the activity's
duration with a  sharp
decrease of effort towards the
end of the activity's duration.

Custom [determined by you] Lets you determine in what
manner a resource's efforts
will be applied to an activity

15.7 Formatting row text in the Resource View

Formatting row text in the Resource View

Formatting text in resource rows allows you to set the font, size, style, justification, and color of text
elements in Resource View subrows.



FastTrack Schedule 10 User Manual212

Copyright © 2010, AEC Software, Inc. All rights reserved.

To format subrow text in resource rows: 

1. Select the resource row or rows you want to format.

2. Double-click the Row Number action column of the selected resource row or any one of the multiple
selected resource rows.

    The Format Resource Row dialog opens.

3. Click the Font tab.

4. From the Format Subrow drop-down list on top, select the text element to which you want to apply
font attributes.

5. In the Font area, set the font, size, style, justification, color, and line spacing.

6. Click OK to apply your changes and close the Format Resource Row dialog.

Note:

Text in columns is formatted in the Format Column dialog.

See also:

Working with resources 

15.8 Formatting rows in the Resource View

Formatting rows in the Resource View
Formatting resource rows allows you to set the height, background color and pattern, and bottom line

color of resource rows.

To open the Format Resource Row dialog:

1. Select the resource row or rows you want to format.

2. Double-click the Row Number action column of the selected resource row or any one of the multiple
selected resource rows.

    The Format Resource Row dialog opens.
2. In the Display tab, from the Format Subrow drop-down list, select the part of the resource row you

wish to change the display of.

3. Select from the options described below.

This Option: Does this:
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Row

Background

Attributes:

Display Location Allows the color and pattern you have selected to display on:

columns only, the timeline only, both the columns and the

timeline, or not at all.

Color Allows you to set a background color to display in the resource

row as a whole or in the specified subrow.

Pattern Allows you to set a background pattern to display in the

resource row as a whole or in the specified subrow.

Bottom Line

Attributes:

Display Location Allows the color you have selected to display beneath: columns

only, the timeline only, both the columns and the timeline, or

not at all.

Color Allows you to set a bottom line color to display in the resource

row as a whole or in the specified subrow.

Size Set the size, or thickness, of the bottom line.
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Height: (only available when formatting a resource subrow)

Expanded Determines at what row height the resource subrow will display

when it is expanded.

Collapsed Determines at what row height the resource subrow will display

when it is collapsed or hidden.

Options:

Page Break After

this Row

Sets a page break after the resource you are currently

formatting.

Show Scale Displays the scale for the graph.

Show Parent Tree Displays the contents of the Parent Tree column (the activity

preceded by all of its parents) in the Assignments subrow.

4. Click OK to apply your changes and close the Format Resource Row dialog.

Notes:

- If you are formatting several rows at once, selecting Page Break After this Row will put a page break
after each row.
- Clicking the Set as Default button makes the selected settings the default for all new resource rows.
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See also:

Working with resources 

15.9 Formatting graph data in the Resource View

Formatting graph data in the Resource View

Formatting the appearance of graphs in the Resource View’s Percent Usage and Time Usage subrows
allows you to customize the look of many aspects of each graph.

To format graph data in resource rows:

1. Select the resource row or rows you want to format.

2. Double-click the Row Number action column of the selected resource row or any one of the multiple
selected resource rows.

    The Format Resource Row dialog opens.

3. Click the Graph tab.

4. From the Format Subrow drop-down list, select the graph to which you want to apply attributes.

5. In the Section area drop-down list, select the section of the graph to which you want to apply
attributes.

6. Set the color and pattern attributes for the selected graph section.

7. Select or clear the Show Outline checkbox.

8. If you selected to show the outline, set the color, pattern, and outline size for the outline of the
selected graph section.

9. In the 100% Line area, select a color and size for the 100% line in the graph.

    The 100% line marks the maximum amount of time or usage available.

10. Click OK to apply your changes and close the Format Resource Row dialog.

See also:

Working with resources 

16 Consolidation

16.1 Understanding Consolidation

Understanding Consolidation
You can easily consolidate your FastTrack files into one master file to analyze a big picture view of your

data. Whether you want to see all the separate components of one larger project, or see every project
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your company is currently working on, Consolidation allows you to do so. Consolidation works across

platforms so consolidated files can originate from either a Mac or Windows operating system.

Master file - the file you create by consolidating existing files is called a master file. A master file can

never be inserted into another file or into itself.

Subordinate file - a file that is inserted into a master file is called a subordinate files.

Subordinate files must be accessible, either on the hard drive or by network, and openable. The user of

the master file must have read access to a file to insert it.

Important:

Consolidated subordinate files are not live. There are no automatic updates. When data changes in

a subordinate file the changes do not appear in the master file until you choose to refresh the data from

that subordinate file. Changes you make to data in the master file must be manually applied to the

appropriate subordinate files.

A key to consolidation is the Work Calendar. In a perfect structure, all subordinate files would have

the same Work Calendar as the master file. However, it may not always be the case. FastTrack

Schedule 9.2 will consolidate files and report work calendar conflicts. Such conflicts may cause

scheduling discrepancies between the master file and the subordinate file because the subordinate files

will be displayed using the work calendar of the master file.

Changes to data in the master file are for analysis only and do not affect the subordinate file. If you

decide that you want to apply changes you have made in a master file, you must open the appropriate

subordinate files and manually make the changes there.
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The following data is consolidated:

- All columns – except calculation columns
- Bars and barstyles
- Pictures, textboxes and legends
- Links
- Assignments
- Pointers

Any conflict in data between a subordinate and the master file results in that data being excluded from
consolidation.

If a column in a subordinate file is formatted to save data Per Bar and the same column in the master
file is formatted to save data Per Row, that column will not be included in the consolidation.

Consolidation is data driven, not visual. Formatting related information will not be consolidated.

Formatting is determined by the master file’s preference settings. You can edit Filter, Sort, Layout,

Range, FastSteps and format settings in the master file, but the changes will not be applied to the

subordinate file unless you manually apply them.

Resources do not get deleted from the master file even if future updates of the subordinate file in which

the resource originated no longer includes that resource.

You can consolidate subordinate files that have different Resource Work Calendars defined for the same

resource.

What would you like to do?

 Consolidate files

 Learn about work calendar conflicts

 Work with a master file

 Update a master file
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16.2 Consolidating files

Consolidating files
You can create a master file by inserting any accessible FastTrack Schedule file into an open FastTrack

Schedule file.

To insert one project into another: 

1. On the Tools tab, in the Consolidation group, click Define.

    The Define Consolidation dialog opens.

2. Use the options described below to consolidate files.

This option: Does this:

Add Allows you to navigate to a file you want to insert into the

master file.

Remove Removes a file from the table. That file will no longer be

inserted into the master file or updated. The Removed file

will then be removed from the master file though it had been

inserted previously.

Locate Opens a navigation window showing the path of the

selected subordinate file. If you have copies of the same file

in different locations, Locate allows you to be sure you are

consolidating the correct copy.
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"Files are

subproject…"

option

Every subordinate file in the master file will share the same

Project Finish Date and Time, those of the master file.

"Files are

project…"

option

Every subordinate file in the master file will maintain its own

Project Finish Date and Time.

Update Inserts the most recent saved version of the selected file.

Update All Selects and updates every file in the dialog and closes the

dialog.

Close Closes the dialog.

Notes:

- It is recommended that all subordinate files have the same Work Calendar as the master file's Work
Calendar.
- It is recommended that if one of the subordinate files has a 24 Hour Work Calendar, that the master
file's Work Calendar also be set to a 24 Hour Work Calendar.
- Subordinate files whose Work Calendars do not match the master file's Work Calendar can be inserted
in the master file.  When files have different Work Calendars a log file is created that will analyzes and
documents the differences in Work Calendars.
- If you want to consolidate several files with matching custom Work Calendars, simply modify the Work
Calendar of the master file to match. You can simply Copy a Work Calendar and Paste the Work
Calendar into all the resources and files by using the Copy Calendar and Paste Calendar buttons in the
Work Calendar dialog. 

See also:
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Understanding Consolidation

Consolidation Work Calendar Conflicts

Working with a master file

Updating a master file

16.3 Consolidation and work calendars

Consolidation work calendar conflicts

Work calendars are a key factor in the consolidation of schedules, and should the subordinate file differ

from the Master File work calendar, tasks and activities scheduled in the subordinate file will have

different scheduling attributes.

FastTrack Schedule analyzes and documents the differences in Work Calendars between the master file

and the subordinates which you can save in a log file, in text format.

The file is organized in two sections:

The first section shows the master file work calendar, and resources calendars indicating non-work days

and hours. 

If the master file or subordinate files contain 24 Hour Work Calendars the differences are infinite and

therefore the differences are not enumerated. 

See also:

Understanding Consolidation
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Working with a master file

Updating a master file

16.4 Working with a master file

Working with a master file
A master file contains and displays the data from subordinate files that you want to analyze and of which

you want to get an overview.

Every subordinate file will have a summary bar. This summary bar can not be moved. You can, however,

move and edit the summarized bars to allow for analysis.

In a master file, the Consolidation icon appears in the Information action column for the first row of a

subordinate file.

 

Hover over the Consolidation icon to display the subordinate file’s location.

Click on the Consolidation icon to open the Project Information form for that subordinate file.

If you have selected the "Files are projects and have separate Project Finish Dates" option in the
Define Consolidation dialog, the subordinate file’s Project Information data will stay what it is in the
subordinate file. If not, the Project Information data for every subordinate file will match that of the
master file.

When you update a subordinate file, that data will overwrite changes you have made in the master file.
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All appearance formatting is dictated by the master files preferences. You can reformat the appearance

of data, but those changes will not be applied to the subordinate file and will appear only in the master

file. Formatting changes made in the master file will also be overwritten when you update a subordinate

file’s data.

Currency data is considered simply a number and the designated currency is defined by the master file’s

Currency Preference settings.

See also:

Understanding Consolidation

Consolidation Work Calendar Conflicts

Updating a master file

16.5 Updating a master file

Updating a master file
Once you have created a master file you can quickly update every subordinate file it contains, or choose

to update only selected files.

To update every subordinate file in a master file: 
1. On the Tools tab, in the Consolidation group, click Get Updates.

    -or-

1. On the Tools tab, in the Consolidation group, click Define.

    The Define Consolidation dialog opens.

2. Click Update All to update every subordinate file and close the Define Consolidation dialog.

To update only specific subordinate files in a master file:
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1. On the Tools tab, in the Consolidation group, click Define.

    The Define Consolidation dialog opens.

2. Select the subordinate files you want to update.

3. Click Update.

4. Click Close to close the Define Consolidation dialog.

See also:

Understanding Consolidation

Consolidation Work Calendar Conflicts

Working with a master file

17 Printing & Previewing

17.1 Working with Print Preview

Working with Print Preview
Print Preview is a separate window in the application that displays the pages of the Schedule, Calendar,

or Resource Views just as they will appear when printed. Print Preview is also interactive – it allows you

to add pictures, autotext stamps, headers and footers, and other information to an overlay layer that

does not affect the contents of the Schedule, Calendar, or Resource Views. 

In addition to displaying printed schedules, Print Preview allows you to export an image of the printed

page onto the Clipboard or to a file. This allows you to then paste this image into another application for

use there: for instance, a page layout application, word processor, or other presentation application. You

can also send the file via email to someone for viewing or display on a website

See also:

Using Print Preview
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17.2 Using Print Preview

Using Print Preview
Print Preview allows you to see how each page of a specified View will print before you send it to a

printer. Headers, footers, and pictures added to the Print Preview window will appear when you print the

page or export a picture of the page. Pictures, legends and text stamps are not supported in the Print

Preview window of the Calendar View.

To open Print Preview:

1. On the Quick Access toolbar, click the Print Preview icon.

    The Quick Access toolbar is located beside the Application Button which is the graphic  at the
top left of the FastTrack Schedule window.

To view a different page in the Print Preview window:

1. On the Format bar, click the Previous Page or Next Page to navigate to the page you would like to
view.

To see the printable area of the page (to make sure items are not clipped):

1. On the Format bar, select the Printable Area option.

You are in Actual Size when the view of your schedule is 100%. If you are zoomed in less than 100%,

your schedule will automatically resize to the size of the Print Preview window.

To zoom in and out of the Fit-in-Window and Actual Size view:

1. In the Zoom group, click Zoom In or Zoom Out.

To view a different part of the schedule when in Actual Size view:

1. Click and drag the page image to see a different area.
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To close the Print Preview window:

1. In the Preview group, click Close.

See also:

Insert page number, date, time or file name and path 

Adding titles and pictures to Print Preview 

Printing a schedule 

17.3 Adding headers and footers

Adding headers and footers
Each View (Schedule, Resource, and Calendar) can have a header and footer that appear when you print

that View or use the Print Preview window of that View. This allows you to include information such as

the file name, date, and page number on printed pages.

To add headers and footers:

1. In the Schedule, Calendar or Resource View,on the Insert tab, in the Page group, click Header &

Footer.

    -or-

    In Print Preview, from the Page group, click Header & Footer.

    The Header and Footer dialog opens.

2. From the Format drop-down list, select Header or Footer.

3. Select a cell in the left, center, or right table into which you want to place information.

4. From the Insert into Cell drop-down list, select one of the pre-defined pieces of data.

    -or-

    Enter custom information into the left, center, or right table.

5. From the Display Options drop-down list, select which pages the data will display on. 

6. If you wish, click the Font button to define the textual appearance of data in the cell.
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7. Click OK to apply your font styles and close the Font dialog.

8. Click OK to apply your changes and close the Header and Footer dialog.

Notes:

- Each table can contain multiple pieces of data. The Copy All button copies every piece of data from the
Header and Footer tables to the Clipboard. The Paste All button pastes Header and Footer data from the
Clipboard. You can copy and paste between similar files.
- You can remove headers or footers anytime by simply deleting the text from the Left, Center, or Right
tables.

See also:

Adding titles and pictures to Print Preview 

17.4 Inserting page #, date, time, and file name

Inserting page #, date, time, and file name and path
Inserting autotext allows you to include a dynamic page number, date, time, and file name and path in

the Print Preview windows of the Schedule and Resource Views. This information will appear when the

document is printed. You can also use headers and footers to include this data on the printed document.

Headers and Footers allow you to format the display of the items.

To insert items in the Print Preview window:

1. In Print Preview, from the Page Items group, click Insert and choose Page Number.

    -or-

    In Print Preview, from the Page Items group, click Insert and choose Date.

    -or-

    In Print Preview, from the Page Items group, click Insert and choose Time.

    -or-
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    In Print Preview, from the Page Items group, click Insert and choose File Name and Path.

To change the display of an inserted autotext item in the Print Preview window:

1. Click the item to select it.

2. From the Page Items group, click Format Selected.

    -or-

    Right-click on the item and select Format.

    The Format Item dialog opens.

3. Use the options to change the display of the item.

4. Click OK to apply your changes and close the Format Item dialog.

To define what pages an inserted autotext item is displayed on:

1. Click the item to select it.

2. From the Page Items group, click Format Selected.

    The Format Item dialog opens.

3. In the Display tab, use the Show On options to display the item on all pages, the current page only,

or a range of pages.

4. Click OK to close the Format Item dialog.

Note:

Inserted items appear in the middle of the Print Preview window. Use the Arrow tool to drag the item to a

different location.

See also:

Changing the font of text boxes 

Adding headers and footers 
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17.5 Adding titles and pictures to Print Preview

Adding titles and pictures to Print Preview
Adding text boxes and pictures (both called items) to Print Preview allows you to add titles and images
that are only displayed on printed pages. Pictures, legends and text boxes are not supported in the Print
Preview window of the Calendar View.

To add a text box to the Print Preview window:

1. In Print Preview, from the Page Items group, click Insert and choose Insert Text Box from the drop-

down list.

2. Drag the text box to place it in the desired location.

4. Enter the text in the text box and it will resize to fit the text.

To add a picture to Print Preview:

1. In Print Preview, from the Page Items group, click Insert and choose Insert Picture from the drop-down

list.

    The Insert Picture dialog opens.

2. In the Insert Picture dialog, choose to insert a picture you've previously saved to the Clipboard, or

browse to find the picture you want to insert.

3. Click OK to close the Insert Picture dialog and insert your picture.

4. Drag the picture to place it in the desired location.

To define which pages an item displays on:

1. Click the item to select it.

2. From the Page Items group, click Format Selected.

    The Format Item dialog opens.

3. In the Display tab, use the Show On options to display the item on all pages, the current page only,

or a range of pages.
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4. Click OK to close the Format Item dialog.

See also:

Changing the font of text boxes 

Resizing text boxes

Moving text boxes

Resizing pictures

Moving pictures

Formatting items

17.6 Fitting the document to a number of pages

Fitting the document to a number of pages
Fitting the schedule to a number of pages allows you to determine how many pages wide you would like
the printed Schedule or Resource Views to be and automatically resizes the timeline graph columns to
make the schedule the appropriate width. This only affects the number of pages horizontally, not
vertically. This does not scale the output. The Calendar View has a unique Page Optionsdialog to which
the procedures detailed below do not apply.

To fit the printed Schedule View or Resource View to a number of pages wide:

1. From the Application menu, select Print and choose Page Options from the submenu.

    The Page Options dialog opens.

2. From the Format drop-down list, select Fit to Pages (Width).

3. Enter a value in the Number of Pages Across box.

    For instance, if you enter the value 2, the document fits to span 2 pages.

4. Click OK to apply your changes and close the Page Options dialog.

Notes:

- When Fit to Pages (Width) is selected, you will not be able to resize the timescale and columns in the
timeline – as the application automatically defines their width.
- For large schedules, fitting to a small number of pages may cause the timeline-columns to contract to
a size too small to display timescale labels. Either choose a larger number of pages or hide columns to
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gain more space.

See also:

Using Print Preview 

Printing the Calendar View 

Setting the Calendar View page options 

17.7 Making a wall chart

Making a wall chart
Making a wall chart prints the Schedule View or Resource View in such a way that the pages, which are
completely separate in a standard layout, can be pieced together to form one large page. This allows
you to use a small printer to create a large wall chart. The Calendar View has a unique Page Option
dialog to which the procedures detailed below do not apply.

To define the schedule as a wall chart:

1. From the Application menu, select Print and choose Page Options from the submenu.

    The Page Options dialog opens.

2. From the Format drop-down list, choose Wall Chart (Tiled).

3. Use the options that appear to define a border around the schedule.

4. Click OK to create the wall chart and close the Page Options dialog.

To view the wall chart:

1. From the Application menu, select Print and choose Print Preview from the submenu.

2. To view the wall chart as it will look when pieced together, select the All Pages checkbox from the

Page Map Toolbar.

To piece together the wall chart:

1. Print all pages of the wall chart.
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2. Cut the right and bottom edge off of each page except the pages that form the right and bottom of the

Wall Chart.

3. Tape together seams.

Hint:

Cut the pages flush to the very edge of the printing.

See also:

Using Print Preview 

Printing the Calendar View 

Setting the Calendar View page options

17.8 Breaking printed pages at rows

Breaking printed pages at rows
In the Schedule and Resource Views, breaking the printed page at a row allows you to determine where

the pages break and which row is the last on the page. 

To break a page at a specific row:

 1. If it is displayed, click in the Page Break action column of the desired row.

    -or-

1. Select the desired row and from the Insert menu, select Page Break.

   -or-

1. In the Schedule View, select the row that you want to be the last on a printed page.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Row dialog opens.
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3. In the Display tab, select the Page Break After this Row checkbox.

4. Click OK to apply your changes and close the Format Row dialog.

To break a page at a specific resource row:

1. If it is displayed, click in the Page Break action column of the desired row.

    -or-

1. Select the desired row and from the Insert menu, select Page Break.

    -or-

1. In the Resource View, select the row that you want to be the last on a printed page.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Resource Row dialog opens.

3. In the Display tab, select the Page Break After this Row  option.

4. Click OK to apply the page break and close the Format Resource Row dialog.

Note:

You can also define that no partial rows (broken rows) are printed at the bottom of the page by selecting

the Break Page at Rows option in the Page Options dialog of the Schedule View or Resource View.

See also:

Using Print Preview 

Printing the Calendar View 

Setting the Calendar View page options

17.9 Printing a schedule

Printing a schedule



Printing & Previewing 233

Copyright © 2010, AEC Software, Inc. All rights reserved.

Printing a schedule outputs your schedule to a printer, creating a hard copy.

To print a schedule:

1. From the Application menu, select Print and choose Print from the submenu.

    If you are connected to a printer, this will print the schedule.

See also

Using Print Preview 

Printing the Calendar View 

Setting the Calendar View page options

17.10 Choosing Page Options

Choosing Page Options
Choosing page options allows you to fine tune the form, margins, and display of the printed schedule.

The Calendar View has a unique Page Options dialog to which the procedures detailed below do not

apply.

To select Page Options for the Schedule View or Resource View:

1. In the Schedule or Resource View, from the Application menu, select Print and choose Page Options.

    -or-

    In Print Preview, in the Printing group, click Page Options.

    The Page Options dialog opens.

2. Select from the options described below.

To do this: Do this:
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Format

Print pages normally From the Format drop-down list, select

Standard.

Print a Wall Chart From the Format drop-down list, select Wall

Chart (Tiled).

Fit to a specific number of

pages

From the Format drop-down list, select Fit to

Pages (Width).

Alignment

Align on the printed page From the Alignment area, choose Left, Center,

or Right.

Margin

Offset from page edge Enter Top, Left, Right, and Bottom margins.

Standard Options

Print the pages in reverse

order

Select Print Back to Front.

Print row numbers Select Print Row Numbers.
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Allow only full rows Select Break Page at Rows

Allow only full columns Select Break Page at Columns

Repeat on Every Page

Print columns on each page Select Left Locked Columns and/or Right

Locked Columns

Print timescales on each page Select Top Headings and/or Bottom Headings.

Blank Rows

Add a number of blank rows

and then fill the last page with

blank rows, UNLESS the

number of rows needed to fill

the last page exceeds the

maximum number of rows set

below.

Enter a Minimum value.

Set the maximum number of

blank rows that can be added

to the schedule. The last page

Enter a Maximum value.
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of the schedule will not fill with

rows if it exceeds this number.

3. Click OK to apply your changes and close the Page Options dialog.

See also:

Using Print Preview

Printing the Calendar View 

Setting the Calendar View page options

17.11 Setting up the page

Setting up the page
Page Setup defines how the schedule appears on the printed page. Your selected printer determines the

options in the Page Setup dialog. Commonly, there are options for orientation, paper size, and for

Postscript printers, scaling.

To use Print Setup:

1. From the Application menu, select Print and choose Print Setup.

2. Select either the portrait (vertical) or landscape (horizontal) orientations.

3. Select the size of the paper.

4. Select special print options.

5. Click OK to print the schedule and close the dialog.

Hint: 

Most schedules print best in landscape (horizontal) orientation.



Printing & Previewing 237

Copyright © 2010, AEC Software, Inc. All rights reserved.

See also:

Using Print Preview 

Printing the Calendar View 

Setting the Calendar View page options

17.12 Exporting the page as a picture

Exporting the page as a picture
Exporting the page image as a picture allows you to use it in other documents (such as reports and

presentations) or display it on a web page as a simple graphic. You can determine exactly how the page

is exported using the Export as Picture dialog.

When you select Export Picture from within the Print Preview window, the document (or portions thereof)

that appears on the currently selected page is exported. When you select Export Picture from outside of

the Print Preview window, the entire View (regardless of pages) is exported.

The file types are: Windows Bitmap (BMP), Windows Enhanced Metafile (EMF), JPEG/JFIF (JPG),

Portable Network Graphic (PNG), Tagged Image File Format (TIF), Macintosh PICT (PCT)

To export the page of the specified View as a picture:

1. In the Quick Access toolbar, click the Print Preview icon.

2. From the Application menu, select Export, and choose Picture from the submenu.

    The Export as Picture dialog opens.

3. Choose to export the picture to the Clipboard or a File.

    If necessary, use the Browse button to navigate to a file on disk and choose the file name, location,
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and, on Windows, what type of file to save as.

4. To export just the schedule, resource, or calendar portion of the current page, select Export

Document Only.

    -or-

    To export the schedule, resource, or calendar portion, the text boxes and graphics, and the image of

the paper on the current page, select Export Document and Paper.

    -or-

    To export the schedule, resource, or calendar portion and the items on the current page, select

Export Document and Page Items.

5. Click OK to export the picture and close the Export as Picture dialog.

To export the entire View as a picture:

1. Close the Print Preview window (if open).

2. From the Application menu, select Export, and choose Picture from the submenu.

    This exports the entire View (Schedule, Resource, or Calendar), regardless of pages or Print Preview

items.

See also:

Using Print Preview 

Printing the Calendar View 

Setting the Calendar View page options
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18 Filters & Sorts

18.1 Working with filters and sorts

Working with filters and sorts

Filtering uses search criteria that you define to identify information in rows, activity bars and resource

rows. It then allows you to apply filters to the Schedule, Resource, and Calendar Views to hide or select

activities or resources that match the criteria. Because the Calendar View uses the same data as the

Schedule View, filters created in the Calendar View are applicable in the Schedule View or vice versa.

Filters created in the Schedule View or Calendar View, however, are not applicable to the Resource View

or vice versa.

Creating or editing filters 

Applying filters 

Hiding and showing rows 

Restoring hidden rows 

Sorting allows you to define sort criteria and then arrange activity or resource rows in order by values in

different columns. Because the Calendar View does not have rows and columns, sorts are not available.

Sorts created in the Schedule View are not applicable to the Resource View or vice versa.

Defining sort criteria

Applying sorts

Restoring sorted rows 
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18.2 Creating or editing filters

Creating or editing filters
Filters can be created and edited in the Define Filter dialog.

To create or edit a filter:

1. On the Project tab, in the Sort & Filter group, click Filters, and choose Define from the drop-down list.

    The Filters dialog opens.

2. Click the New button to create a new filter.

    The Define Filter dialog opens.

    -or-

    To edit an existing filter, in the Filters dialog, select the filter from the Filters table and click the Edit

button.

    The Define Filter dialog opens.

    The Define Filter dialog has three tabs.

3. Use the options in the Define Filter dialog to create or edit a filter.

4. Click OK to save your changes and close the Define Filter dialog.

5. In the Filters dialog, choose to either show or select the filtered activities or resources. 

    In the Calendar View, activity bars can only be shown or hidden by a filter, not selected.

6. Click OK to apply the selected filter and close the Filters dialog. 

    -or-

    Click Close if you do not want to apply the filter at that time.

    The filter is saved for future use.

See also:

Working with Schedule and Calendar View filters

Working with Resource View filters
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18.3 Working with Schedule and Calendar View filters

Working with Schedule and Calendar View filters
When you create a filter, there are three tabs in the Define Filter dialog with which you interact: the 

Options tab, theColumn/Value Criteria tab, and the Date/Time Criteria tab.

18.4 Setting filter options

Setting filter options
In the Options tab of the Define Filter dialog you organize every aspect of a Schedule or Calendar Views’

filter. In this tab you determine which type of criteria to apply, what constitutes a filter-matching activity,

and which outline levels and bars will display when the filter is applied.

To use the Options tab of the Define Filter dialog:

Apply:

This option: Means:

Column/Value

Criteria

In order to be shown or selected by this filter, an activity

must meet only the criteria defined in the Column/Value

Criteria tab.

Date/Time Criteria In order to be shown or selected by this filter, an activity

must meet only the criteria defined in the Date/Time

Criteria tab.
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Column/Value

Criteria AND Date/

Time Criteria

You are applying the filter criteria you laid out in both the

Date/Time and Column/Value Criteria tabs. In order to be

shown or selected by this filter an activity must meet the

criteria defined in each of those tabs.

Column/Value

Criteria OR Date/

Time Criteria

You are applying the filter criteria you laid out in both the

Date/Time Criteria and Column/Value Criteria tabs. In

order to be shown or selected by this filter an activity

need only meet the criteria defined in either one of those

tabs.

Expand All Prior to

Filtering

All subactivities will be displayed before the filter is

performed. Only visible rows are filtered.

Restore All Prior to

Filtering

All rows are restored before the filter is performed. Only

visible rows are filtered. Restoring does not necessarily

return your View to the same appearance it had before

you hid rows. If you have made changes that affect the

order of activities or resources, these changes cannot be

restored. Changes that affect the order of rows include:

moving, inserting, deleting, cutting, and pasting rows.

Apply All Bars

Range After Filtering

After the filter is applied, your timeline range will begin

on the earliest activity Start Date/Time and end on the
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Finish Date/Time of the latest scheduled activity.

Filter A Row When Options:

This option: Means:

Filter A Row When

Any Bar in that Row

Matches

In rows with multiple bars, if any of a row’s bars meets

the filter criteria, that row will be shown or selected.

First Bar in that Row

Matches

In rows with multiple bars, only those rows whose first

bar meets the filter criteria will be shown or selected.

All Bars in that Row

Match

In rows with multiple bars, a row will be shown or

selected only if every bar in that row meets the filter

criteria.

Matching Rows Display Options:

This option: Means:

Bars Options:

All Bars in the Row In rows with multiple bars, every bar in the row will

display if any bar in the activity meets the filter criteria.

Matching Bars Only In rows with multiple bars, only those bars that meet the

filter criteria will display.
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Rows Options:

Matching Rows

Only

The filter will show or select only those activities that

meet the filter criteria, on any visible outline level.

Matching Rows

AND Parents

The filter will show or select the activities that meet the

filter criteria and the activities one or more level up in the

same outline.

… AND Children The filter will show or select the activities that meet the

filter criteria and any subactivities one or more outline

level below.

… AND Parents and

Children

The filter will show or select the activities that meet the

filter criteria; the activities one or more level up in the

same outline; and any subactivities one or more outline

level below.

…AND Families The filter will show or select every activity on every level

of the outline for those activities that meet the filter

criteria.

See also:
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Working with Schedule and Calendar View filters 

Filtering and sorting 

18.5 Creating a column/value filter

Creating a column/value filter
You set the criteria for a Column/Value filter in the Column/Value Criteria tab of the Define Filter dialog.

Criteria you set in this tab can then be used as part or all of the filter that you define in the Options tab.

To use the Column/Value Criteria tab of the Define Filter dialog:

1. In the Schedule or Calendar View, on the Project tab, in the Sort & Filter group, click Filters, and

choose Define from the drop-down list.

    The Filters dialog opens.

2. Click the New button to create a new filter.

3. In the Filter Name box, enter a name for your filter.

4. Click the Column/Value Criteria tab.

5. From the Column drop-down list, click to select a column in which to search for the Value, for

instance Activity Name.

6. Click the Test cell in the table.

7. From the Test drop-down list, select the appropriate comparer for the column value, for instance <>

(not equal to).

8. Click the Value cell in the table. 

9. Enter a value to look for in the specified column, for instance Laura Spears.

    -or-

    From the Insert Function/Column into Value drop-down list, select a column or function. 

    A function is a value that represents a variable. 
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Notes:

- If you have defined a value list for a column, that value list will appear in the Value cell when the column
is selected in the Column cell. This helps avoid typing errors and insures accuracy. Value lists are built
in the Value List tab of the Format Column dialog. Create a drop-down list or pop-up value list and use
the Build From Data button to enter all the unique column data into the value list.
- You can define multiple criteria in a single filter by entering additional lines in the table. Multiple lines
must be separated with "And" or "Or" in the And/Or column on the right of the table. "And" narrows the
search as the activity must meet both criteria. "Or" expands the search as the activity can meet either
criteria.
- To group multiple criteria together to change their meaning, click the parentheses cells ( ).
- When filtering for a value made up of a certain set of consecutive letters, instead of matching the entire
value, enter the wildcard character which is an asterisk *. For instance, to search a column for the word
"train" as any part of a value, enter *train*. Such a search will find the words "retrain" and "training" as
well as "train."
- Click the buttons to add a new line to the filter (between two existing rows), clear a line from the filter,
or clear all filters from the table.

See also:

Working with Schedule and Calendar View filters

Filtering and sorting

18.6 Creating a date/time filter

Creating a date/time filter
You set the criteria for a Date/Time filter in the Date/Time Criteria tab of the Define Filter dialog. Criteria

you set in this tab can then be used as part or all of the filter that you define in the Options tab.

To use the Date/Time Criteria tab of the Define Filter dialog:

This option: Does this:

Bars

(componenet)

Sets the date/time filter to look only at the Scheduled,

Revised, or Actual component of activity bars in the schedule.
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Starts In Asks the filter to search bars whose selected component

starts in the specified date/time range.

Ends In Asks the filter to search bars whose selected component

ends in the specified date/time range.

Is Contained In Asks the filter to search bars whose selected component is

contained within the specified date/time range.

Spans Asks the filter to search bars whose selected component

contains, within its dates and times, the specified date/time

range.

This option: Does this:

Date/Time

Range

Current  "X" Allows you to select from a drop-down list a defined date or

time to act as the filter’s specified date/time range. Select

from Current Hour, Day, Week, Month, Quarter, or Year.

Custom

Defined Range

From the drop-down list, select Custom Defined Range. This

allows you to define, using the numerous options provided, a
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range of dates and/or times that will act as the filter’s

specified date/time range. You can set a Start Date/Time and

a Finish Date/Time or use a calculation to be the basis of

your custom range. Then, you can choose to have the range

start or finish a select number of units before or after the

custom range. For example, this could allow you to filter for

the month of October plus an additional 14 days.

See also:

Working with Schedule and Calendar View filters

Filtering and sorting

18.7 Working with Resource View filters

Working with Resource View filters
Though you can create filters in all three Views, the Resource View has different columns and data than

the Schedule and Calendar Views and therefore has different filter options. All the filter options for the

Resource View are available in a single tab in the Define Filter dialog.

To create a Resource View filter:

1. In the Resource View, on the Project tab, in the Sort & Filter group, click Filters, and choose Define.

    The Filters dialog opens.

2. Click the New button to create a new filter.

3. In the Filter Name box, enter a name for your filter.

4. Select a cell in the Column column of the table.

5. From the Column drop-down list, click to select a column in which to search for the Value, for
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instance Resource Name.

6. Click the Test cell in the table.

7. From the Test drop-down list, select the appropriate test for the column value, for instance < [Less

Than].

8. Click the Value cell in the table. 

9. Enter a value to look for in the specified column, for instance Sue Jones.

    -or-

    From the Insert Function/Column into Value drop-down list, select a function. 

    A function is a value that represents a variable.  For instance the current date or the Per Use Cost

value of the resource you are searching.

Notes:

- If you have defined a value list for a column, that value list will appear in the Value cell when the column
is selected in the Column cell. This helps avoid typing errors and insures accuracy. Value lists are built
in the Value List tab of the Format Column dialog. Create a drop-down list or pop-up value list and use
the Build From Data button to enter all the unique column data into the value list.
- You can define multiple criteria in a single filter by entering additional lines in the table. Multiple lines
must be separated with "And" or "Or" in the And/Or column on the right of the table. "And" narrows the
search as the resource must meet both criteria. "Or" expands the search as the resource can meet
either criteria. 
- The top-to-bottom order of filters in the Column/Value Criteria tab determines the order filters are
performed.
- To group multiple criteria together to change their meaning, click the parentheses cells ( ).
- When filtering for a value made up of a certain set of consecutive letters, instead of matching the entire
value, enter the wildcard character which is an asterisk *. For instance, to search a column for the word
"train" as any part of a value, enter *train*. Such a search will find the words "retrain" and "training" as
well as "train."
- Click the buttons to add a new line to the filter, clear a line from the filter, or clear the entire table by
deleting all lines from the table.

See also:

Working with Schedule and Calendar View filters 
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18.8 Deleting a filter

Deleting a filter
Filters can be deleted in the Filters dialog.

To delete a filter:

1. On the Project tab, in the Sort & Filter group, click Filters, and choose Define from the drop-down list.

    The Filters dialog opens.

2. Select the filter you wish to delete.

3. Click the Delete button.

    A confirmation dialog appears asking you to verify that the filter will be deleted.

4. Click OK to delete the filter or Cancel to retain the filter.

    If you delete the filter, it will no longer be available from the Filters Toolbar or Filters submenu.

5. Click OK to close the Filters dialog and apply the filter that is currently selected.

    -or-

    Click Close to close the Filters dialog without applying a filter.

See also:

Working with Schedule and Calendar View filters 

Filtering and sorting 

18.9 Duplicating a filter

Duplicating a filter
Filters can be duplicated in the Filters dialog.

To duplicate a filter:

1. On the Project tab, in the Sort & Filter group, click Filters, and choose Define from the drop-down list.
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    The Filters dialog opens.

2. Select the filter you wish to duplicate.

3. Click the Duplicate button.

    The Define Filter dialog opens.

4. Edit the new filter.

5. Click OK to save the filter and close the Define Filter dialog.

6. Click OK to close the Filters dialog and apply the filter that is currently selected.

    -or-

    Click Close to close the Filters dialog without applying a filter.

See also:

Working with Schedule and Calendar View filters 

Filtering and sorting

18.10 Applying a filter

Applying a filter
When you apply a filter, FastTrack Schedule searches the displayed activities for values that match the

filter criteria. It then selects or shows only those matching activities.

To apply a filter:

1. On the Project tab, in the Sort & Filter group, click Filters, and choose from the list of existing filters

in the drop-down list.

    -or-

    On the Project tab, in the Sort & Filter group, click Filters, and choose Define from the drop-down list.

    The Filters dialog opens.
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2. Select the filter you want to apply from the table of filter names.

3. In the Matching Rows area, select either Show, which displays only those activities that meet the

filter criteria, or Select, which highlights the activities that meet the filter criteria.

    In the Calendar View, activity bars can only be shown or hidden by a filter, not selected.

4. Click OK to apply the selected filter and close the Filters dialog.

Notes:

- The filter only looks at displayed data. The default setting in the Options tab of the Define Filter dialog
is to restore and expand all rows prior to filtering. If these options are changed and a row, activity bar,
resource row, or resource subrow is not displayed because it is hidden or collapsed, that information is
not searched.
- In order to match the filter criteria, the entire value of the searched cell must match the search value.
For instance, if the filter was searching the Resource Name column, and the search value was
"Johnson," a resource named "Johnson" would match, but "Seth Johnson" would not match. Using the
wildcard character (*) in your filter criteria, the search value "*Johnson" would find "Seth Johnson."
- Any changes you make to the order of rows while rows are hidden may not be restored. Changes that
affect the order of activities include: moving rows, inserting rows, deleting rows, cutting rows, and pasting
rows.
- The main purpose of selecting rows with a filter is to highlight them. Once rows are highlighted, you
may select either Hide Selected or Hide Unselected from the Tools menu or perform other selection-
based operations like copying, deleting, and moving.

See also:

Hiding and showing rows 

Restoring hidden rows 

Creating and editing filters 

Filtering and sorting 

18.11 Showing and hiding rows

Showing and hiding rows
You can hide and show rows using commands in the Editing group on the Home tab. This allows you to

select individual rows to be hidden.
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To show only the selected rows:

1. Select the row or rows.

2. Right-click and choose Hide Unselected from the context menu.

    This leaves visible only the rows that are selected, hiding all other rows.

To hide rows:

1. Select the row or rows.

2. On the Home tab, in the Edit group, choose Hide Selected Rows.

    -or-

    Right-click and choose Hide from the context menu.

    This hides all selected rows leaving visible only the rows that are unselected.

Note:

Once you have hidden rows, through the menu or with a filter, you can show them all again by restoring

the rows. This shows all hidden rows and rearranges them so that they resume their original, Master

Sort order. Right-click a visible row and choose Restore All from the context menu. Restoring does not

necessarily return your View to the same appearance it had before you hid rows. If you have made

changes that affect the order of activities or resources, these changes cannot be restored. Changes that

affect the order of rows include: moving, inserting, deleting, cutting, and pasting rows.

See also:

Restoring hidden rows

Filtering and sorting
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18.12 Restoring hidden rows

Restoring hidden rows
Once you have hidden rows, through the menu or with a filter, you can show them again by restoring

rows. This shows all hidden rows and rearranges them so that they resume their original, Master Sort

order.

To restore hidden rows in Schedule or Resource Views:

1. On the Project tab, in the Sort & Filter group, click Restore All.

Note:

Restoring does not necessarily return your View to the same appearance it had before you hid rows. If

you have made changes that affect the order of activities or resources, these changes cannot be

restored. Changes that affect the order of rows include: moving, inserting, deleting, cutting, and pasting

rows.

See also:

Hiding and showing rows 

Filtering and sorting 

18.13 Defining sort criteria

Defining sort criteria
Setting up a sort defines the columns that are used to arrange rows in the Schedule and Resource

Views. You can define multiple-level sorts that arrange rows based on more than one value. Sorts

created in the Schedule View are not applicable in the Resource View or vice versa. The Calendar View

does not support sorts as it does not display data in rows.
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To use the Define Sort dialog:

1. In the Schedule or Resource View, on the Project tab, in the Sort & Filter group, click Sorts, and

choose Define from the drop-down list.

    The Sorts dialog opens.

2. In the Sorts dialog, click the New button to define a new sort.

    -or-

    To change an existing sort, select a sort from the Sorts table and click the Edit button.

3. Enter or edit the name of the sort in the Sort Name box.

4. In the Columns table, click the name of the column by which you want to sort.

5. Click Show to send it to the Sort Order table.

    Remove columns from the Sort Order table by clicking the Hide or Hide All buttons.

6. To define a multi-level sort, show more than one column in the Sort Order table.

7. To change the order of sorts in a multi-level sort, click on a sort in the Sort Order table and drag the

sort up or down and release it in the desired position.

    The top-to-bottom order of sorts in the Sort Order table determines the order sorts are performed.

8. To change the order in which values are arranged, click the Ascending or Descending icons (stair

steps).

9. In the Schedule View only, select from the options described below.

This option: Does this:

All Rows to Move Anywhere Rearranges rows anywhere, regardless of the

outline levels.

Only Within Outline Levels Retains outline levels by only rearranging rows

within each outline level.
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Lock Outline Levels Through Level Allows you to specify which outline line levels

with be retained in a sort. Select how many

outline levels you wish to lock.

10. Click OK to save the sort criteria and close the Define Sort dialog.

11. Click OK to apply the selected sort and close the Sorts dialog.

    -or-

    Click Close to close the dialog without applying the sort.

    The sort is saved for later use.

Important:

For Schedule View sorts, the Only Within Outline Levels move rows option ensures that activities do not

move out of their respective outline levels when sorted. When the All Rows to Move Anywhere option is

selected, rows can move out of their outline levels. Changes made to the order of activities while the

schedule is sorted in this manner cannot be restored.

See also: 

Applying sorts 

Restoring sorted rows 

Filtering and sorting 

18.14 Deleting a sort

Deleting a sort
Sorts can be deleted in the Sorts dialog.
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To delete a sort:

1. On the Project tab, in the Sort & Filter group, click Sorts, and choose Define from the drop-down list.

    The Sorts dialog opens.

2. Select the sort you wish to delete.

3. Click the Delete button.

    A confirmation dialog appears asking you to verify that the sort will be deleted.

4. Click OK to delete the sort or Cancel to retain the sort.

    If you delete the sort, it will no longer be available from the Sorts Toolbar or Sorts submenu.

5. Click OK to close the Sorts dialog and apply the sort that is currently selected.

    -or-

    Click Close to close the Sorts dialog without applying a sort.

See also:

Defining sort criteria 

Applying sorts 

Filtering and sorting

18.15 Duplicating a sort

Duplicating a sort
Sorts can be duplicated in the Sorts dialog.

To duplicate a sort:

1. On the Project tab, in the Sort & Filter group, click Sorts, and choose Define from the drop-down list.

    The Sorts dialog opens.
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2. Select the sort you wish to duplicate.

3. Click the Duplicate button.

    The Define Sort dialog opens.

4. Edit the new sort.

5. Click OK to close the Sorts dialog and apply the sort that is currently selected.

    -or-

    Click Close to close the Sorts dialog without applying a sort.

 

See also:

Defining sort criteria 

Applying sorts 

Filtering and sorting

18.16 Applying a sort

Applying a sort
Applying a sort rearranges rows based on the values in their sorted columns. For multiple-level sorts,

rows are arranged in order initially by the first column. Then, all rows with the same value in the first sort

are arranged in order by the values in their second column.

To apply a sort:

1. On the Project tab, in the Sort & Filter group, click Sorts, and choose from the list of existing sorts in

the drop-down list.

    -or-

    On the Project tab, in the Sort & Filter group, click Sorts, and choose Define from the drop-down list.

    The Sorts dialog opens.
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2. Select the name of the sort you wish to apply from the Sorts table.

3. If desired, select the Define as Master Sort checkbox to designate the currently selected sort as the

Master Sort.

4. Click OK to apply the sort and close the Sorts dialogs.

    -or-

    Click Close to close the dialog without applying the sort.

    The sort is saved for later use.

Important: 

Defining a sort as the Master Sort deletes the original order of your rows – the one to which you return

when you use Restore All. 

Note:

Any changes you make to the order of rows while they are sorted may not be restored. Changes that

affect the order of rows include: moving, inserting, deleting, cutting, and pasting rows.

See also:

Defining sort criteria 

Restoring sorted rows 

Filtering and sorting 

18.17 Restoring sorted rows

Restoring sorted rows
Once you have sorted rows, you can return to the original, Master Sort order again by restoring the rows.
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To restore sorted rows in Schedule or Resource Views:

1. On the Project tab, in the Sort & Filter group, click Restore All.

Note:

Restoring does not necessarily return your View to the same appearance it had before you sorted rows.

If you have made changes that affect the order of activities or resources, these changes cannot be

restored. Changes that affect the order of rows include: moving, inserting, deleting, cutting, and pasting

rows. 

See also:

Defining sort criteria 

Applying sorts 

Filtering and sorting 

19 Work Calendars

19.1 Using Work Calendars

Using Work Calendars
In Fast Track Schedule there are three types of work calendars: project, activity and resource. You
assign just one work calendar to the project, but any activity can be assigned a separate work calendar
and every resource has its own work calendar. Each of these calendars is edited in the Work Calendar
dialog and each of these calendars is completely customizable.

Work calendars allow you to define typical work days and exceptional days for the project, each
resource and any activity.

Work Calendars helps you accurately track the amount of time available for work on activities. Once
Work Calendars have been defined, you can use them in several ways:
- To display the work schedule in the Schedule View timeline by hiding and/or shading non-work times.
- To help you schedule activities during project work times only.
- To help you note assigned resources' non-work periods.

There are three key elements of the Work Calendar:  the [selected] Calendar, Typical Days, and Specific
Days.



Work Calendars 261

Copyright © 2010, AEC Software, Inc. All rights reserved.

This
element:

Does this:

[Selected]
Calendar

Determines the calendar you assign to a project, activity or
resource and from which you may build a custom calendar.
Choose from: Standard - 8 hour work days Monday -Friday, 24
Hours - 24 hour work days seven days a week, Night Shift - a
40 hour work week from 11 PM - 8 AM, and any custom
calendars you have created.

Typical
Week Day

Allows you to set up a work schedule in which each day of the
week might have different hours, for instance, a Monday might
differ from other days.

Exceptions Defines the specific days of the year that deviate from the
typical days. Each specific day can have its own set of hours or
no hours. For example, you might want to designate holidays as
exceptions. Exceptional days are listed in the Exceptions table
and can be given a descriptive name.

You can copy and paste a Work Calendar from another file if you would like to use that Work Calendar’s
arrangement.

What would you like to do?

 Define the Work Calendar

 Display the Work Calendar

 Calculate durations in work units

 Drag bars using the Work Calendar

19.2 Defining the Work Calendar

Defining and editing a Work Calendar
Defining and editing Work Calendars allows you to determine the hours of the day that are considered

work hours for typical and specific days for the project, an activity or a resource.
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To define or edit a Work Calendar:

1. On the Project tab, in the Details group, click Work Calendars.

    The Work Calendars dialog opens.

2. Define the Work Calendars with the options described below.

To select a calendar:

1. In the Work Calendar dialog, use the Calendar drop-down list to choose from: Standard - 8 hour work

days Monday -Friday, 24 Hours - 24 hour work days seven days a week, Night Shift - a 40 hour work

week from 11 PM - 8 AM, and any custom calendars you have created.

To create a new calendar:

1. In the Work Calendar dialog, click the New button.

2. In the New Work Calendar dialog, enter a name for the new calendar and choose a calendar on which

to base the new calendar.

To set the work hours for a Specific day (such as a vacation day):

1. In the Work Calendars dialog, in the Define Specific Days area, select a year and month to display

from the drop-down lists.

    The month appears in the calendar below. 

2. Select a day from the calendar. 

3. In the Work Shift Details table, enter the periods of time that should be considered work hours for that

day.

    -or-

    Click the Create Exception button to remove all work hours from that day.

    All Specific days appear as an item in the Exceptions table to which you can give a descriptive name.

    The total work hours for that specific day appear in the calendar.
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4. Click OK to apply your changes and close the Work Calendars dialog.

To set the work hours for a Typical day of the week (such as every Monday):

1. In the Define Typical Week Days area, click on the day of the week for which you want to define

typical hours.

2. In the Work Shift Details table, enter the periods of time that should be considered work hours for that

day of the week.

    The total number of work hours appears under that day in the Define Typical Week Days area.

3. Repeat this procedure for each day of the week you wish to set.

4. Click OK to apply your changes and close the Work Calendars dialog.

To set the work hours for the Base Work Day (used in calculations):

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The FastTrack Schedule Document Options dialog opens.

3. Click the Project tab.

4. In the Calendar Calculations section, in the Hours per Day control, enter the number of hours in a
base work day.
    The Base Work Day defines how durations of work hours are calculated.

5. Click OK to apply your changes and close the Document Options dialog.

Notes:

- Only exceptional days are displayed in the calendar shown in the dialog.
- In the Hours area, you must enter periods of time in both the Start and Finish columns. For instance,
the default Standard work day is 8:00AM to 12:00PM and 1:00PM to 5:00PM.
- The Copy Day button copies the work shift details for a typical or specific day to the Clipboard. The
Paste Day button pastes work shift details from the Clipboard to a typical or specific day.
- The work shift details for a typical day can be pasted to a specific day or vice versa.
- The Copy Calendar button copies the contents of a work calendar to the Clipboard. The Paste Calendar
button pastes a Work Calendar from the Clipboard to the open Work Calendar.
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See also:

Using the Work Calendar 

19.3 Displaying the Work Calendar

Displaying the Work Calendar
In the Schedule View timeline you can shade or hide non-work days. You can also set what day a

typical week begins or ends on and what hours will be displayed in the schedule. 

To shade non-work days in the timeline graph:

1. In the Schedule View, on any tab, in the View group, click the Dialog Box Launcher.

    The Format Schedule View dialog opens.

2. In the Display tab, select Days from the Timeline Units drop-down list. 

3. Select the Shade Non-Work option.

4. Select the color and/or pattern you would like to shade non-work days.

5. Click OK to apply your changes and close the Format Schedule View.

    This fills, with the specified shade pattern and color, the timeline graph columns that have no work

hours in them.

To hide non-work days in the timeline graph:

1. In the Schedule View, on any tab, in the View group, click the Dialog Box Launcher.

    The Format Schedule View dialog opens.

2. In the Display tab, select "Hours" or "Days" from the Timeline Units drop-down list.

3. Select the Hide Continuous Non-Work/Shade Other option.

4. Select the color and/or pattern you would like to shade other days.
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5. Click OK to apply your changes and close the Format Schedule View.

    For schedules in base timeline units of days, this hides non-work periods that span 12:00 AM (as

defined by Typical and Specific Days), and shades other non-work periods.

Important:

Dragging the middle of a bar when hiding non-work periods can cause activity bars to jump when you

drag them over non-work periods. This is because dragging the middle of a bar keeps its Duration

constant and therefore the bar must lengthen or shorten to account for the hidden periods of time. This

helps to avoid scheduling activities during non-work periods.

To set the day on which a typical week begins or ends:

1. In the Schedule View, on any tab, in the View group, click the Dialog Box Launcher.

    The Format Schedule View dialog opens.

2. In the Display tab, deselect the Use the Application Preferences for Weeks Timeline option.

3. Use the Typical Week options to determine on which day a typical week Starts or Ends.

4. Select the day from the drop-down list.

5. Click OK to apply your changes and close the Format Schedule View.

To set the hour display in the timeline:

1. In the Schedule View, on any tab, in the View group, click the Dialog Box Launcher.

    The Format Schedule View dialog opens.

2. In the Display tab, select Hours from the Timeline Units drop-down list.

3. Set the Hour Display Start time and the Hour Display End time.

4. Click OK to apply your changes and close the Format Schedule View.

Note:
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Hour Display options are only available when you choose Hours from the Timeline Units pull-down list.

See also:

Defining the Work Calendar 

Dragging bars using the Work Calendar 

Using the Work Calendar 

19.4 Calculating durations in work units

To calculate durations in work units:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu.

2. In the Application menu, click the Document Options button at the bottom of the menu.

    The FastTrack Schedule Document Options dialog opens.

2. Click the Project tab.

3. In the Units section, Duration Units drop-down list, select a unit.
4. Click OK to apply your changes and close the Document Preferences dialog.

Important:

Dragging the middle of a bar while calculating durations in work units can cause the bar to jump when

dragged over non-work periods. 

Notes:

- The units in which durations are calculated is set for the entire document (not per column). 
- If you draw a new bar entirely within a non-work period, the duration is entered as 0. Therefore, when
you drag that bar to a work period, it will have no length.

See also:
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Defining the Work Calendar 

Dragging bars using the Work Calendar 

Using the work calendar 

19.5 Dragging bars using the Work Calendar

Dragging bars using the Work Calendar
In the Schedule View, dragging activity bars while using Work Calendar options helps you avoid

scheduling activities during non-work periods by jumping the bar’s start point, or end point, over non-work

periods.

Dragging bars while Work Calendar options are selected is done in the same manner regardless of work

units. The behavior of the bar, however, may be different. When dragging the middle of a bar (not

necessarily the start or end points, though), the bar may jump for the following reasons:

Work Calendar option: Hide Continuous Non-Work/Shade Other is selected in Format Schedule View

dialog.

- Behavior: Dragging the middle of the bar causes the entire bar to extend or compress over hidden
non-work periods.
- Why? Periods of time represented in the duration are hidden, therefore the part of the bar that is over a
non-work period is also hidden.

Work Calendar option: Duration Units calculated in a custom Work Calendar instead of a 24-Hour

Calendar (set in Document Options dialog).

- Behavior: Dragging the middle of a bar forward to the right causes the end point to jump. Dragging the
bar backwards to the left causes the start point to jump.
- Why? When you drag to the right, the Finish is calculated as the Start plus the Duration. Because the
Duration is in work units, the Finish must fall in a valid work period. Therefore the end point jumps to the
next valid work period. When you drag to the left, the Start is calculated as the Finish minus the
Duration and will therefore jump backwards to the next valid work period.
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See also:

Defining the Work Calendar 

Displaying the Work Calendar

Calculating Durations in work units

Using the work calendar

20 Importing and Exporting

20.1 Importing data

Importing data
You can use data that has been created in another application in FastTrack Schedule. Import data from

the Clipboard or a file into an open schedule. 

FastTrack Schedule imports and exports ASCII text – the standard text format. Importing works just as if

you were entering the data: appending to the first empty row, the first value is read into the first column.

When it encounters a value separator (either a tab or comma), it moves to the next column and enters

that value. It continues this way until it sees a row separator (hard return) and then begins entering

values in the next row.

FastTrack Schedule can also open Microsoft Project .MPP files and import and export Microsoft

Project .XML and .MPX files.

To import data into the Schedule or Resource Views

1. Store the data you wish to import by saving it as an ASCII text file or by copying it to the Clipboard.

2. Position the columns in your layout so that their order will match the imported data.



Importing and Exporting 269

Copyright © 2010, AEC Software, Inc. All rights reserved.

3. Select the order of bar styles in the list of bar styles in the Bar Styles group.

    The first set of dates corresponds to the first bar style in the list, the second set of dates to the

second bar style, and so on. 

4. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, select Import, and choose Data from the submenu.

    The Import Data dialog opens.

5. Select from the options described below.

This Option: Does This:

Source:

File Allows you to select a file saved on disk to import.

Browse Opens a dialog where you can navigate to a file whose data

you want to import.

Clipboard Imports data that is stored on the Clipboard.

Options

Values

Separated

with

Tabs Looks for tabs between values.



FastTrack Schedule 10 User Manual270

Copyright © 2010, AEC Software, Inc. All rights reserved.

Commas Looks for commas between values.

Locate

Multiple Bars

on

Same

Alignment Grid

For lines of data that contain multiple sets of dates,

corresponding activity bars will be drawn on the same

alignment grid within the row.

New Alignment

Grid

For lines of data that contain multiple sets of dates,

corresponding activity bars will be drawn on the successive

alignment grid within the row (only applicable if there are

multiple grids).

Number of

Activity Levels

Defines the maximum number of outline levels to be imported.

For instance, enter 2 if the import data contains activities with

only one level of subactivities.

Import First

Item

Imports the first line of data as an activity or resource. Do not

select this if the first line of data is a column heading.

Import

Settings
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Show Import

Monitor

If selected, the Import Monitor appears when the import

begins; use it to check data as you import it (see table below

for details).

Fields

Enclosed in

Quotes

Removes any quotes that surround imported values.

Optimize

Outline Levels

Recognizes the same set of characters as a single outline

level. For instance if you had two columns, A and B, and

column A had the word Floor in every cell of rows 1-3 and

column B had 1, 2, and 3 as the values in its cells, when

optimized the data would import as Floor with 3 subactivities,

1, 2, and 3 indented below it. When not optimized, each

instance of the value Floor would be its own row with one

subactivity indented below it.

6. Click OK to save your import options and close the Import Data dialog.

If you selected to display the Import Monitor, it will appear once the import begins. Use the Import

Monitor to check data as it is imported, as described below.

Click: To do this:

Import the next value.
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Import all remaining values.

Delete the last value and import the next.

Cancel the import.

Note:

It is sometimes helpful to view the information to be imported in a word processing application or

spreadsheet. This allows you to see the exact order of the values and how they are separated.

See also:

Exporting data 

20.2 Inserting a picture

Inserting a picture
Inserting pictures into the Schedule View timeline or Print Preview window allows you to customize your

schedule with photos, company logos, clip art, and other images. You can also add image columns to

the Schedule View of your schedule.

The following file formats can be imported in FastTrack Schedule:

Windows Bitmap (BMP), Windows Enhanced Metafile (EMF), Windows Metafile (WMF), JPEG (JPG),
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Portable Network Graphic (PNG), Tagged Image File Format (TIF), Mac QuickDraw Picture (PICT)

To add a picture to the timeline:

1. On the Insert tab, in the Timeline Elements group, click Picture.

    The Insert Picture dialog opens.

2. Select Clipboard if you have previously saved an image to your Clipboard.

    -or-

    Select the File option and click the Browse button to navigate to a file.

3. Click OK to apply your changes and close the Insert Picture dialog.

To add a picture to an image column:

1. Insert an image column into your current layout.

2. Double-click in an image column cell.

    The Open dialog opens. 

3. In the Open dialog, navigate to an image file and select it.

4. Click Open to insert the picture into the image field and close the Open dialog.

Note:

If the Clipboard option yields no results, the item on the Clipboard is not in the correct format.

See also:

Exporting a picture 

Resizing pictures

Moving pictures

Formatting pictures
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20.3 Exporting data

Exporting data
You can export ASCII text to a file on disk or the Clipboard. This allows you to use activities, resources,

and other schedule data created within FastTrack Schedule as data in other applications.

FastTrack Schedule imports and exports ASCII text – the standard text format. Exporting is "what you

see is what you get." Only visible data will be exported. You hide, show, and position columns and rows

and then use the export options to make the data conform to the expectations of the application to

which you are exporting.

To export data from the Schedule or Resource Views:

1. Decide what types information you want to export and then hide, show, and position columns

accordingly.

2. Decide which activities or resources you want to export and then hide, show, collapse, expand, and

position rows in the layout accordingly.

3. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, select Export, and choose Data from the submenu.

4. Select from the options described below.

This Option: Does This:

Destination:

File Allows you to browse for a file.
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Browse Opens a dialog where you can navigate to the location

where your data will be exported.

Clipboard Exports the data to the Clipboard.

Activity Options (Schedule View only options)

Ignore Outline

Levels

Places all Activity Names in the same column and outline

level, regardless of whether or not they are indented.

Tab Outline

Levels

Moves indented subactivities to another column, creating a

column for each activity level.

Repeat Outline

Names

When the checkbox above is selected, this option repeats

the higher-level activity names in every blank cell that was

created by moving the subactivity level to another column.

Export

Subactivities Only

Only exports the activity names of activities that are at the

lowest level of indentation within the outline level.

Export Multiple

Bars per Activity

as 

(Schedule View only options)
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One Record – 

Database (Line-

feeds)

Places line feed characters instead of carriage returns after

each bar’s information. Use this for exporting to relational

databases (multiple sets of dates will be exported in the

same record).

Spreadsheet

(Tabs)

Places tabs instead of carriage returns after each bar’s

information. Use this for exporting to spreadsheets.

Separate Records Places carriage returns after each bar's information, forcing

each line to contain only one activity bar.

Repeat Activity

Values

Fills in the activity values for each set of bars that were left

empty when multiple bars were moved to new lines.

Separated

Values with

Tabs Places tabs between values as separators.

Commas Places commas between values as separators.

Data Options

Export as For users of Microsoft NT™, this assures that the exported
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Unicode data is saved in Unicode format.

Export Column

Names

Exports the column names as the first line in the exported

data.

Export Column

Summaries

Exports any column summaries you may have defined

(Schedule View only).

Enclose Values in

Quotes

Places quotes around values. This helps when exporting

data that contains tabs, commas, or carriage returns that

might otherwise be interpreted as column and row

separators.

5. Click OK to save your export options and close the Export Data dialog.

Note:

It is sometimes helpful to view the exported information in a word processing application or spreadsheet

before using it in a database. This allows you to see the exact order of the columns and how they are

separated.

See also:

Exporting data as HTML 

Exporting data as a Microsoft Project XML file

Exporting data as a picture 
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Exporting data as an MPX file 

Importing data 

20.4 Exporting data as HTML

Exporting data as HTML
The Exporting as HTML option exports data to a file on disk or the Clipboard where it can then be

interpreted by Internet or web browsers. This allows you to view activity data as a table on the Internet or

an intranet.

To export data from the Schedule or Resource Views:

1. Decide what types information you want to export and then position your layout accordingly.

2. Decide what activities or resources you want to export and then hide, show, collapse, expand, and

position rows accordingly.

3. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, select Export, and choose HTML from the submenu.

    The Export Data dialog opens.

4. Select from the choices in the Options tab.

5. Click the HTML tab.

6. Select from the options described below.

This Option: Does This:

Title Defines the text that appears as the page title, usually in the

window frame and in a History menu.
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Header Defines the text that appears at the top of the page, defined to

appear in the style of a level two header.

Footer Defines the text that appears at the bottom of the page,

defined to appear in the style of a level two header.

Created By Defines the text that appears at the very bottom of the page.

You can enter your name here.

Date Adds the date the HTML code was generated to the bottom of

the page.

E-mail

Address

Defines the text that appears at the very bottom of the page

and is usually clickable to launch your email application.

Options

Cell Alignment Aligns the text in the cells of the table to the left, center, or

right of the cell. It is flagged "<td align = "center">".

Border Width Defines the size (in number of pixels) of the border drawn

around the outside of the table. It is generated to the standard

line in the HTML table definition as "table border = ".
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Cell Spacing Defines the number of pixels separating the cells. It is

generated to the standard line in the HTML table definition as

"cellspacing = ".

Cell Padding Defines the size (in number of pixels) of the border drawn

around the each cell. It is generated to the standard line in the

HTML table definition as "cellpadding = ".

First Line is

Header

Applies the header font style to the first line of export data,

usually used if you have included column names in the export.

It is flagged "<th>" (table header). When not selected the first

line of export data is flagged "<td>" (first row).

Divider Line

Before Table

Draws a line between the text in the Page Header area and the

beginning of the table. It is flagged "<hr>" (horizontal rule).

Divider Line

After Table

Draws a line between the end of the table and the text in the

Page Footer area. It is flagged "<hr>" (horizontal rule).

7. Click OK to apply your changes and close the Export Data dialog.

Note:

This creates a text file that is interpretable as HTML code. It produces a textured table from the export
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data that can be made accessible to Internet browsers.

See also:

Exporting data 

Importing data 

20.5 Exporting data as a Microsoft Project XML file

Exporting data as a Microsoft Project XML file
You can export your FastTrack file data into Microsoft Project 2003 or later in the XML format.

To export a FastTrack Schedule file as a Microsoft Project XML file:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, select Export, and choose Microsoft Project XML from the

submenu.

    The Save As dialog opens.

2. Navigate to the location to which you want the XML file saved, enter or edit the file name, and click

Save.

3. Open the newly created XML file in Microsoft Project.

Note:

You can also import Microsoft Project .XML and .MPX files and open Microsoft Project .MPP files.

See also:

Exporting data 
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Importing data 

20.6 Exporting a picture

Exporting data as a picture
You can export a picture of the Schedule, Resource, and Calendar Views and/or their items to the

Clipboard or a file on disk. From the Print Preview window, define what is exported: the portion of the

View on the page, the View plus graphic items, or the View, its items, and an image of the piece of

paper. When performed outside of the Print Preview window, an image of the entire View is exported.

You can export to the following file types:

Windows Bitmap (BMP), Windows Enhanced Metafile (EMF), JPEG/JFIF (JPG), Portable Network

Graphic (PNG), Tagged Image File Format (TIF), Macintosh PICT (PCT)

In Print Preview, to export a page of the file as a picture:

1. In any View, click the Application Button which is the graphic  at the top left of the FastTrack

Schedule window to open the Application menu, select Print and choose Print Preview from the

submenu.

2. Make sure that the page appears as you want and that nothing is selected.

3. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, select Export, and choose Picture from the submenu.

    The Export as Picture dialog opens.

4. Select from the options described below.

This Option: Does This:
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Destination

File Saves the exported picture to a file on disk.

Browse Opens a dialog where you can select a destination and

file name for the export.

Clipboard Saves the exported picture to the Clipboard.

Options

Export Document

Only

Copies the area of the file that appears on the current

page.

Export Document

and Paper

Copies the area of the file which appears on the current

page, all text boxes and stamps in the Print Preview

window on this page, and an image of the paper on

which it is positioned. This also includes headers,

footers, and pictures.

Export Document

and Page Items

Copies the area of the file which appears on the current

page plus all text boxes and stamps in the Print Preview

window on this page. This also includes headers,

footers, and pictures.
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5. Click OK to create the export and close the Export as Picture dialog.

In the Schedule, Resource, or Calendar Views (not in Print Preview), to export the entire View

as a picture:

1. Make sure nothing is selected. 

    Click once in the timeline area or outside of the calendar to assure this.

2. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule

window to open the Application menu, select Export, and choose Picture from the submenu.

Notes:

- The file type is entered after the file name or determined in the Save As dialog when browsing for the
file.
- If you choose to export a JPEG file you will have the option of choosing the quality of the picture. The
quality is ranked from 99-1 with 99 being the highest quality.

See also:

Exporting the page as a picture 

Exporting data 

Importing data 

20.7 Using MPX with FastTrack Schedule

Using MPX with FastTrack Schedule
When managing projects, it may be helpful to open data from other applications or export data from the

application in which you are working. MPX, which stands for Microsoft Project exchange, is an ASCII file

format that automates and simplifies the process of opening data between applications. 

There are many benefits to opening and saving files in the .mpx extension. In addition to the transfer of
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raw data: date and time formats, the work calendar, outline levels, and links are also preserved. MPX

does not capture font attributes (for example: font color, font size, bar styles, etc.). 

Important:

Microsoft Project can only read MPX files. The data will have to be saved as some other file type, XML

for instance.

What would you like to do?

 Open an MPX file in FastTrack Schedule 

 Export FastTrack Schedule as MPX

See also:

Importing data

Exporting data

21 Timescales

21.1 Working with timescale rows

Working with timescale rows
A timescale contains timescale rows that label the dates and times on the timeline graph. The timescale

rows can be formatted to display different divisions of the base timeline units. For instance, a schedule

that is divided into base timeline units of weeks might also have timescale rows that group the timescale

into months and fiscal quarters.

Timeline units are set in the Format Schedule View dialog or Format Resource View dialog. Timescales
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and timelines can differ in the Schedule and Resource Views.

Timescale area – Sections of the screen that display the timescale rows. The Schedule and Resource

Views can each contain two different timescale areas: one above the timeline and one below it. You can

use options in the Define Layout dialog to have the bottom timescale mirror the top timescale.

Base Timescale Row – The timescale row that displays the base timeline units (the smallest units

set). You cannot change the units of the base timescale row; they always reflect the base timeline units.

Width – The width of the divisions in the base timescale row define the width of columns in the timeline.

Therefore, if the Schedule View timeline is in base units of weeks, changing the width of a column in the

row that displays weeks changes the width of the timeline graph.

What would you like to do?

 Formatting timescale rows

 Showing, hiding, and mirroring timescale areas

 Inserting new timescale rows

 Formatting timescale row units

 Formatting timescale row gridlines

 Changing the font attributes of timescale rows

 Moving timescale rows

 Changing the height of timescale rows

 Changing the width of the timescale & timeline-columns
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21.2 Formatting timescale rows

Formatting timescale rows
The Format Timescale Row dialog allows you to choose the units, display, and gridlines for the selected

timescale row.

To open the Format Timescale Row dialog:

1. Double-click the timescale row you want to format.
    -or-

1. Select the timescale row you wish to format.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Timescale Row dialog opens.

Note:

You can format multiple timescale rows at once by selecting them and then opening the Format

Timescale Row dialog. 

See also:

Choosing new units 

Formatting timescale row gridlines 

21.3 Showing, hiding, and mirroring timescale areas

Showing, hiding, and mirroring timescale areas
Showing the top and/or bottom timescale area labels the timeline, dividing it into units of time – from

hours to fiscal years. Mirroring timescale areas produces another version of the top timescale area in the

bottom timescale area.
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To show or hide timescale areas:

1. On the Project tab, in the Layout group, click Layouts, and choose Define from the drop-down list.

    The Layouts dialog opens with the current Layout selected.

2. Click Edit. 

    The Define Layout dialog opens.

3. In the Columns tab, select or clear the following check boxes.

Selecting this: Does this:

Column Headings

and Timescale (Top)

Displays the column headings and top timescale in the

Schedule or Resource Views.

Column Summaries

and Timescale

(Bottom)

Displays column summaries, if any are defined, and a

bottom timescale in the Schedule or Resource Views.

Mirror Timescale from

Top

Causes the bottom timescale to appear as a mirror

reflection of the top timescale. Column Summaries &

Timescale (Top) must be selected if you want to mirror

the top timescale.

4. Click OK to save your layout changes and close the Define Layout dialog.

5. Click OK to apply the selected layout and close the Layouts dialog.

See also:
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Inserting timescale rows into timescale areas 

Moving timescale rows in timescale areas 

Using Layouts 

21.4 Inserting new timescale rows

Inserting new timescale rows
Inserting new timescale rows into a top or bottom timescale area adds another row that you can use to

label the timeline.

To insert a new timescale row:

1. To select it, click the timescale row below which you want the new row to appear.

2. Right-click and choose Insert Timescale Row from the shortcut menu.

    -or-

1. Select the timescale row below which you want the new row to appear.

2. On the Insert tab, in the Timeline Elements group, click Timescale.

Notes:

- These steps add a row to a timescale area. To show or hide the top or bottom timescale area, use the
Define Layout dialog.
- The new timescale row automatically generates in the base timeline units. To format the timescale row
to show different units, open the Format Timescale Row dialog.

See also:

Showing & hiding timescale areas 

Formatting timescale rows 
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21.5 Formatting timescale row units

Formatting timescale row units
Formatting a timescale row’s units allows you to select the units (e.g., Days) in which the timescale row

displays. It also allows you to determine how the units will look when displayed in the Schedule or

Resource Views.

To change the units of the timescale row:

1. Double-click the timescale row.

    -or-

1. Select the timescale row you wish to format.

2. On the Format menu, in the Timeline Elements group, click Timescale.

    The Format Timescale Row dialog opens.

3. In the Display tab, from the Units drop-down list, select a new unit to display in the timescale.

4. Use the options to determine how the selected unit will display.

5. Click OK to apply your changes and close the Format Timescale Row dialog.

Notes:

- Units that are smaller than the base timeline units are not available in the Units drop-down list.
- You cannot change the units of the base timescale row; they always reflect the base timeline units.
- Depending on which unit is selected, different display options are available for Regular, Generic, and
Fiscal labels.

See also:

Formatting timescale row gridlines 

21.6 Formatting timescale row gridlines

Formatting timescale row gridlines
Formatting the gridlines for timescale rows allows you to define their thickness, pattern, color, and
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display in the timescale area and timeline graph.

To define the gridlines for a timescale row:

1. Double-click the timescale row.

    -or-

1. Select the timescale row you wish to format.

2. On the Format menu, in the Timeline Elements group, click Timescale.

    The Format Timescale Row dialog opens.

3. Click the Gridlines tab.

4. Select or clear the "Show in current Timescale Rows" or "Show in other Timescale Rows and Timeline

Graph" check boxes to define where gridlines are drawn.

5. If you wish to design your own gridlines, select the Use Custom Gridlines check box and select the

custom gridline color, pattern, and size.

6. Click OK to apply your changes and close the Format Timescale Row dialog.

Note:

When Use Custom Gridlines is not selected, gridlines are drawn according to the options defined in the

Gridlines tab of the Format Schedule View or Format Resource View dialogs.

See also:

Formatting timescale row units 

21.7 Changing the font attributes of timescale rows

Changing the font attributes of timescale rows
Changing the font, size, style, and color of timescale rows allows you to customize their appearance.
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To change the font attributes of timescale rows:

1. Click the desired timescale row or rows to select them.

2. On the Home tab, in the Font group, use the available controls to format the font attributes.

    -or-

    Right-click and choose Font from the shortcut menu.

Note:

If you make a change that increases the size of the text in the timescale row, the labels may be partially

hidden because they no longer fit in the space available. Select a smaller font or resize the timescale

and timescale-columns.

See also:

Changing the font attributes of column headings 

Changing the font attributes of cells 

21.8 Moving timescale rows

Moving timescale rows
Moving timescale rows within a timescale area allows you to arrange the top-to-bottom order within a

timescale area.

To move a timescale row:

1. Click the desired timescale row to select it.

    Once you have selected a timescale row, the cursor changes to the Move cursor.

2. Click and drag the timescale row up or down.
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Note: 

You cannot move timescale rows from the top timescale area to the bottom timescale area or vice versa.

See also:

Inserting new timescale rows 

21.9 Changing the height of timescale rows

Changing the height of timescale rows
Resizing timescale rows vertically changes the height of the timescale row.

To change the height of a timescale row:

1. Position the cursor over the bottom gridline (or top gridline if in the bottom timescale area) of the

timescale row you are resizing.

2. Click and drag up or down to change the height of the row.

See also:

Changing the width of timescale & timeline columns 

21.10 Changing the width of timescale & timeline-columns

Changing the width of timescale & timeline-columns
Resizing a timescale column horizontally changes the width of all timescale columns and therefore the

timeline-columns. When you resize one column, they will all change.
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To change the width of the timescale & timeline-columns:

1. Position the cursor over a vertical gridline in the base timescale row.

2. Click and drag to the left to make the timescale and timeline narrower, or to the right to make them

wider.

Notes:

- The base timescale row, which displays the base timeline units, is the one that defines column width in
the timeline. For instance, if the timeline is in the base units of weeks, the timescale row that displays
weeks is the one to be resized.
- If the width of a timescale row is not wide enough to display the entire label, the label is partially
hidden.
- You will not be able to resize the base timescale row if Fit to Pages (Width) is selected in the Page
Options dialog.

See also:

Changing the height of timescale rows 

Changing the width of columns 

22 Alignment Grids

22.1 Showing and hiding the alignment grid

Showing and hiding the alignment grid
Showing the grid displays the vertical alignment grid as red dotted lines. The vertical alignment grid is

only displayed in the Schedule View.

To view the alignment grid:

1. In the Schedule View, on the View tab, in the Show/Hide group, click Alignment Grid.

    This toggles between hiding and showing the grid.
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Notes:

The alignment grid does not print.

There is a horizontal alignment grid, but it does not display.

See also:

Using alignment grids 

22.2 Using alignment grids

Using alignment grids
Alignment grids make moving activity bars, text boxes, pictures in the Schedule View, and assigned

bars in the Resource View more precise by forcing them to snap to a position relative to the grids you

define. The alignment grid only affects items in the timeline.

What do you want to do?

 Define alignment grids

 Define activity bar alignment

 Define text box alignment

 Define picture alignment

 Align items to grids

 Snap items to grids

22.3 Defining alignment grids

Defining alignment grids
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You can define the grids to which activity bars, text boxes, pictures in the Schedule View, and assigned

bars in the Resource View can be aligned. Because it only supports bars, the Resource View only uses

a horizontal alignment grid.

To define alignment grids:

1. On the Tools tab, in the Arrange group, click Arrange, and choose Alignment Grid Options from the

drop-down list.

    The Alignment Grid Options dialog opens.

2. Select from the options described below.

Select this: To do this:

Horizontal

None Tell the schedule to use no horizontal

alignment grid.

Number "X" of Time Unit "X" Select a unit of time from the drop-down list

and then enter the number of those units to

space items on the horizontal alignment grid.

The smaller the unit between horizontal grid

lines, the more you can fine tune a bar or

item’s horizontal placement within the timeline.

Vertical

None Tell the schedule to use no vertical alignment
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grid.

Center of Row Set the vertical alignment grid to the middle of

each row.

Number "X" of Points Set the spacing of the vertical alignment grid to

a number of pixels. The smaller the number of

points between vertical grid lines, the more you

can fine tune a bar or item’s vertical placement

within the timeline.

Align with Text Set the vertical alignment grid to align with the

text you specify.

Text drop-down list Determine the text with which the grid will align

vertically.

3. Click OK to apply your change and close the Alignment Grid Options dialog.

Notes:

- To show the vertical alignment grid in the Schedule View, on the View tab, in the Show/Hide group,
click Alignment Grid.
- The alignment grid does not print.
- Horizontal grids are defined in units of time instead of pixels to help you position activity bars in the
Schedule View timeline and assigned bars in the Resource View timeline.
- The exact position of the aligned item is determined in Alignment tab of the Format Bar Style dialog
and the Display tab of the Format Item dialog.
- There are different alignment grid options available depending upon your base Timeline unit. For
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example, you can set the alignment grid to minute increments if your base Timeline unit is Days or, you
can set the alignment grid to daily increments if your base Timeline unit is Weeks.

See also:

Defining activity bar alignment 

Defining text box alignment 

Defining picture alignment 

Aligning items to grids

Snapping items to grids

Using alignment grids 

22.4 Defining activity bar alignment

Defining activity bar alignment
Defining the alignment of a bar style allows you to fine-tune the position of an activity bar relative to the

alignment grids. You can define the alignment of a bar style from the Schedule, Resource, and Calendar

Views.

To define the alignment of a bar style:

1. In the Bar Styles Toolbar, select the bar style for which you want to define the aligned position.

2. On the Format tab, in the Display group, click Bar Style.

    The Format Bar Style dialog opens.

3. Click the Alignment tab.

4. Using the check boxes, select which elements of the bar will snap to the alignment grids.

5. If you want to change the position of the bar relative to the alignment grid, enter horizontal and vertical

offset values.

6. Click OK to apply your changes and close the Format Bar Style dialog.
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Notes:

- As you make your changes, notice how it affects the bar in the Example window relative to the
alignment grids.
- Existing bars will not automatically snap to the revised alignment settings. You must select the
existing bars, from the Tools menu select Arrange, and choose Align from the submenu.
- Choosing both Start Point and End Point can change the duration of the activity fit between alignment
grids.

See also:

Defining alignment grids

Aligning items to grids

Snapping items to grids

22.5 Defining text box alignment

Defining text box alignment
Defining the alignment of text boxes allows you to fine-tune their position relative to the alignment grids.

You can define the alignment of text boxes only from the Schedule View.

To define the alignment of a text box:

1. Select a text box.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Item dialog opens.

3. Click the Display tab.

4. Select from the options described below.

This

Option:

Does This:



FastTrack Schedule 10 User Manual300

Copyright © 2010, AEC Software, Inc. All rights reserved.

Left Aligns the left edge of the text box to the grid. 

Right Aligns the right edge of the text box to the grid. 

None Does not align the text box to the grid.

Top Aligns the top edge of the text box to the grid. 

Center Aligns the center edge of the text box to the grid. 

Top Line Aligns the center of the first line of text (based on total text

height) in the text box to the grid.

Top Line

Ascent

Aligns the center of the first line of text (based on the text height

without descending letters) in the text box to the grid.

Clipping

None Allows the text box to sit atop the row gridlines so that the entire

text box displays in the schedule.

Containing

Row

Places the text box in a row so that the size of the row

determines how much of the text box displays in the schedule.
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Determines the number of pixels that surround the text box.

Offset

Horizontal Positions the text box to the left or right of the alignment grid.

Enter a positive number to move the text box to the right or a

negative number to move the text box to the left.

Vertical Positions the text box above or below the alignment grid. Enter a

positive number to move the text box up or a negative number to

move the text box down.

5. If you want to apply this alignment to all new text boxes, click the Set as Default button.

6. Click OK to apply your changes and close the Format Item dialog.

See also:

Defining alignment grids

Aligning items to grids

Snapping items to grids

22.6 Defining picture alignment

Defining picture alignment
Defining the alignment of pictures allows you to fine-tune their position relative to the alignment grids.

You can define the alignment of pictures only from the Schedule View.
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To define the alignment of a picture:

1. Select the picture for which you would like to define the alignment.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Item dialog opens.

3. Click the Display tab.

4. Select from the options described below.

This

Option:

Does This:

Alignment

Left Aligns the left edge of the item to the grid.

Right Aligns the right edge of the item to the grid.

Top Aligns the top edge of the item to the grid.

Bottom Aligns the bottom edge of the item to the grid.

Clipping

None Allows the picture to sit atop the row gridlines so that the entire

picture displays in the schedule.
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Containing

Row

Places the picture in a row so that the size of the row determines

how much of the picture displays in the schedule. Determines

the number of pixels that surround the picture.

Offset

Horizontal Positions the picture to the left or right of the alignment grid.

Enter a positive number to move the picture to the right or a

negative number to move the picture to the left. Is available only

when the Top or Bottom Alignment option is selected.

Vertical Positions the picture above or below the alignment grid. Enter a

positive number to move the picture up or a negative number to

move the picture down. Is available only when the Top or Bottom

Alignment option is selected.

5. If you want to apply this alignment to all new pictures, click the Set as Default button.

6. Click OK to apply your changes and close the Format Item dialog.

See also:

Defining alignment grids

Aligning items to grids

Snapping items to grids
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22.7 Aligning items to grids

Aligning items to grids
Aligning items to grids helps you position them precisely by moving the item to the closest alignment

grid, according to the alignment options defined for the selected item.

To align items to grids:

1. Select the item or bar.

2. On the Tools tab, in the Arrange group, click Arrange, and choose Alignment Grid from the drop-down

list.

Note:

To align to grids as you draw or drag items, from the Tools menu, select Arrange, and choose Snap To

Grid from the submenu.

See also:

Snapping items to grids

Defining alignment grids

Defining activity bar alignment 

Defining text box alignment 

Defining picture alignment 

22.8 Snapping items to grids

Snapping items to grids
Snapping items to alignment grids as you drag them automatically positions them to the closest

alignment grid, according to the alignment options defined for the item.
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To snap items to grids as you drag:

1. On the Tools tab, in the Arrange group, click Arrange, and choose Snap To Grid from the drop-down

list.

    As you move items, they will jump to their defined alignment grid.

See also:

Aligning items to grids

Defining alignment grids

Defining activity bar alignment 

Defining text box alignment 

Defining picture alignment 

23 Summary Graphs

23.1 Showing and hiding summary graph rows

Showing and hiding summary graph rows
Showing summary graphs adds an area below the timeline graph that displays the total, average,

standard deviation, minimum, maximum, and/or count of the values currently displayed in columns for a

particular period of time. For instance, you could show a summary graph row that displays the total cost

of all activities per week.

To show and hide summary graphs:

1. In the Schedule view, on the Project tab, in the Layout group, click Layouts, and choose Define from

the choice list.

    The Layouts dialog opens with the current layout selected.

2. Select the name of the layout you wish to change.

3. Click the Edit button.
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4. In the Define Layout dialog, click the Summary Graphs tab.

    Any summary graphs you have created appear in the Available Rows table.

5. From the Available Rows or Shown Rows table, select the summary graph you wish to hide or show.

6. Click the Hide or Show button to select if the summary graph should be displayed.

7. Click OK to save the layout and close the Define Layout dialog.

8. Click OK to apply your changes and close the Layouts dialog.

Note:

When you show a summary graph row, it defaults to displaying the total Scheduled Duration per week.

You can change the information in summary graph rows by formatting them. The Format Summary

Graphs dialog opens when you double-click inside of a summary graph row.

See also:

Inserting new summary graph rows 

Formatting summary graph rows 

23.2 Inserting new summary graph rows

Inserting new summary graph rows
Inserting a new summary graph row adds another row to the summary graph below the timeline graph.

You can define multiple rows, each displaying a different summary or unit of time.

To insert a new summary graph row:

1. If your schedule does not already contain summary graphs, on the Insert tab, in the Timeline

Elements tab, select Summary Graph.
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    A summary graph is created and the Format Summary Graphs dialog opens.

    -or-

1. Select an existing summary graph row.

2. Right-click and select Insert.

    The new summary graph will appear below the existing graph you selected. You may then move it if

you wish.

To duplicate a summary graph row:

1. Select the summary graph row you wish to duplicate.

2. Right-click and select Duplicate.

Notes:

-Holding the Alt key and positioning the cursor in the summary graphs area gives you the Insert cursor.
When you see the Insert cursor, click. A new summary graph will appear and the Format Summary
Graphs dialog will open. The inserted summary graph row will default to displaying a total of the
Scheduled Duration per week. You can change the information in summary graph rows by formatting
them. 
- You can also create a new summary graph row by clicking the Create New Summary Graph Row
button in the Summary Graph tab of the Define Layout dialog.

See also:

Formatting summary graph rows 

Showing & hiding summary graph rows 

Moving summary graph rows 

23.3 Deleting summary graph rows

Deleting summary graph rows
Summary graphs are deleted by choosing Delete from their context menus.
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To delete a summary graph row:

1. Select the summary graph row you wish to delete.

2. Right-click and select Delete.

See also:

Showing & hiding summary graph rows 

Inserting new summary graph rows

23.4 Formatting summary graph rows

Formatting summary graph rows
Opening the Format Summary Graphs dialog allows you to select the units, the data summarized, the

type of summary operation, and the display of information for the selected summary graph row.

To open the Format Summary Graphs dialog:

1. Click the summary graph row you want to format to select it.

2. On the Format tab, in the Display group , click Format Selected.

    -or-

    Double-click the summary graph row within the timeline graph .

See also:

Inserting new summary graph rows 

Choosing units for summary graph rows 

Choosing data to summarize 
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Choosing a summary operation 

Formatting the display of summary graph rows

23.5 Choosing units for summary graph rows

Choosing units for summary graph rows
Choosing units for a summary graph row allows you to determine the unit of time (days, weeks, months,

etc.) upon which the summary graph row bases its summaries.

To change the units of the summary graph row:

1. Double-click within the timeline graph of the summary graph row you want to format.

    The Format Summary Graphs dialog opens.

2. Use the Summary Units drop-down list to select a unit of time.

3. Click OK to apply your changes and close the Format Summary Graphs dialog.

Note:

If you choose a fiscal option as a unit, you will need to select when that fiscal period begins from the

Starts On drop-down list.

See also:

Formatting summary graph rows 

Choosing data to summarize 

Choosing a summary operation 

Formatting the display of summary graph rows 
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23.6 Choosing data to summarize in summary graphs

Choosing data to summarize in summary graph rows
Choosing the data to summarize in a summary graph defines what information is summarized per unit of

time. For example, you could choose to summarize the Duration column, the Start Date column, or both

columns. 

To select data to summarize in the summary graph row:

1. Double-click within the timeline graph of the summary graph row you want to format.

    The Format Summary Graphs dialog opens.

2. From the Data to Summarize column in the table, select the column to summarize.

3. Select whether or not to summarize All Bar Styles.

4. If you choose not to summarize all bar styles, from the Bar Style to Summarize drop-down list, select

one particular bar style in which to summarize data.

5. Choose whether you wish to distribute the custom column data by Schedule, Revised, or Actual

Duration.

6. Click OK to close the Format Summary Graphs dialog.

Notes:

- Remember that, as you add data, too many summaries in one row can lead to confusion.
- In the Format Summary Graphs dialog, the Data to Summarize column drop-down list contains two
parts. The first 12 selections represent the Scheduled, Revised, and Actual information for a bar. Options
below those 12 are columns which you have created that store their information per bar.
- Only columns which store values per bar can be summarized in a summary graph row.

See also:

Formatting summary graph rows 

Choosing units for summary graph rows 
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Choosing a summary operation 

Formatting the display of summary graph rows 

23.7 Choosing summary operations for summary graphs

Choosing summary operations for summary graph rows
Choosing a summary operation for a summary graph row defines which of the following operations the

row displays: the total, average, standard deviation, minimum, maximum, or count of activity bar values. 

A cumulative summary is calculated in the same manner as a non-cumulative summary, however, the

result of each column is added to previous columns; thus, the values accumulate from time period to

time period.

To select a summary operation for a summary graph row:

1. Double-click within the timeline graph of the summary graph row you want to format.

    The Format Summary Graphs dialog opens. 

2. From the Summary Operation drop-down list, select an operation.

3. If the operation will or can be tallied cumulatively, use the Cumulative checkbox to establish whether

values before the start of the timeline will be included in the calculation of cumulative summaries.

4. If the operation will or can be tallied cumulatively, select to include or to ignore values for activities that

occur before the schedule start in your summary.

5. Click OK to close the Format Summary Graphs dialog.

Note:

Some options in the Format Summary Graphs dialog are only available for certain column types.
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See also:

Formatting summary graph rows 

Choosing units for summary graph rows 

Choosing data to summarize 

Formatting the display of summary graph rows 

23.8 Formatting the display of summary graph rows

Formatting the display of summary graph rows
Formatting the display of data in a summary graph row defines how the information is displayed. You

can show data as numeric text, a histogram, or a line graph.

You can choose to have one set of summarized data display in more than one way within a single

summary graph row. You can also choose to have more than one set of summarized data display in the

same way or in different ways, within a single summary graph row. 

To format the display of data in a summary graph row:

1. Double-click within the timeline graph of the summary graph row you want to format.

    The Format Summary Graphs dialog opens. 

2. In the Display As column drop-down list, select how you want the summary graph to display.

    You can display information as numeric text, a line graph, or a histogram.

3. Use the display attribute options that appear below to determine the appearance of the summary

graph.

4. Click OK to apply your changes and close the Format Summary Graphs dialog.

Notes:

- Each Display As type has a different set of display attribute controls which appear when they are
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selected.
- Though you can summarize more than one set of data in a given summary graph row, summarizing too
much data in one row can be visually confusing when displayed in the schedule, so consider simply
inserting additional summary graphs.

See also:

Formatting summary graph rows 

Choosing units for summary graph rows 

Choosing data to summarize 

Choosing a summary operation 

23.9 Labeling summary graph rows

Labeling summary graph rows
Providing a label for a summary graph row allows you to describe the contents of the row.

To label a summary graph row:

1. Double-click within the timeline graph of the summary graph row you want to format.

    The Format Summary Graphs dialog opens. 

2. In the Left Label box, enter the text you would like to appear, as a label, to the left of the timeline

graph.

3. In the Right Label box, enter the text you would like to appear, as a label, to the right of the timeline

graph.

4. If you wish to display the contents of the left label in the right label, select the Mirror Labels

checkbox.

5. Select the Show Labels checkbox in the table to display the labels in the summary graph row.

6. Choose from the Label Options area that appears below.

7. Click OK to save your changes and close the Format Summary Graphs dialog.
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Note:

The label area of summary graphs is determined by the left and right locked columns, as set in the

Define Layout dialog. You must have a column locked on either side of the timeline to display the labels.

See also:

Using Layouts 

23.10 Changing the font attributes of summary graph rows

Changing the font attributes of summary graph rows
Changing the font, size, style, and color of summary graph rows allows you to customize their

appearance.

To change the font attributes of a summary graph row:

1. Click the action column area next to the desired summary graph row or rows to select them.

2. On the Home tab, in the Font group use the options to format the font attributes.

    -or-

    Right-click and choose Font from the shortcut menu.

Note:

If you make a change that increases the size of the text in the summary graph row, the information may

be partially hidden because it no longer fits in the space available. Select a smaller font or resize the

timescale columns.

See also:



Summary Graphs 315

Copyright © 2010, AEC Software, Inc. All rights reserved.

Moving summary graph rows 

Changing the height of summary graph rows 

23.11 Moving summary graph rows

Moving summary graph rows
Moving summary graph rows within the summary graph area allows you to determine the order of rows.

To move a summary graph row:

1. Click to the left of a summary graph’s label cell to select that summary graph row.

    Once you have selected a summary graph row, the cursor changes to the Move cursor.

2. Click and drag the selected summary graph up or down.

    -or-

1. In the Schedule view, on the Project tab, in the Layout group, click Layouts, and choose Define from

the choice list.

    The Layouts dialog opens.

2. Click the Edit button.

    The Define Layout dialog opens.

3. In the Summary Graphs tab, click and drag on the name of summary graphs in the Shown Rows table

to arrange the summary graphs.

4. Click OK to apply your changes and close the Define Layout dialog.

5. Click OK to apply the selected layout and close the Layouts dialog.

See also:

Showing & hiding summary graph rows 

Inserting new summary graph rows 
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23.12 Changing the height of summary graph rows

Changing the height of summary graph rows
Resizing summary graph rows vertically changes the height of rows.

To change the height of a summary graph row:

1. Click to the left of a summary graph’s label cell to select that summary graph row.

2. Position the cursor over the top gridline of the selected summary graph row. 

    The Resize Cursor will appear.

3. Click and drag up or down to change the height of the row.

See also:

Changing the width of timescale & timeline-columns 

24 Calculations

24.1 Overview of using calculations

Overview of using calculations
A calculation column is one whose values are based on a calculation. Its value cannot be entered

directly into a column – unlike text and number columns. 

For example, if you wanted a column whose value was your profit – assuming a margin 4 cents on the

dollar, you could define a calculation column called "Profit" which consisted of a Cost column multiplied

by .04. If no Cost data entered for an activity, there would be no value in that activity’s "Profit" cell.
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The following calculation could be used to return the value described above:

Cost 1 * .04 = "Profit"

See also:

What is a calculation? 

What are the elements of a calculation? 

Defining a calculation column 

Entering a calculation 

24.2 What is a calculation?

What is a calculation?
A calculation is an expression that FastTrack Schedule evaluates to determine values for the calculation

column. A calculation can consist of any legal combination of column references, text strings, numbers,

functions, and operators. For example, the following calculation could be used to return a value for a

calculation column you name "Profit," if you assume a profit margin of 4 cents on the dollar.

Cost 1 * .04 = "Profit"

In this example, the Cost 1 column is a numeric column. Each time values are assigned to the Cost 1

column, FastTrack Schedule multiplies that value by .04 and displays the result in a calculation column

you have named "Profit."

The result of a calculation is referred to as the return value. All of the values required as input to the

calculation must be present for FastTrack Schedule to evaluate the calculation. If one of the values

required for the calculation does not exist when the calculation is evaluated, FastTrack Schedule does
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not assign a value to the calculation. The value of the calculation column is empty (null) until the missing

value is supplied.

See also: 

What are the elements of a calculation? 

Defining a calculation column 

24.3 What are the elements of a calculation?

What are the elements of a calculation?
A calculation can contain the following elements:

Type of element: Example:

Column reference [Finish Date]

Text String "The final date is"

Number 5.75

Functions DateToText(Date)

Combination of

elements

"The final date is" + DateToText([Finish Date])
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These elements can be combined using Operators to produce an expression. FastTrack Schedule

includes over 60 functions capable of complex calculations. For example, nested If Statements have

been tested to over 100 nests. FastTrack Schedule’s functions operate just like those of other popular

spreadsheet applications. 

See also: 

Defining a calculation column 

Entering a calculation

24.4 Defining a calculation column

Defining a calculation column
Defining a calculation column allows you to create a column that uses column references, text strings,

numbers, functions, and operators to determine its value. For instance, you could create a column

named "Profit" that would have a calculation of: "[Cost 1] * .04 =Profit ", where [Cost 1] is another

column that stores values per bar.

To define a calculation column:

1. In the Schedule View or Resource View, on the Insert tab, in the Rows and Columns group, click

Column.

    The Insert Column dialog opens.

2. From the Show pull down list, select Calculation to show every available column of the type

"Calculation".

3. In the Column Display Name table, click to select the name of the next available calculation column.

4. Click OK to insert the new column.

    The Format Calculation dialog opens.
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5. In the Format Calculation dialog, enter a calculation.

6. Click OK to apply your changes and close the Format Calculation dialog and close the Insert Column

dialog.

    The calculation column now appears in the schedule.

Notes:

- Because their values are generated from other information, you cannot edit calculated values directly in

the calculated column.

- To change the name and/or appearance of the column, select it and, on the Format tab, in the Display
group, click Format Selected. The Format Column dialog will open.

See also:

Overview of using calculations 

Entering a calculation 

24.5 Entering a calculation

Entering a calculation
Entering a calculation defines the expression that is being evaluated to return a value for the calculation

column.

To enter a calculation in the Format Calculation dialog:

1. Insert a calculation column.

2. In the Format Calculation dialog, enter the calculation as described below.

To do this: Do this:
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Enter a column

reference

In the field at the top of the dialog, click where you want

to insert the column reference and then double-click the

desired column name in the Columns table.

Enter an operator In the field at the top of the dialog, click where you want

to insert the operator and then double-click the desired

symbol in the Operators table.

Enter a function In the field at the top of the dialog, click where you want

to insert the function and then double-click the desired

function in the Functions table.

View specific

functions

Click the drop-down list above the Functions table and

select to sort the functions by name or category, or

select to search the table for functions of a specific

category.

Enter a literal text

string

In the field at the top of the dialog, click where you want

to insert the text string, enter quotes, and enter the text

between the quotes. Values in quotations are interpreted

literally by FastTrack Schedule. The characters enclosed

in quotation marks appear in the return value exactly as

they appear in the calculation.
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Enter a number In the field at the top of the dialog, click where you want

to insert the number and then enter the number.

See a description

of an element

Single-click an element from the Columns, Operators, or

Functions table and read the description below the

Functions table. Click the Function Reference button to

open the help system to a detailed description of every

function.

3. Click the Check Calculation button to evaluate the calculation and verify it is correct.

4. Click OK to apply your changes and close the Format Calculation dialog.

Notes:

- Column names must be contained in square brackets [ ] and must be spelled exactly as they appear
in the Columns table.
- Only columns that store values per bar or resource can be used in a calculation (this is displayed or
determined in the Options tab of the Format Column dialog). 
- Functions cannot have a space between the function name and the opening parenthesis and must be
spelled exactly as they appear in the Functions table.
- You may enter carriage returns in your calculation between elements.
- A calculation can provide a value only for the column for which it is defined.

See also:

Overview of using calculations 

25 Text Boxes, Pictures, & Legends

25.1 Working with text boxes, pictures, and legends

Working with text boxes, pictures, and legends

What is a text box?
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A text box is like a post-it note you can attach to your schedule. You can enter text in the box and then

reposition it in the timeline. Text boxes can be of any font or style and you can define their backgrounds,

outline, and shadow. Text boxes are graphic items, like activity bars and pictures, which can be aligned

to the alignment grid and positioned in relation to other items.

Adding text boxes to the Schedule View timeline helps to describe and label items in the schedule. You

can also add them to the Print Preview window of the Schedule and Resource Views as titles and other

descriptions that you want to see only on the printed page. The Print Preview window is separate from

the View it previews and items in this window do not appear in the Schedule View or Resource View

unless printed.

Since working with text boxes in the Schedule View timeline and Print Preview window are the same in

many respects, we will address them together, but will point out differences as they occur.

What is a picture?

A picture is a graphic item that you can add to the Schedule View. You can select and position pictures

in the timeline just as you can activity bars and text boxes. Using features such as the definable

alignment grid and back-to-front ordering, you can place them precisely where you want them to appear.

A picture can be any graphic. For instance, a company logo created in a drawing application is a

picture. You can add a picture either to the Schedule View timeline or the Print Preview window of the

Schedule and Resource Views. The Print Preview window is separate from the View it previews and

items in this window do not appear in the Schedule or Resource Views unless printed. 

What is a legend?
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A legend is an item that explains, graphically, what the bar styles in a schedule represent. If each bar

style in your schedule has a different meaning, a legend allows you to display this in your schedule.

Legends can only be added to the Schedule View and the Print Preview window of the Schedule and

Resource Views.

Bar styles are often used as a way of adding information to bars that cannot be expressed by dates.

Typically, bar styles are used to differentiate one group of activity bars from another. For example, all the

activities assigned to the sales department may have blue activities bars while another department’s

activity bars are red. Color-coding is one of the most common uses of bar styles; however, other

elements of a bar style that you can customize include endpoints, fill patterns, and outline patterns. 

The elements of a legend are the:

- title
- bar styles
- labels for bar styles
- border lines, shadowing, and attributes

A bar style can be applied to one or several activities. You can apply a different bar style to each task if

it suits your purposes. Legends can show all of the bars styles used in a schedule or just the ones you

want to include. For example, you may want to include only the bar styles for key activities. You can

also define multiple legends.

Each line in a legend represents a single component of a Scheduled, Revised, or Actual bar style. Thus,

to show all three components of the bar style would require three lines in the legend.

You can show all three components of a bar style or just the components you want to include. For

example, if your schedule does not use Revised or Actual components, there is no need to display the

bar style for those components in the legend.
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If you redefine a bar style that is displayed in the legend, the legend is automatically updated to reflect

the changes. If you delete a bar style from the Bars Styles Toolbar, any bars in the schedule using that

bar style change to use the default bar style. If the deleted bar style is displayed in the legend, it is

automatically changed to the default bar style.

In FastTrack Schedule, legends are considered to be graphic items. Other types of graphic items are

activity bars, pictures, text boxes, and stamps. Legends can be added to your schedule – in either the

Schedule View or the Print Preview window – and then moved, resized, formatted to have a border, and

so forth. Using such features as the definable alignment grid and back-to-front ordering, you can position

legends precisely where you want them to appear.

See also: 

Using Print Preview 

Adding text boxes 

Adding pictures 

Inserting a legend

25.2 Bringing items to front

Bringing items to front
Bringing items to the front changes the placement of the item in a row's back-to-front order. 

The items in each row are drawn from back to front. This has two consequences: 

- Bars, text boxes, and pictures may obscure each other, as in a drawing application. 
- Most importantly, the back-to-front order of a row's activity bars determines the order of their dates in
the date, time, and duration columns.
- An item’s back-to-front order is based on the first row containing the item’s top edge.
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The first set of dates in the column corresponds to the bar that is at the back of the back-to-front order.

Therefore, selecting a bar and bringing it to the front makes its dates appear last in the column. 

To bring an item to the front of the row's order:

1. Select the item. 

2. On the Tools tab, in the Arrange group, click the Bring to Front button. 

See also:

Sending items to back 

25.3 Sending items to back

Sending items to back
Sending an item to the back changes the placement of the item in a row's back-to-front order. 

The items in each row are drawn from back to front. This has two consequences:

- Bars, text boxes, and pictures may obscure each other, as in a drawing application. 
- Most importantly, the back-to-front order of a row's activity bars determines the order of their dates in
date, time, and duration columns. 
- An item’s back-to-front order is based on the first row containing the item’s top edge.

The first set of dates in the column corresponds to the bar that is at the back of the back-to-front order.

Therefore, selecting a bar and choosing Send to Back makes that bar’s dates appear first in the column.

To send an item to the back of the row's order:

1. Select the item. 

2. On the Tools tab, in the Arrange group, click the Send to Back button. 
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See also:

Bringing items to front 

25.4 Formatting items

Formatting items
Formatting text boxes, pictures, legends, and OLE objects allows you to add borders, backgrounds, and

shadows.

To format an item:

1. Click the item or items to select them.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Item dialog opens.

3. Select from the options described below.

This option: Does this:

Display tab

Alignment Sets the item’s alignment.

Clipping: None Allows the item to sit atop the row gridlines so that the entire

item displays in the schedule.

Clipping:

Containing Row

Places the item in a row so that the size of the row

determines how much of the item displays in the schedule.
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Determines the number of pixels that surround the item.

Offsets Enter the amount of space (in pixels) between the item and

horizontal/vertical alignment grids. Not available when the

Alignment option "None" is selected.

Show On (available in Print Preview window only)

Show On: All

Pages

Places the object on every page of the printed FastTrack

Schedule document.

Show On: This

Page

Places the object only on the page of the printed FastTrack

Schedule document that is currently displayed in the Print

Preview window.

Show On: Page

Range X – X

Places the object only on specified pages of the printed

FastTrack Schedule document. Use the From and To boxes

to enter the page numbers.

Border tab

Background Sets the item’s background color and margin. If you wish to

see beneath the item, select the Transparent checkbox.
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Line Sets the color and size for the item’s border line.

Shadow Sets the color and size for the item’s shadow.

Corner Radius Determine how sharp or rounded the corners of the item’s

border will be.

Set as Default Makes the options you select in the Border tab become the

default for all items created in the future.

Font tab Sets font options for text boxes and legends.

4. Click OK to save your changes and close the Format Item dialog.

See also:

Adding text boxes

Adding pictures

25.5 Text Boxes

25.5.1 Adding text boxes

Adding text boxes 
Adding text boxes to the timeline allows you to enter notes, reminders, and labels that customize the

appearance of your schedule.
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To add a text box:

1. On the Home tab, in the Tools group, click the Text Box tool.

2. Click in the timeline and drag out the width of text box that you want.

3. Enter the content for the text box.

Notes:

- As you enter text, the text box adds more lines in order to fit the contents to the width you have
defined.
- To add labels to individual bar elements, use the Schedule or Resource View Labels tab of the Format
Bar Style dialog.
- You can also add text boxes while in the Schedule or Resource Views’ Print Preview window. Text
boxes created in the Print Preview window appear only in Print Preview and the printed schedule.

See also:

Editing text boxes

Resizing text boxes

Moving text boxes

Formatting text boxes

Changing the font attributes of text boxes 

Using Print  Preview 

25.5.2 Editing text boxes

Editing text boxes
Editing a text box allows you to enter new text that replaces or adds to the old content.

To edit a text box:

1. With the Arrow tool selected, double-click an existing text box.

2. Enter or edit text in the text box.
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See also:

Adding text boxes

25.5.3 Resizing text boxes

Resizing text boxes
Resizing text boxes changes the width of the text box, causing it to add or remove lines in order to fit

content to the new width.

To resize a text box:

1. Click the text box to select it.

2. Click on one of the resize handles and drag the text box’s outline to the desired width.

Note:

The number of lines needed to fit its contents to the current width automatically determines the height of

a text box. You can only resize the height of text boxes by changing the number of lines required to fit

the text or by increasing the size of the background in the Border tab of the Format Item dialog.

See also:

Adding text boxes

25.5.4 Moving text boxes

Moving text boxes
You can change the position of text boxes in the schedule.

To move a text box:
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1. Click the text box and drag it to a new position in the schedule.

Notes:

- Holding down the Shift key constrains the text box to moving vertically or horizontally.
- You can position the text precisely by using alignment grids.
- Moving the text box up or down can change the row to which it belongs, that is, the row that contains
the top edge of the text box. Operations (such as collapsing) that affect its new row also affect the text
box.

See also:

Adding text boxes

25.5.5 Changing the font attributes of text boxes

Changing the font attributes of text boxes
Changing the font, size, style, color, and justification of text allows you to customize the appearance of

the text boxes in your schedule.

To change the font attributes of a text box:

1. select the text box.

2. On the Home tab, in the Font group, use the controls to format the font attributes of the text box.

    -or-

1. select the text box.

2. On the Format tab, in the Display group, click the Format Selected button.

    The Format Item dialog opens.

3. Click the Font tab.

4. Select the font attributes.

5. Click OK to save your changes and close the Format Item dialog.
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Notes:

- The font attributes defined for the text box affect all its contents – you cannot define different font
attributes for separate words.
- You can define default font attributes for future text boxes by selecting a text box with the desired font
attributes, opening the Format Item dialog, and clicking the Set as Default button.

See also:

Changing the font attributes of cells 

25.5.6 Adding pointers to items

Adding pointers to items
Pointers (also known as leaders) are lines that branch out from items, such as text boxes and pictures,
and extend to any point on the timeline graph. Pointers act as a graphic representation of the
relationship of an item to some part of the schedule, such as a bar or a point in time. Pointers are only
available in the Schedule View.

To add pointers to items:

1. Select the item or items to which you want to add a pointer.

2. On the Insert tab, in the Timeline Elements group, click Pointer.

    The Format Pointer dialog opens.

3. Format the pointer.

4. Click OK to save your pointer style and close the Format Pointer dialog.

5.  Select the pointer, and use your mouse to drag the pointer around the item and anchor it to a handle

point.

6. Use your mouse to extend the pointer out to whatever point you want the item to refer to in the

timeline.

Notes:

- Each item can have an unlimited number of pointers added to it.
- When you move the item, the pointer will change size as necessary to stay fixed to the schedule
element to which it is pointing.
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See also:

Formatting pointers 

Adding text boxes 

Adding pictures 

Formatting items 

25.5.7 Formatting pointers

Formatting pointers
Formatting pointers allows you to select the path of the pointer, the pointer line’s size, color, and

pattern; and the arrowhead’s shape, size, color, and pattern.

To format pointers:

1. Double-click the pointer you want to format.

    The Format Pointer dialog opens.

2. Select from the options described below.

    -or-

1. select the pointer you want to format.

2. On the Format tab, in the Display group, click the Format Selected button.

    The Format Pointer dialog opens.

3. Select from the options described below.

This option: Does this:

Location

Location When you set a pointer to go from an item to an activity

bar, this option allows you to determine to which part of a
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bar you want the pointer to be attached.

Line

Size Allows you to determine the width of the pointer line.

Color Allows you to determine the color of the pointer line.

Optimize

Hairlines

Optimizes the appearance of pointer lines when printed with

a high-resolution printer.

Arrows

Shape Allows you to choose to have an arrowhead on the start, the

finish, or both ends of the pointer. You can also choose to

display no arrowhead on the pointer.

Color Allows you to determine the color of the pointer’s

arrowhead.

Pattern Allows you to determine the pattern of the pointer’s

arrowhead.

Arrowhead Size Allows you to determine the size of the pointer’s arrowhead.
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Path

Path buttons Allows you to decide if the path of the pointer is: a straight

line, over and up/down, or up/down and over.

4. Click OK to save your changes and close the Format Pointer dialog.

See also:

Adding pointers to items 

Adding text boxes 

Adding pictures 

Formatting items 

25.6 Pictures

25.6.1 Adding pictures

Adding pictures
Inserting pictures into the Schedule View timeline or Print Preview window allows you to customize your

schedule with photos, company logos, clip art, and other images. You can also add image columns to

the Schedule View of your schedule.

The following file formats can be imported in FastTrack Schedule:

Windows Bitmap (BMP), Windows Enhanced Metafile (EMF), JPEG/JFIF (JPG), Portable Network

Graphic (PNG), Tagged Image File Format (TIF), Macintosh PICT (PCT)

To add a picture to the timeline:
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1. On the Insert tab, in the Timeline Elements group, click Picture.

    The Insert Picture dialog opens.

2. Select Clipboard if you have previously saved an image to your Clipboard.

    -or-

    Select the File option and click the Browse button to navigate to a file.

3. Click OK to apply your changes and close the Insert Picture dialog.

To add a picture to an image column:

1. Insert an image column into your current layout.

2. Double-click in an image column cell.

    The Open dialog opens. 

3. In the Open dialog, navigate to an image file and select it.

4. Click Open to insert the picture into the image field and close the Open dialog.

Note:

If the Clipboard option yields no results, the item on the Clipboard is not in the correct format.

See also:

Resizing pictures

Moving pictures

Formatting pictures

25.6.2 Formatting items

Formatting items
Formatting text boxes, pictures, legends, and OLE objects allows you to add borders, backgrounds, and

shadows.
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To format an item:

1. Click the item or items to select them.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Item dialog opens.

3. Select from the options described below.

This option: Does this:

Display tab

Alignment Sets the item’s alignment.

Clipping: None Allows the item to sit atop the row gridlines so that the entire

item displays in the schedule.

Clipping:

Containing Row

Places the item in a row so that the size of the row

determines how much of the item displays in the schedule.

Determines the number of pixels that surround the item.

Offsets Enter the amount of space (in pixels) between the item and

horizontal/vertical alignment grids. Not available when the

Alignment option "None" is selected.

Show On (available in Print Preview window only)
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Show On: All

Pages

Places the object on every page of the printed FastTrack

Schedule document.

Show On: This

Page

Places the object only on the page of the printed FastTrack

Schedule document that is currently displayed in the Print

Preview window.

Show On: Page

Range X – X

Places the object only on specified pages of the printed

FastTrack Schedule document. Use the From and To boxes

to enter the page numbers.

Border tab

Background Sets the item’s background color and margin. If you wish to

see beneath the item, select the Transparent checkbox.

Line Sets the color and size for the item’s border line.

Shadow Sets the color and size for the item’s shadow.

Corner Radius Determine how sharp or rounded the corners of the item’s

border will be.
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Set as Default Makes the options you select in the Border tab become the

default for all items created in the future.

Font tab Sets font options for text boxes and legends.

4. Click OK to save your changes and close the Format Item dialog.

See also:

Adding text boxes

Adding pictures

25.6.3 Resizing pictures

Resizing pictures
Resizing a picture changes its dimensions. You can resize pictures added to the Schedule View

timeline and to the Print Preview layer. You cannot resize pictures in an image column within FastTrack

Schedule. Those images should be resized outside of the program then added to a cell in the column.

To resize a picture:

1. Click the picture to select it.

2. Click and drag one of the handles until its outline has reached the desired proportions.

    -or-

    Hold down the Shift key and drag one of the corner handles to maintain the same scale.

Note:

Double-clicking the picture returns the picture to its original size.
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See also:

Adding pictures

Moving pictures

Formatting pictures

25.6.4 Moving pictures

Moving pictures
Moving a picture allows you to change its position in the timeline. You can move pictures added to the

Schedule View timeline and to the Print Preview layer. You cannot move pictures in an image column

cell: they will always be centered in the cell.

To move a picture:

1. Click the picture and drag its outline to the desired position.

Notes:

- Holding down the Shift key constrains the picture to moving vertically or horizontally.
- You can also nudge the picture one pixel at a time by selecting it and pressing the left, right, up or
down arrows on your keyboard.
- Moving the picture up or down can change the row to which it belongs, that is, the row that contains
the picture’s top edge. Operations that affect its new row, such as collapsing, also affect the picture.

See also:

Adding pictures

Formatting pictures

Resizing pictures 
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25.7 Legends

25.7.1 Inserting legends

Inserting legends
Inserting a legend creates a key to the bar styles used in the schedule. It lists the chosen bar style and

allows you to assign a name, or a label, to each bar style. You can create multiple legends in the

Schedule View and the Schedule and Resource Print Preview windows.

To insert a legend in the Schedule View:

1. On the Insert tab, in the Timeline Elements group, click Legend.

    The Format Legend dialog opens.

2. Format the legend.

3. Click OK to save the legend and close the Format Legend dialog.

To insert a legend in the Print Preview layer of the Schedule or Resource View:

1. On the Print Preview tab, in the Page Items group, click Insert and choose Insert Legend from the

drop-down list.

    The Format Legend dialog opens.

2. Format the legend.

3. Click OK to save the legend and close the Format Legend dialog.

See also:

Formatting a legend 

Moving legends

25.7.2 Formatting legends

Formatting legends
Formatting a legend defines the title, bar styles, labels, font attributes, border, background, and options



Text Boxes, Pictures, & Legends 343

Copyright © 2010, AEC Software, Inc. All rights reserved.

for the selected legend.

To open the Format Legend dialog in the Schedule View:

1. Click the legend to select it.

2. On the Format tab, in the Display group, click Format Selected.

    The Format Legend dialog opens.

To open the Format Legend dialog in the Print Preview window of the Schedule or Resource

View:

1. Click the legend to select it.

2. On the Print Preview tab, in the Page Items group, click Format Selected.

    The Format Legend dialog opens.

To format a legend:

1. Click the Display tab of the Format Legend dialog.

2. Enter a name in the Title box and select the Show checkbox if you want it displayed at the top of the

legend.

3. Select a cell in the Bar Style column of the table and, from the Bar Style drop-down list, select a bar

style.

    The selected bar style appears in that cell.

4. Select a cell in the Label column of the table and name the bar style appropriately.

5. To change the font attributes of the text or title, use the options in the Font tab.

6. To change the border or background, use the options in the Border tab.

7. Click the Options tab.

8. In the Clipping area, select None or Containing Row.

    None will display the whole legend and Containing Row will hide the parts of the legend that are
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outside the row that contains the legends top-left corner.

    For Print Preview legends, in the Show On area, select the printed pages on which you wish to

display the legend.

9. Click OK to apply your legend changes and close the Format Legend dialog.

Notes:

- To change the order in which rows appear in the legend, click and drag bar styles up or down in the
table.
- To delete a bar style from the legend, select a bar style from the table and press the Delete key on
your keyboard.

See also:

Inserting a legend 

Moving a legend 

Resizing a legend 

25.7.3 Moving legends

Moving legends
Moving legends allows you to change the position of legends in the Schedule View timeline or Print

Preview window.

To move a legend:

1. Click the legend, hold down your left mouse button and drag it to a new position.

Notes:

- Holding down the Shift key constrains the legend to moving vertically or horizontally.
- Moving the legend up or down in the timeline can change the row to which it belongs, that is, the row
that contains the legend’s top edge. Operations that affect its new row, such as collapsing, also affect
the legend.
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See also:

Inserting a legend 

Resizing legends 

25.7.4 Resizing legends

Resizing legends
Use the Arrow tool to resize legends.

To resize a legend:

1. Click the legend to select it.

2. Click on one of the resize handles and drag the outline to the desired width.

Note:

To maintain the proportions of the legend while you resize it, hold down the Shift key and drag one of the

corner handles.

See also:

Inserting a legend 

Moving legends

26 FastSteps

26.1 What are FastSteps?

What are FastSteps?
FastSteps are a scripting ability, built into FastTrack Schedule. FastSteps allow you to automate

repetitive scheduling tasks by grouping a series of commands into a single sequence that you can then

initiate with one menu choice. FastSteps are available in the Schedule, Resource, and Calendar Views
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and their Print Preview windows.

Let’s say, for instance, that every time you update a particular file, you want a report of the activities that

remain unfinished. Using FastSteps, you can create a sequence that applies a filter for incomplete

activities, prints the filtered schedule, restores those activities hidden by the filter, saves the file, and

then closes that schedule. The graphic below illustrates the FastSteps command sequence detailed

above. It is named "Activities to be Completed".

Every time you finish editing the schedule, you simply select "Activities to be Completed" from the list of

FastSteps and all of the commands listed above will be completed automatically.

Each member of a project team can have a FastSteps sequence to suit his or her needs. You could also

create different sequences for every version of the schedule you would like to print, thus creating reports.

There is no limit to the number of uses you can find for this powerful tool.

See also:

Defining a new FastSteps sequence 

Editing an existing FastSteps sequence 

Running an existing FastSteps sequence 

26.2 Defining a new FastSteps sequence

Defining a new FastSteps sequence
FastSteps allow you to string a collection of commands together into one FastSteps script that can be

run with one menu choice.

To create a new FastSteps sequence:



FastSteps 347

Copyright © 2010, AEC Software, Inc. All rights reserved.

1. On the Tools tab, in the Macro group, click FastSteps and choose Define from the choice list.

    The FastSteps dialog opens.

2. Click the New button.

    The Define FastSteps dialog opens.

3. In the FastStep Name box, enter a name for the FastStep.

4. Select an item in the Commands table.

5. Click the Add button to send the command to the FastStep table.

6. Continue inserting commands into the FastStep table until you have the sequence of commands you

desire.

7. Drag commands up and down in the FastStep table to change the order in which the commands

occur.

8. Click OK to apply your change and close the Define FastSteps dialog.

9. Click OK to apply the FastStep and close the FastSteps dialog.

    -or-

    Click Close to exit FastSteps without running a FastSteps sequence. 

    Your newly created FastStep is saved; you simply select the sequence name from the FastSteps

choice list when you are ready to run it.

Notes:

- By selecting the Pause command, you can add a pause to your script. This will pause the FastStep

and bring up a dialog displaying a message you define. Then, in the Pause dialog, you can click the

Resume button to start the FastSteps script where it left off, or you can click the Stop button to abort

the sequence all together. 

- FastSteps can be referenced (called) by other FastSteps and used in Visual Basic and AppleScripts.

See also:

Editing an existing FastSteps sequence 
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What areFastSteps?

26.3 Editing an existing FastSteps sequence

Editing an existing FastSteps sequence
An existing FastSteps sequence can easily be altered to suit your changing needs.

To edit an existing FastSteps sequence:

1. On the Tools tab, in the Macro group, click FastSteps and choose Define from the choice list.

    The FastSteps dialog opens.

2. From the table, select the FastSteps sequence you would like to edit.

3. Click the Edit button.

    The Define FastSteps dialog opens.

4. If necessary, click in the FastStep Name box to edit the title of the FastSteps sequence.

5. Click the Add and Remove buttons to alter the commands in the FastStep table.

6. Drag commands up and down in the FastStep table to change the order in which the commands

occur.

7. Click OK to apply your changes and close the Define FastSteps dialog.

8. Click OK to apply the FastStep and close the FastSteps dialog.

    -or-

    Click Close to exit FastSteps without running a FastSteps sequence. 

    Your changes to the FastStep are saved; you simply select the sequence name from the FastSteps

choice list  when you are ready to run it.

See also:
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Defining a new FastSteps sequence 

What are FastSteps? 

26.4 Deleting a FastSteps sequence

Deleting a FastSteps sequence
FastSteps can be deleted in the FastSteps dialog.

To delete a FastStep:

1. On the Tools tab, in the Macro group, click FastSteps and choose Define from the choice list.

    The FastSteps dialog opens.

2. Select the FastStep you wish to delete.

3. Click the Delete button.

    A confirmation dialog appears asking you to verify that the FastStep will be deleted.

4. Click OK to delete the FastStep or Cancel to retain the FastStep.

    If you delete the FastStep, it will no longer be available from the FastSteps choice list.

5. Click OK to close the FastSteps dialog and apply the FastStep that is currently  selected.

    -or-

    Click Close to close the FastSteps dialog without applying a FastStep.

See also:

What are FastSteps?
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26.5 Duplicating a FastSteps sequence

Duplicating a FastSteps sequence
An existing FastSteps sequence can be duplicated in the FastSteps dialog.

To duplicate a FastStep:

1. On the Tools tab, in the Macro group, click FastSteps and choose Define from the choice list.

    The FastSteps dialog opens.

2. Select the FastStep you wish to duplicate.

3. Click the Duplicate button.

    The Define FastSteps dialog opens.

4. Edit the new FastStep.

5. Click OK to save the new FastStep and close the Define FastSteps dialog.

6. Click OK to close the FastSteps dialog and apply the FastStep that is currently selected.

    -or-

    Click Close to close the FastSteps dialog without applying a FastStep.

See also:

What are FastSteps?

26.6 Running an existing FastSteps sequence

Running an existing FastSteps sequence
Once you have created a FastSteps script you can run it at any time you are working on a schedule.

Keep in mind, however, that changes to filters, sorts, layouts, and ranges will affect any FastSteps that

include them.



FastSteps 351

Copyright © 2010, AEC Software, Inc. All rights reserved.

To run an existing FastSteps sequence:

1. On the Tools tab, in the Macro group, click FastSteps and select the FastStep you wish to run from

the choice list.

Note:

If a FastSteps script is unable to run, the Define FastSteps dialog opens with the command that does

not work highlighted. Most likely, the FastStep contains a filter, sort, layout, or range that has been

deleted or renamed.

See also:

Editing an existing FastSteps sequence 

What are FastSteps?

27 iCalendar Integration

27.1 Working with iCalendar files

Working with iCalendar files

iCalendar is a data standard for viewing your project data in calendar form.

You can quickly publish your FastTrack Schedule file as an iCalendar (.ics) file to any hosting location.
You can also export the file as an iCalendar (.ics) file, or, if you are using Mac OS X 10.3.9 or later,
into iCal.

What do you want to do:

 Publish a schedule as an iCalendar file

 Unublish an  iCalendar file

 Using the Schedule Publish Log

 Import iCalendar files

 Export data as an iCalendar file
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27.2 Publishing schedules as iCalendar files

Publishing schedules as iCalendar files

You can publish your schedule as an iCalendar to a public or private server. 

To publish a schedule as an iCalendar to another location:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Publish and choose Publish to iCalendar Server from
the submenu.

    The Publish iCalendar dialog opens.

2. Click Publish.

    The Schedule Published dialog opens.

3. Click Visit Page to open the iCalendar file in a browser.

    -or-

    Click Send Mail to open your mail program and create a mail message regarding the newly
published iCalendar file.

    -or-

    Click Close to close the Schedule Published dialog.

See also:

Working with iCalendar files

27.3 Unpublishing an iCalendar schedule

Unpublishing an iCalendar file

You can remove an iCalendar you have published to a server.

To unpublish a schedule as an iCalendar:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Publish and choose Unpublish to iCalendar Server
from the submenu.

    The Unpublish iCalendar dialog opens.

2. Select the Publish Name of the iCalendar file in the table.

3. Click the Unpublish Selected button.

    Clicking the Unpublish All button will select and unpublish every iCalendar in the table.

4. Click Close to close the Unpublish iCalendar dialog.
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See also:

Working with iCalendar files

27.4 Importing iCalendar files

Importing iCalendar files

You can import an iCalendar (.ics) file into your open schedule.

To import an iCalendar file:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Import, and choose iCalendar.

    The Open dialog opens.

2. Navigate to the iCalendar file you want to import, and select it.

3. Click Open to close the Open dialog and import the iCalendar file.

See also:

Working with iCalendar files

27.5 Exporting data as an iCalendar

Exporting data as an iCalendar file

You can export your open schedule as an iCalendar (.ics) file.

To export an iCalendar file:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Export, and choose iCalendar.

    The Export iCalendar dialog opens.

2. Click Export.

    The Save As dialog opens.

3. Choose the name and location to which you want to save the exported .ics file.

4. Click Save to close the Save As dialog and export your open schedule data to an iCalendar file.

See also:
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Working with iCalendar files

27.6 Using the Schedule Publish Log

Using the Schedule Publish Log

Every time you publish a schedule as an iCalendar, the transaction is noted in the Schedule Publish
Log. Data in the log is static, but you can clear data and save the log as a text file.

To clear the Schedule Publish Log:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Publish and choose Publish Log from the submenu.

    The Schedule Publish Log opens.

2. Click Clear Log to erase the logged transactions.

3. Click Close to close the Schedule Publish Log.

To save the Schedule Publish Log:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Publish and choose Publish Log from the submenu.

    The Schedule Publish Log opens.

2. Click Save Log to save the logged transactions as a text file.

    The Save As dialog opens.

3. From the Save as type pull-down list, choose the file type in which you would like to save the log
data.

4. Navigate to the location to which you would like to save the file.

5. Click Save to save the log data.

6. Click Close to close the Schedule Publish Log.

See also:

Working with iCalendar files
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28 MindManager Integration

28.1 Working with MindManager files

Working With MindManager Files

You can easily exchange data between FastTrack Schedule and MindJet MindManager files. 
You can open and import MindManager files, as well as export the file as a MindManager file.

What do you want to do:

 Importing MindManager Files 

 Opening MindManager Files 

 Exporting Data as MindManager Files

28.2 Importing MindManager Files

Importing MindManager Files

You can import a MindManager (*.mmap) file into your open schedule.

To import a MindManger file:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Import, and choose MindJet MindManager.
    The Import MindManager dialog opens
2. Navigate to the MindManager file you want to import, and select it.
3. Click Open to close the Open dialog and import the MindManager file.

See also:

Opening MindManager Files 

Exporting Data as MindManager Files 

28.3 Opening MindManager Files

Opening MindManager Files

You can open a MindManager (*.mmap) file and create a new FastTrack Schedule Document.

To Open a MindManager file:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Open.
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    The Open dialog opens
2. Navigate to the MindManager file you want to open, and select it.
3. Click Open to close the Open dialog and open the MindManager file. 
    A new FastTrack Schedule Document is created with the data from the MindManager file.

See also:

Importing MindManager Files 

Exporting Data as MindManager Files 

28.4 Exporting Data as MindManager Files

Exporting Data as MindManager Files

You can export your open schedule as a MindJet MindManager  file.

To export a FastTrack Schedule file as a MindJet MindManager File:

1. Click the Application Button which is the graphic  at the top left of the FastTrack Schedule
window to open the Application menu, then click Export, and choose MindJet MindManager from the
submenu.
    The Save As dialog opens.
2. Navigate to the directory, enter or edit the file name, and click Save.
3. Open the newly created MMap file in MindJet MindManager. 

See also:

Importing MindManager Files 

Opening MindManager 

29 Reference Information

29.1 Keyboard Shortcuts

Keyboard Shortcuts

This notation: Means:
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Ctrl The key labeled Control or Ctrl.

Alt The key labeled Alternate or Alt.

Option The key labeled Option.

Shift The key labeled Shift.

Ctrl+B Hold down the Control key and at the same time press the key

labeled B.

Ctrl+Alt+P Hold down the Control key and at the same time press the Alt key

and the key labeled P.

To do/launch this: Shortcut:

Bold Text Ctrl + B

Calendar View Ctrl + 2

Carriage Return Alt + Enter

Close file Ctrl + W

Copy Ctrl + C

Cut Ctrl + X

Current Date Ctrl + 7

Current Time Ctrl + 8

Exit the program Ctrl + Q

ExpressDate calendar Ctrl + 9

ExpressTime clock Ctrl + 0 (zero)

Find/Replace dialog Ctrl + F
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Font dialog Ctrl + Shift + T

Format Item Ctrl + Shift + M

Format View Ctrl + Shift + F

Get Consolidation Updates Ctrl + E

Go To Bar Ctrl + D

Go To Row Ctrl + G

Help Contents Ctrl + ? or F1

Italics Ctrl + I

Information Form Ctrl +T

Launch File/URL Ctrl + L

Link Selected Bars Ctrl + Shift + L

New File Ctrl + N

Nudge Down Down Arrow

Nudge Left Left Arrow

Nudge Right Right Arrow

Nudge Up Up Arrow

Open File Ctrl + O

Open Template Ctrl + Shift + O

Paste Ctrl + V

Print Preview Ctrl + Alt + P

Print Schedule Ctrl + P
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Print Setup Ctrl + Shift + P

Project Information form Ctrl + Shift + D

Redo Ctrl + Y

Resource Information form Ctrl + R

Resource View Ctrl + 3

Save As Ctrl + Shift + S

Save file Ctrl + S

Schedule View Ctrl + 1

Select All Ctrl + A

Underline Text Ctrl + U

Undo Ctrl + Z

Unlink Bars Ctrl + Shift + U

Zoom In Ctrl + +

Zoom Out Ctrl + -

29.2 Additional Help Resources

29.2.1 AEC Software support services

AEC Software support services
If you have a question about the operation of the application, first look in the Online Help System

resources, outlined in the Online help section. If you cannot find the answer to your question, contact

AEC Software Technical Support. Technical Support is typically available Monday through Friday,

between 8:00 AM and 5:00 PM Eastern Standard Time, USA.
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You can contact AEC Software Technical Support in a variety of ways:

- Phone: (703) 450-2318
- Fax: (703) 450-9786
- Email: support@aecsoftware.com
- WWW: http://www.aecsoftware.com/support

For sales information, (703) 450-1980.

When you call AEC Software Technical Support, your computer and FastTrack Schedule should be

running and you should be in front of your computer.

Please be prepared to provide the following information:

· Your serial number. (This number is found on the CD sleeve, the back cover of the manual, or the
registration card.)
- The product version number.
- The type of hardware and the operating system on which you are running the application.
- The exact nature of your problem and what you were doing when it occurred.
- The exact message in any alerts or dialog boxes that appear on your screen in response to your
problem.
- Any and all steps you have taken to solve the problem.

29.2.2 Online Help

Online help 
Help is only a click away when you use FastTrack Schedule’s Online Help System. FastTrack

Schedule’s Online Help is a comprehensive and context-sensitive help system that provides keyword

searches, topic searches, and tutorials. FastTrack Schedule Online Help is available whenever

FastTrack Schedule is running. It contains the most up-to-date help information available for FastTrack

Schedule.

mailto:support@aecsoftware.com
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To access the online help topics when FastTrack Schedule is running, click the Help icon . On the

Application tab, in the Help group, you can access: a list of keyboard shortcuts, example files and

tutorials.

You must have a web browser (such as Microsoft Internet Explorer™ or Mozilla Firefox™) installed on

your computer to run FastTrack Schedule’s Online Help System. You do not, however, have to be

connected to the Internet.

Additional Help Options

·  FastTrack Schedule Help button. This button, located in many of the dialogs, is context-sensitive
and opens the FastTrack Schedule Online Help System directly to the topic page describing the related
procedure.

· Tool Tips . When you hover your cursor over a button, tool, or dialog option for a few moments, a Tool
Tip appears describing the item’s basic features or purpose. 

Extended Tool Tips and Help Tags. To display extended information about a dialog option, click the
Help button with the question mark icon in the top right corner of the dialog and click a dialog option.
Extended Tool Tips are available for many dialog options.

Tutorials. FastTrack Schedule provides online tutorials with instructions that you can follow on your
computer or print out. Each tutorial has a practice FastTrack Schedule file to use as you work through
the tutorial. Look in the Help group on the Application tab for tutorial resources.

Frequently Asked Questions. The AEC Software website now hosts a searchable, frequently-updated

database of common questions received from customers about the latest version of FastTrack Schedule.

Support Knowledgebase. The AEC Software website also hosts an extensive, searchable database of
commonly asked questions from recent FastTrack Schedule versions. Search by keyword, article
number, or title.
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29.3 Function Reference

29.3.1 Function Reference

Function Reference

Select a category of functions from those listed below:

Number Functions

Text Functions 

Statistical Functions

Logical Functions

Date and Time Functions

Alphabetical Listing 

See also:

Entering a calculation 

Overview of calculation columns 

Calculation setup 

29.3.2 Number Functions

Number Functions

Abs

Cos

Div

Even

Exp 

Fact 
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FV (Future Value)

Ln Function 

Log

Mod

NullNum

Odd

Pmt (Payment)

Power 

PV (Present Value)

Round 

Sin

Sqrt

Tan

Trunc 

See also:

Text Functions 

Statistical Functions

Logical Functions

Date and Time Functions

(Alphabetical Listing)

29.3.3 Text Functions

Text Functions
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DateToText

Find Function 

FindPos

Left

LeftWords

Mid

MidWords

NumChars

NumToText

NumWords

Proper

Replace

Right

RightWords

TextToDate

TextToNum

TextToTime

TimeToText

ToLower

ToUpper

Trim

See also:

Number Functions 

Statistical Functions 

Logical Functions 



Reference Information 365

Copyright © 2010, AEC Software, Inc. All rights reserved.

Date and Time Functions 

(Alphabetical Listing)

29.3.4 Statistical Functions

Statistical Functions
 

Ave

AveDev

Max Function

StdDev

See also:

Number Functions

Text Functions 

Logical Functions

Date and Time Functions

(Alphabetical Listing)

29.3.5 Logical Functions

Logical Functions

If Function 

IsEven

IsInt
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IsNull

IsOdd

TextIsDate

TextIsNum

TextIsTime

See also:

Number Functions

Text Functions 

Statistical Functions 

Date and Time Functions

(Alphabetical Listing)

29.3.6 Date and Time Functions

Date and Time Functions

Date

Day Function 

DayOfWeek

DayOfWeekName

Duration

Duration (with times) 

DatelineDate 

DatelineTime 

Finish Date 
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Finish Date (with times) 

Month

MonthName

Time Function 

Work Calendar Base Day Duration 

Work Calendar Day Duration 

Work Calendar Typical Day Duration 

Year

See also:

Number Functions

Text Functions 

Statistical Functions 

Logical Functions 

(Alphabetical Listing)

29.4 Operator Reference

29.4.1 Operator Reference

Operators
Symbols that determine which operation to perform on the calculation elements:

+, -, *, =, <>, <, >, <=, >=, and, or, not

Each operator has a precedence, which determines the order in which expressions are evaluated in a

calculation that contains more than one operator. FastTrack Schedule evaluates operators from left to
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right and performs multiplication and division before addition and subtraction. You can change the

precedence by enclosing the expression you want calculated first in parentheses.

Mathematical

Text

Comparison

Logical

29.5 Comparison Operators

29.5.1 Comparison Operators

Comparison Operators

Comparison operators compare two expressions and return either true or false (sometimes called a

Boolean expression). Arithmetically, a result of true equals 1 and a result of false equals 0.

Symbol Name Example Definition

= Equal to 38 = 38 returns true True when both items

are equal

<> Not equal to 38 <> 39 returns

true

True when both items

are not equal

> Greater than 19 > 1 returns true True when the value on

the left is greater than

the value on the right

< Less than 5 < 6 returns true True when the value on

the left is less than the
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value on the right

>= Greater than or

equal to

19 > 1 returns true True when the value on

the left is greater than

the value on the right

<= Less than or equal

to

5 < 6 returns true True when the value on

the left is less than the

value on the right

IMPORTANT: When using comparison operators with functions and columns which evaluate to a date or

time, remember that all arguments surrounding the operator must be of the same type: date or time. For

instance, the following calculation:

If(([Start Date] <  Jun 18, 2002) , "Late", "Early") 

is not valid because "Jun 18, 2002" is not interpreted as a date in this case. 

For this situation, use:

If(([Start Date] <  TextToDate("Jun 18, 2002")) , "Late", "Early") 

which converts "Jun 18, 2002" into a date so that it may be compared to [Start Date].

Or if comparing times, use:

If(([Start Time] <  TextToTime("11:30 AM")) , "Late", "Early") 

which converts "11:30 AM" into a time so that it may be compared to [Start Time].

Operator Reference 
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29.6 Release Notes

29.6.1 Release Notes

Release Notes

Select the Release number for which you would like to view Release Notes:

Current Version 10.0.3

Version 10.0.2

Version 10.0.1

Version 10.0.0

29.6.2 Release Notes Version 10.0.3

Release Notes Version 10.0.3

New and Enhanced Features:

Changed the behavior of Save as Template to not memorize current path for future Saves.

Improved HTML export so that the resultant file can be opened in Safari and Chrome.

Bug Fixes:

Fixed failure to launch issue experienced by some users with Safari 5.1 (Mac version).

Fixed a Save and Replace MPX/XML error

Fixed bar stacking in the Calendar view (Windows version).

Fixed Find/Replace error when searching for a repeating sequence of characters (Windows
version).

Fixed a Save and Replace error when exporting as MPX or Project XML (Mac version).

Miscellaneous and minor errata affecting English and International versions.

 Return to Release Notes
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29.6.3 Release Notes Version 10.0.2

Release Notes Version 10.0.2

New and Enhanced Features:

Added an event alert 12 hours before the event start time when tasks are exported to iCal and as
an .ics file

Constrained the spin box in the QuickRange to non-negative numbers

Improved the conversion of FastSteps in files upgraded from FastTrack Schedule 9x to FastTrack
Schedule 10

Improved conversion of Filters with Dateline calculations in files upgraded from FastTrack Schedule
9x to FastTrack Schedule 10

Improved importing of Microsoft Project .mpp and .mpx files by correcting reversed baseline bars,
making them 1 day tasks (MS Project allows baseline start dates to be later than baseline finish
dates. FastTrack Schedule 10 does not allow this scheduling inaccuracy)

Improved the importing of Microsoft Project .mpp and .mpx files where Work is zero in the MS
Project file

Bug Fixes:

Fixed crash caused when switching the timeline graph units to hours in files created from Microsoft
Project .mpp and .mpx files

Fixed error that resulted in events being shifting by one day when exporting to iCal and as an .ics
file

Fixed copy/paste error that occurred when images from some other applications were placed into
Print Preview (This error had rendered the file unopenable. Issue is fixed and affected files can now
be opened)

Fixed issue that would cause a crash in some files when a duplicate resource name was entered in
the Information dialog

Miscellaneous and minor errata

 Return to Release Notes
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29.6.4 Release Notes Version 10.0.1

Release Notes Version 10.0.1

New and Enhanced Features:

Improved handling of special characters in a file name when exporting to iCalendar or as an .ics file

Improved dragging of bars when the timeline is set to hours

Improved error handling when creating new resources from within the Information form

Improved dragging of bars in the Schedule view

Improved file conversion of FastTrack Schedule 8 and 9 files that contained spot resource
allocations with zero work values

Added background resource row highlighting in the Resource Information form

Improved pasting of text into columns

Added feature enabling opening MS Project 2010 files.

Added feature enabling font attributes for text values in a group of cells to be modified for most fonts

Improved the updating of data in the Resource Cost column when a resource's effort is modified

Improved link selection controls, minimizing unintended link deletion

Added a Table of Contents to the Concurrent-User Guide PDF (Concurrent-User Versions)

Added the ability to enter four digit years in the Define Range dialog, providing the ability to display
historic timeline ranges

Bug Fixes:

Fixed error involving disappearing values in the Activity Name column

Fixed error involving a null Resource Name

Fixed error regarding 'Send to Mail Recipient as Picture' from Print Preview

Fixed error regarding opening the Define Consolidation dialog

Fixed error involving bars sometimes not appearing when drawn

Fixed printing errors when using FastSteps

Constrained the size of milestones to non-negative numbers

Fixed error when switching Resource View timeline units to hours
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Fixed the updating of Actual Start Dates in the Information form when entering dates in the
Schedule View Actual Start Date column

Fixed display of bars in the Bar Styles table after bar styles are copied, pasted, and deleted

Fixed an error where it was possible to have no bar style selected in the Bar Style table

Fixed an error relating to deleting a Summary Graph via a contextual menu

Fixed an error that limited the number of bar styles

Miscellaneous and minor errata

 Return to Release Notes

29.6.5 Release Notes Version 10.0.0

Release Notes Version 10.0.0

New and Enhanced Features:

Getting Started dialog with Quick Tips Video Tutorials

All new interface

Dual interface, you can choose to use the Ribbon or Classic Menus interface.

Unified, simplified menu structure for all three views (Classic Menus interface)

Effort Driven Scheduling providing automatic schedule changes as additional resources are
assigned

All new work calendaring system, providing unlimited flexibility, convenience, and compatibility.

Image columns, providing up to 10 images per row.

Greatly enhanced Resource Contact form, including resource photos

New resource availability filtering

Resource Usage graph in the Schedule View provides resource usage information prior to, and
after, resource assignments are made

Automatic resource assignment contouring

Live resizing of graphic elements

Gradients for graphic items and bar styles

Alternating row shading

New bar styles
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Open Microsoft Project files directly

Enhanced compatibility with Microsoft Project

Enhanced compatibility with Microsoft Outlook

Open and Save-As to MindManager 8 files

More New Templates and Examples

Numerous other enhancements and ease of use features

 Return to Release Notes

29.7 Requirements

29.7.1 Hardware and software requirements

Hardware and software requirements
The following hardware and software is required to run FastTrack Schedule:

To run FastTrack Schedule on a Microsoft Windows® operating system, you need:

- Microsoft Windows XP (SP3), Windows Vista (SP1), Windows 7
- 500 MHz processor or higher

- 256MB of RAM

- 150MB of free hard disk space

- 1024x768 or higher screen resolution

To run FastTrack Schedule on a Mac® computer, you need:

- Mac OS X v10.5.8 Leopard or later, v10.6 Snow Leopard
- 867 MHz or faster Intel, PowerPC G5, or PowerPC G4 processor

- 512MB of RAM

- 150MB free hard disk space

- 1024x768 or higher screen resolution

30 Glossary

30.1 Action Columns

Action Columns

FastTrack ScheduleAction Columns simplify working with activities and resources. The Action
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Columns can be displayed to the left of the columns in the Schedule and Resource Views. They
simplify operations performed on rows, subrows, and outline levels.

Row Number/Select Row

Clicking here selects the row for moving, deleting, copying, cutting, formatting, and hiding.

 Page Break 

Clicking here makes the corresponding row the last row on a printed page.

Information Form

Clicking here opens the Information form in the Schedule View and the Resource Information form in
the Resource View.

 Expand/Collapse

Clicking here collapses and expands outline levels in the Schedule View and subrows in the Resource
View.

30.2 Activities

Activities
Anything you need to schedule or track. FastTrack Schedule displays activities in rows and lets you see

their start, finish, and duration as bars in the timeline graph. 

There are many common terms for activity: task, project, phase, event, milestone, and deadline.
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30.3 Actual Dates

Actual Dates
The dates of an activity which represent when the activity actually began and finished. Interrelated with

% Complete. Part of FastTrack Schedule's Scheduled, Revised, and Actual tracking for monitoring the

progress of activities against a planned baseline.

30.4 Arrow tool

     

Arrow tool. The general-purpose tool that selects, resizes, and moves items in all Views. When you
want to drag an activity bar, this is the tool you need to have selected.

30.5 Assignments

Assignments

Assignments link a resource and all its data to a task or tasks in the schedule. The Schedule and
Resource Views draw from two different pools of information. Assignments act to bridge those two
pools of information. 

You can create a schedule full of tasks and you can create numerous resources complete with work
calendars and cost data, but until you actually assign a resource to a task, the Schedule and
Resource Views cannot interact.

See also:

Working with resources

30.6 Assignment subrow

Assignment subrow

This subrow displays all activity bars to which this resource has been assigned. 

You can move bars in this subrow -- and this affects the location of the bar in the Schedule View. You
can also spot allocate the resourceusage from within this subrow.
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30.7 Bar

Bar
Also referred to as "Activity Bar." It is drawn in the timeline graph to display an activity's start, finish, and

duration. FastTrack Schedule lets you design and draw bars and lets you display information about each

bar in columns.

30.8 Bar Labels

Bar Labels

Showing data on a bar style lets you add date, time, duration, % Complete, and other bar information
as a label on a bar style. 

Bar labels created in the Format Bar Style dialog do not display in the Calendar View. Use the Format
Calendar View dialog to create bar labels in the Calendar View.

30.9 BarStyles group

Bar Style group

The cells of the Bar Styles drop-down list contain the bar styles defined for the schedule. You can use
the Bar Styles Toolbar to design a new bar style, edit an existing bar style, or change the bar style
applied to an activity.

30.10 Bar Tracking Window

Bar Tracking Window

The bar tracking window displays the date and time information about the drawn or dragged activity bar.
Use the Tracking tab of the Document Options dialog to customize this option. 

30.11 Bar tool

     

Bar tool. Draws activity bars in the timeline graph.
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30.12 Calendar Title

Calendar Title

The title is, by default, the current calendar range. You can choose to show or hide the title in the
Format Calendar View dialog.

You can use headers and footers to create custom titles that will display when the calendar is printed.

30.13 The Calendar View

The Calendar View

The Calendar View displays information from the Schedule View in the traditional look of a wall
calendar. This allows you to view time vertically rather than horizontally, as you do in the Schedule and
Resource Views. You can view and print completely customizable calendars that can be filtered to
display only those activities you want to see. You can also create a calendar of any number of
contiguous weeks.

In the Calendar View you can draw bars; move bars; hide bars; filter activities – to view only those bars
you want to see; edit Scheduled, Revised and Actual dates and times; apply ranges and FastSteps;
and print the calendar in current, monthly, and custom configurations.
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See also:

The Schedule View 

The Resource View 

30.14 Chaining

Chaining
The process of adjusting activity dates so that there are no overlaps or lead/lag time between the

activities’ starts and finishes. Chaining creates a tight schedule by setting activities' start dates to the

previous bar's finish dates.

30.15 Chart

Chart
Another word for the Timeline Graph which displays the activity bars in a schedule.

Also, FastTrack Schedule makes it simple for you to print a wall chart, or large display version of your

schedule, using standard paper.

30.16 Collapsed

Collapsed
Refers to activities whose outline levels have been "rolled-up." Their subactivities are no longer visible.

30.17 Columns

Columns

Columns display data related to each activity, such as the start, finish, and duration of its activity bars,
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the resources assigned to the activity, and so on. You can show as many columns as you want on
either side of the timeline graph, using the Columns tab in the Define Layout dialog.

30.18 Column Summaries

Column Summaries

Column summaries summarize the values currently displayed in columns. They appear below the
column they summarize. Six types of summaries can be performed: total, average, standard deviation,
minimum, maximum, and count.

30.19 Context-clicking

Right-clicking

Throughout the help documentation you will see references to right-clicking on items. Right-clicking
refers to clicking with your right mouse button. If your mouse does not have a right mouse button, hold
down the Control key while clicking your mouse. 

You right-click to access context, or shortcut, menus that pertain directly to the object on which you
click.

It is a good idea to try right-clicking on every object in every view in the program to see which have a
shortcut menu. Once you have discovered how to access shortcut menus, try to use them as much as
possible as you work with FastTrack Schedule.

30.20 Component

Component
Refers to activity bars. Activity bars have three components: Scheduled, Revised, and Actual. Each

component has a set of dates, times, and durations for which columns are defined. The display of each

component is defined in the Format Bar Style dialog.

30.21 Critical Path

What is a critical path?

In FastTrack Schedule, the critical path is the route between linked bars, in a group of linked bars, with
the smallest total slack between tasks. Slack is determined by subtracting a link Minimum lead/lag



Glossary 381

Copyright © 2010, AEC Software, Inc. All rights reserved.

time from a link duration. 

Suppose you have a software project due for delivery in two weeks. In the two weeks before it is due
you must accomplish two things: you must write the software and you must create a graphic for the
box in which the software will ship. Writing the software will take two weeks; creating the graphic will
take one day. 

 

Because you can create the graphic anytime in those two weeks, there is greater elasticity, or slack,
to that task. It must happen before the project is due, but it can happen on the last day and still not
affect your delivery date. Writing, however, is the more critical activity; it cannot slip without affecting
your delivery time. Thus, the task "Write" is on the critical path of your schedule. 

Because a critical path is defined by the dependency of one task on another, only linked bars are
considered part of a critical path. 

See also:

Critical path and bar priority 

Formatting the display of critical path 

Showing and hiding critical paths 

30.22 Cursor Tracking Area

      

The Cursor Tracking Area displays the time and/or date over which the cursor is positioned in the
timeline or calendar. Use the Tracking tab of the Document Options dialog to customize this option.
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30.23 Datelines

Datelines

Datelines allow you to display the current schedule date and time or custom defined dates and times
as a vertical line drawn in the timeline graph. The options to show, hide, change the appearance of, and
set the schedule date and time are available by choosing the Datelines tab of the Format Schedule
View dialog.

30.24 Dependent Activities

Dependent Activities
Activities which have been linked together. When one activity is dependent upon another, changes to

one activity may affect the other.

30.25 Duration

Duration
The length of time between a start and a finish. In FastTrack Schedule, there are durations for Scheduled

activity dates/times, Revised activity dates/times, Actual activity dates/times, and for the project itself.

30.26 Early Start or Finish

Early Start or Finish
Refers to an activity bar that has a Revised date that is earlier than the Scheduled date. For instance,

using the Revised tool, you could drag an activity's Revised start date to an earlier date.

30.27 Expanded

Expanded
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Refers to activities whose outline levels are not collapsed. All of their subactivities are visible.

30.28 Expand/Collapse Action Column

Expand/Collapse Action Column

This Action Column contains a triangular handle for activities which have subactivities indented beneath
them. To collapse an outline level, click the down-facing triangular handle to turn to the right. To
expand an outline level, click the right-facing triangular handle to turn it downwards. 

To display the Expand/Collapse action column, on the View tab, in the Show/Hide group, click Action
Columns, and choose Outline from the drop-down list.

30.29 Full Allocation Line

Full Allocation Line

This line indicates when a resource has been allocated for the maximum amount of time possible, as
defined in its work calendar.

The appearance of the line can be formatted in the Format Resource Row dialog.

30.30 Finish

Finish
The date and time at which an activity or schedule ends. You can set the finish of an activity's

Scheduled, Revised, Actual component as well as for the project itself.

30.31 Gantt

Gantt chart 
A type of scheduling tool named for Henry Gantt. It displays the starts, finishes, and duration of activities

as activity bars placed along a timeline graph. The Schedule View of FastTrack Schedule is a Gantt

chart.
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30.32 Graph

Graph
The timeline graph of the schedule displays a graphed window of time along a continuous timeline. It

contains the activity bars that define the start, finish, and durations of activities.

A summary graphs summarize the values currently displayed in columns over a particular period of
time. A summary graph appears as a row under the timeline graph, making it easy to match the
summary data to the corresponding time period. Six types of summary graphs can be created: Total,
Average, Standard Deviation, Minimum, Maximum, and Count (as well as cumulative totals and
counts). There are three types of graphs: numeric, line graph, and histogram. These can be displayed
in hundreds of different styles.

30.33 Linking

Linking
Creates a dependency between activity bars. When changes are made to one linked activity, all other

linked activities may also change.

30.34 Milestone

Milestones
The type of activity which occurs in a single moment of time. For instance, a deadline is a milestone

because it has just a start date and a time--it has no duration or finish.

30.35 Outline

Outline
Lets you create a hierarchy of activities. An activity outline consists of higher-level activities that contain

subactivities within them.
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30.36 Out of Range Days

Out of Range Days

In the Format Calendar View dialog, you can choose whether or not to shade Out-of-Range days. You
can also format the color and pattern of the shading.

30.37 Overtime

What is Overtime?

Several factors are involved in calculating overtime for an assigned resource.

Percent Effort: When you use Percent Effort values, anything over 100% effort is overtime. You enter
and edit the Percent Effort a resource will expend on a particular task in the Bars>Assignments tab of
the Information form. 

Spot allocation:  When you change a resource’s Time Usage (i.e. Hourly, Daily, etc.) by spot
allocating, the changes are calculated in relation to the units of the Resource View timeline such as
you have defined them (i.e. Hours, Days, etc.). If the Resource View timeline units are in work time,
any Time Usage that exceeds the typical work time you have defined for the unit is overtime. If the
Resource View timeline units are in calendar time, any Time Usage that exceeds the absolute time in
that unit is overtime usage. For example, allocating more than 24 hours of usage to a unit of 1 calendar
day will result in overtime usage.Note:You determine a resource’s overtime rate, if any, in the Resource
Information form or in the Bars>Assignment tab of the Information form. (Overtime rates entered in the
Bars>Assignment tab apply only to the assigned task.)

See also:

Working with resources 

30.38 Legends

Legends

Legends are graphic items that describe what the bar styles on the schedule represent. They contain
an image of a bar style and a label that captures the meaning of a bar style. They can be added to the
Schedule View or Print Preview windows.

30.39 Link tool

     

Link Bars tool. Lets you draw links between bars to create dependencies.
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30.40 Links

Links

Linking two activity bars creates a dependency whereby, if the dates of one activity change, all
dependent activities’ dates change accordingly. FastTrack Schedule supports FS (Finish to Start), FF
(Finish to Finish), SF (Start to Finish) and SS (Start to Start) links.

30.41 Milestones

Milestones

A milestone is used to denote a task that occurs in a single moment of time, such as a meeting or a
deadline. These types of tasks have no duration. Thus, milestones consist of just one point that has a
start but not a finish.

30.42 Percent Complete

Percent Complete
The portion or amount of the activity that has been completed. It can drawn with the % Complete tool or

entered as a data in the % Complete column. It can display graphically on the bar.

30.43 Percent Usage subrow

Percent Usage subrow

This subrow displays the percent of the total available allocation time available for the specified
resource that is being used.

The appearance of the graph can be formatted in the Format Resource Row dialog.

30.44 Pictures

Pictures

Pictures are graphic items that contain images (e.g. clip art) that you paste into the Schedule View or
Print Preview windows and in the Resource View within image columns.
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30.45 Pointers

Pointers

Pointers are lines that branch out from items, such as text boxes and pictures, and extend to any
point on the timeline graph to which you want the item to refer. Frequently, items are situated on the
timeline in such a way that it is not clear with what they are to be associated. Pointers act as a
graphic representation of the relatedness of an item to some part of the schedule, such as a bar or a
point in time. Pointers are only available in the Schedule View.

30.46 Project Hierarchies

Project Hierarchies
Refers to the grouping or break-down of activities into different levels. In FastTrack Schedule, project

hierarchies are created by outlining activities and their subactivities in the Activity Name column or by

creating a Work Breakdown Structure (WBS).

30.47 Revised tool

     

Revise tool. Changes the activity's Revised start and/or finish dates, times, and duration.

30.48 Revised Dates

Revised Dates
Represent changes to the Scheduled dates of an activity. The Revised dates are always the most

current dates. Part of FastTrack Schedule's Scheduled, Revised, and Actual tracking for monitoring the

progress of activities against a planned baseline.

30.49 Rows

Rows

Each row contains an activity or activities and the corresponding activity bar or bars. You can perform
operations on rows using the Action Columns.
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30.50 Row Number Action Column

Row Number Action Column

This Action Column displays the row numbers of rows. Clicking a row number selects the row and
allows you to move it. 

To display the Row Number action column, on the View tab, in the Show/Hide group, click Action
Columns, and choose Row Number/Select Row from the drop-down list.

You can print row numbers by choosing Print Row Numbers in the Page Options dialog.

30.51 Schedule

Schedule
Contains activities which are displayed in columns and a timeline graph that displays the activities' bars.

Each file that you create in FastTrack Schedule is a schedule.

30.52 Scheduled Dates

Scheduled Dates
Represent when an activity is planned to start and end. This is the basic component of an activity bar,

drawn with the Bar tool. Also called, "Baseline Dates."  Part of FastTrack Schedule's Scheduled,

Revised, and Actual tracking for monitoring the progress of activities against a planned baseline.

30.53 Slack

Lead/Lag time 
Describes the amount of time before which the finish of one activity affects the start of another activity.

30.54 Slipping

Slipping
Refers to the act of making a date later. While you can slip the Scheduled component of an activity, the
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term slipping usually denotes a change in the Revised dates. Revised dates can be set using the

Revised tool.

30.55 Spot Allocation

What is spot allocation?

Spot allocation is the act of editing a portion of an assigned resource’s total Time Usage (i.e. Hourly,
Daily, etc.) in the Assignments subrow of the Resource View. Spot allocation is based on the
Resource View timeline units as you have currently defined them (i.e. Work Hours, Work Days, etc.).

A spot allocation example:

If, on Wednesday the 21st and Thursday the 22nd, resource Ann Parker is assigned to work 8 hours
on the task "Design" and 8 hours on the task "Prototype", she has a total Hourly Usage on those days
of 16 hours. Because you have defined her typical work day as being 8 hours in length, Ann Parker is
over allocated on the 21st and 22nd. The solution is to spot allocate her hours directly in the Resource
View timeline.

Simply click to select the display of Wednesday the 21st and Thursday the 22nd’s hours, which are
shown below the bar representing the task "Design" in the Assignments subrow. Change the hours for
both days from "8.00" to "4.00". Now do the same to the hours of Wednesday the 21st and Thursday
the 22nd for the "Prototype" task bar. Ann now works 4 hours on each assignment. The end result is
that her total Hourly Usage for Wednesday the 21st and Thursday the 22nd is now 8 hours.
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See also:

Working with resources 

30.56 Start

Start
The start of an activity is when it begins. You can set the start of an activity's Scheduled, Revised, and

Actual components as the start of the schedule itself.

30.57 Summary Bars

Summary Bars
Display the aggregate start, finish, and duration information for all of an activity's collapsed subactivities.

30.58 Summary Graphs

Summary Graphs

Summary graphs summarize the values currently displayed in columns over a particular period of time.
A summary graph appears as a row under the timeline graph, making it easy to match the summary
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data to the corresponding time period. Six types of summary graphs can be created: Total, Average,
Standard Deviation, Minimum, Maximum, and Count (as well as cumulative totals and counts). There
are three types of graphs: numeric, line graph, and histogram. These can be displayed in hundreds of
different styles.

30.59 Text Boxes

Text Boxes

Text boxes are graphic items that contain small chunks of text. They can be added to the Schedule
View or Print Preview windows. You can use text boxes to describe items in your schedule, to present
notes that stand out, or to create headers and footers for your schedule.

30.60 Text

     

Text tool. Draws and edits text boxes for use as labels and titles.

30.61 Timeline Graph

Timeline Graph

In the Schedule View, the timeline, or timeline graph, is the actual grid of horizontal and vertical lines
on which activity bars sit. In the Resource View, the timeline is the actual grid of horizontal and vertical
lines on which assigned activity bars and resource graphs sit. The timeline can represent any range of
time you determine, in units of hours, days, weeks, months, quarters, and years.

30.62 Timeline Units

Timeline Units
Units of time displayed in the schedule. For instance, a schedule with timeline units of weeks has one

timeline graph column for each week in the timeline graph. The base timescale row is the timescale row

that contains the labels for the timeline units. For instance, in the case above, the base timescale row is

the one that contains the week labels.
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30.63 Timescale Areas

Timescale Areas
Appear at the top and bottom of the schedule to label the units in the timeline graph. They contain one

or more timescale rows that can be formatted to display units such as hours, days, weeks, months,

quarters, fiscal quarters, years, or fiscal years.

30.64 Timescale Rows

Timescale Rows

The timescale rows act as labels for the timeline graph columns. Timescale rows can appear above
and below the timeline graph. The width of the base timescale row also determines the width of the
timeline graph columns.

30.65 The Tools

The Tools

FastTrack Schedule’s Tools group holds six tools. Unless a tool is locked, the default setting for each

tool is to revert back to the Arrow tool after use. When locked, the selected tool is locked down and can

be used multiple times.

 Arrow tool 

The general-purpose tool that selects, moves, and resizes items in all Views. When you want to drag
an activity bar, row, column or graphic item this is the tool you need to have selected.

 Bar Tool 

The Bar Tool draws activity bars in the timeline graph with a default Constrain Type of "Start On Or
After."



Glossary 393

Copyright © 2010, AEC Software, Inc. All rights reserved.

 Link Bars Tool 

Lets you draw links between bars to create dependencies.

 Revise Tool 

Changes the activity's Revised start and/or finish dates, times, and durations.

 % Complete Tool 

Defines the percent complete and Actual start, finish, and duration of an activity.

 Text Tool

Draws and edits text boxes for use as labels and titles.

Note:

Selecting a tool changes the appearance and purpose of the mouse cursor. Each tool has its own

operations and, while a tool is selected, clicking and dragging the mouse performs those operations.

30.66 Usage Graph Scale

Usage Graph Scale

A scale is available in the two Usage subrows of the Resource View. It helps you to gage when a
resource has reached full or over allocation.

To see the scale, the subrow must be sized high enough to display it.

30.67 Work Calendars

Using Work Calendars
In Fast Track Schedule there are three types of work calendars: project, activity and resource. You
assign just one work calendar to the project, but any activity can be assigned a separate work calendar
and every resource has its own work calendar. Each of these calendars is edited in the Work Calendar
dialog and each of these calendars is completely customizable.

Work calendars allow you to define typical work days and exceptional days for the project, each
resource and any activity.

Work Calendars helps you accurately track the amount of time available for work on activities. Once
Work Calendars have been defined, you can use them in several ways:
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- To display the work schedule in the Schedule View timeline by hiding and/or shading non-work times.
- To help you schedule activities during project work times only.
- To help you note assigned resources' non-work periods.

There are three key elements of the Work Calendar:  the [selected] Calendar, Typical Days, and Specific
Days.

This
element:

Does this:

[Selected]
Calendar

Determines the calendar you assign to a project, activity or
resource and from which you may build a custom calendar.
Choose from: Standard - 8 hour work days Monday -Friday, 24
Hours - 24 hour work days seven days a week, Night Shift - a
40 hour work week from 11 PM - 8 AM, and any custom
calendars you have created.

Typical
Week Day

Allows you to set up a work schedule in which each day of the
week might have different hours, for instance, a Monday might
differ from other days.

Exceptions Defines the specific days of the year that deviate from the
typical days. Each specific day can have its own set of hours or
no hours. For example, you might want to designate holidays as
exceptions. Exceptional days are listed in the Exceptions table
and can be given a descriptive name.

You can copy and paste a Work Calendar from another file if you would like to use that Work Calendar’s
arrangement.

What would you like to do?

 Define the Work Calendar

 Display the Work Calendar

 Calculate durations in work units

 Drag bars using the Work Calendar
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30.68 Work in Place

Work in Place
The same as the Actual component of an activity or the Percent Complete.
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